PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Cooling problem...

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Oct 2010, 10:16 am
Coop's Avatar
Regular Cruiser
 
Join Date: Oct 2010
Location: Chicago
Posts: 123
Send a message via Yahoo to Coop
Default Cooling problem...

So I was in terrible stop and go traffic this morning. The temp guage never got above 1/2 way, but the coolant bubbled over and starting steaming out of the motor bay...

So, is it old fluid (I was already going to do a drain and fill), did the thermostat not open up, or is it maybe the cooling fan didn't kick on??? I had to run into work and couldn't listen to see if the fan kicked on which is what I plan on doing today when I get out of work.

I drive an 01 Limited with 53K on it to let you know the age and miles on the car

thanks!
__________________
I want to go peacefully in my sleep like my grandfather did...not screaming like the rest of the passengers in his car!!!!
Reply With Quote
  #2 (permalink)  
Old 16 Oct 2010, 08:26 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: Cooling problem...

Coop, I don't think that needle goes above the almost halfway mark--even if your radiator is empty. My fan was busted and the gauge never went above that mark.

Warm up your car nice and toasty and grasp (lightly) the upper radiator hose. If the engine is hot--and the hose is not--then your thermostat is not opening ....

Tim
Reply With Quote
  #3 (permalink)  
Old 16 Oct 2010, 09:18 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Cooling problem...

I'm not sure what the problem is if the guage didn't go to HOT but I know for certain it DOES go all the way. When my fan went south in heavy traffic I watched the needle climb right towards the top before I pulled over to the side. I've also seen many members of this forum report the needle raising to the red when they were overheating.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 16 Oct 2010, 09:37 pm
garyerrol's Avatar
Cool Cruiser
 
Join Date: Nov 2007
Location: Indianapolis, IN
Posts: 288
Default Re: Cooling problem...

I can also verify that the temp gauge needle does go above the halfway mark. When i'm idling, mine goes between he halfway mark and just under three quarters, continually rising and falling until I start driving to move air through the radiator.

Bubbling over makes me think of air in your system possibly caused by a cracked head or blown head gasket. I hope it is something much simpler.
__________________
2001 LE, Shale Green, Aftermarket Wheels, Shorty Antenna, AirRaid Cold Air Intake, Whelen Talons (amber/white) in front windshield, Whelen Talons (amber) in rear side windows, Tomar RECT25's (amber) and Whelen Slimlighter(amber) in back window. Kenwood TK-880H 45 Watt Mobile Radio, Antenex 3db antenna w/ NMO mount.

http://smg.photobucket.com/albums/v7...0PT%20Cruiser/

Ham: N9PTC
GMRS: WPQS324
Reply With Quote
  #5 (permalink)  
Old 17 Oct 2010, 08:22 am
VNT's Avatar
VNT VNT is offline
Senior Cruiser
 
Join Date: Jun 2009
Location: NE
Posts: 1,466
Default Re: Cooling problem...

Doesnt any idiot light kick on once it gets to hot regardless of what the guage says??

I wouldnt continue to drive it until you get it fixed, sounds like T-stat or fan. Fans seem to be problematic on the non-Turbo
__________________
VNT

89 Shadow ES 2.5 T2 +20's A555 sold
86 TurboZ CS 2.2 T2 +20's A555
90 Daytona ES 2.5 T1 A523
90 Datyona Shelby VNT needs work
00 Durango SLT+ 5.9 4x4
02 Grand Cherokee 4.7 4x4
03 PT GT Black 5 sp Stg 1
05 PT GT Silver 5 Spd Conv
06 PT GT Cool Vanilla 5 spd Conv
06 PT Base Marine Blue 40TE Conv
15 Grand Cherokee Overland 5.7 QD2
Reply With Quote
  #6 (permalink)  
Old 19 Oct 2010, 10:04 am
Coop's Avatar
Regular Cruiser
 
Join Date: Oct 2010
Location: Chicago
Posts: 123
Send a message via Yahoo to Coop
Default Re: Cooling problem...

Well I did a drain and fill. The fluid that Chrylser had it the PT was suppose to be the neon green. Well, this fluid was a reddish green mess. Smelled like complete poop too. Looks like people just added all different brands over the years.

I installed a new thermostat since I had it drained. The thermostat looked all caked up and probably was a good move replacing it. Only problem I had is a small leak from the thermostat housing. I think when I was tighten the bolts back down I popped the gasket out of the groove. There is a little nub marker on the gasket and guessing that popped out of the groove it is suppose to sit in.

No over heating or bubbling at all. The guage acutally will sit a little below the 50% mark when I was driving it last night before noticing the small leak.
__________________
I want to go peacefully in my sleep like my grandfather did...not screaming like the rest of the passengers in his car!!!!
Reply With Quote
  #7 (permalink)  
Old 19 Oct 2010, 03:03 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Cooling problem...

It's good that the needle stays just below half way but not sure about the small leak at the thermostat. If it can leak out, it might let air in and cause problems down the line.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #8 (permalink)  
Old 19 Oct 2010, 03:50 pm
Coop's Avatar
Regular Cruiser
 
Join Date: Oct 2010
Location: Chicago
Posts: 123
Send a message via Yahoo to Coop
Default Re: Cooling problem...

I am draining the whole system again tonight when I get home from work. Going to take the thermostat housing out and make sure that gasket sits in place when I torque it down. It's a little leak. I barely noticed it until I say a little fluid on the back of the thermostat area
__________________
I want to go peacefully in my sleep like my grandfather did...not screaming like the rest of the passengers in his car!!!!
Reply With Quote
  #9 (permalink)  
Old 19 Oct 2010, 03:51 pm
Coop's Avatar
Regular Cruiser
 
Join Date: Oct 2010
Location: Chicago
Posts: 123
Send a message via Yahoo to Coop
Default Re: Cooling problem...

Next project... New belts, spark plugs and spark plug wires!!!

Looks like those projects are going to take a tad bit longer. Anyone do those to let me know what I am getting myself into???
__________________
I want to go peacefully in my sleep like my grandfather did...not screaming like the rest of the passengers in his car!!!!
Reply With Quote
  #10 (permalink)  
Old 19 Oct 2010, 05:31 pm
VNT's Avatar
VNT VNT is offline
Senior Cruiser
 
Join Date: Jun 2009
Location: NE
Posts: 1,466
Default Re: Cooling problem...

Plugs and wires are fairly easy assume the plugs arent frozen in.

I would get a good set of wires, I use the MP blue ones and stock Champion coppers. I put a little anti seize on the threads and a dab of silicone grease on boots before I put the wires on.

Per the anti feeze, the mopar color is orange Hoat G5. the afteramrket I got was yellow in bronze jug. I also use distilled water.

How is your PS fluid, get a turkey baster and suction it out and refresh it. You rack will thank you.

This is the main reason I change all fluids when I first buy a used car, you
never know what the prior owners used.
__________________
VNT

89 Shadow ES 2.5 T2 +20's A555 sold
86 TurboZ CS 2.2 T2 +20's A555
90 Daytona ES 2.5 T1 A523
90 Datyona Shelby VNT needs work
00 Durango SLT+ 5.9 4x4
02 Grand Cherokee 4.7 4x4
03 PT GT Black 5 sp Stg 1
05 PT GT Silver 5 Spd Conv
06 PT GT Cool Vanilla 5 spd Conv
06 PT Base Marine Blue 40TE Conv
15 Grand Cherokee Overland 5.7 QD2
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 pt cruiser turbo cooling fan problem PLZ help patrickjudkins General Turbo Discussions 15 27 Dec 2015 03:42 pm
Cooling fan... need help Jimmyo General PT Cruiser Discussions 4 06 Jun 2010 10:54 pm
A/C not cooling at all bigjoe1651 Tech & Performance Forum 5 10 Oct 2009 02:42 pm
Strange cooling problem shaliberty Tech & Performance Forum 13 01 Oct 2008 09:48 pm
Cooling Fan Mod AZ_IceMan Stage Turbo Kits 3 25 May 2005 04:07 am


All times are GMT -5. The time now is 07:44 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors