PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Swapped my PT, but have a new problem... ABS & TRAC OFF Lights on....

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Dec 2010, 02:18 pm
Fresh Cruiser
 
Join Date: Aug 2008
Location: Bristol, UK
Posts: 48
Default Swapped my PT, but have a new problem... ABS & TRAC OFF Lights on....

Hi folks,

Recently traded in my old PT Cruiser (00, 140k, regular re-occuring overheating problems) for a 04 2.4 litre limited, absolute bargain for it's age with only 14k miles on the clock...

It drives beautifully and feels like a new car it's been so well looked after.

We did a long drive last week to get to / from the Lake District on holiday - car was great the whole way, but we started to get a intermittent issue where the ABS and TRAC OFF lights would come on when we started the car.

First few times they went off again pretty quickly, but last night I was driving back from London and it came on and didn't go off again for 100+ miles. The car itself is braking and holding the road pretty well, but just wondering if anyone has any thoughts?

The car is warrantied from the seller for a year - but they are 90 miles away so would prefer to only utilise the warranty if it's a big issue...

Thanks guys,

Steve
Reply With Quote
  #2 (permalink)  
Old 05 Dec 2010, 02:31 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default Re: Swapped my PT, but have a new problem... ABS & TRAC OFF Lights on....

Usually when I here of your problem it's one of the sensors at the wheel that has gone bad and there's no easy way for you to tell which one. Pick a nice day and go for a ride since it's under warranty.

That's the fault for getting a deal on a car that's far away. It's an 04 so I take it that it's a dealer only warranty and not Chrysler. If Chrysler, you could go to any dealer.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 05 Dec 2010, 02:33 pm
Fresh Cruiser
 
Join Date: Aug 2008
Location: Bristol, UK
Posts: 48
Default Re: Swapped my PT, but have a new problem... ABS & TRAC OFF Lights on....

Hey,

thanks for the quick response.
Yeah it's a dealer warranty - but they've just replied to the email and said I can go to a local shop and bill them for the repair which is great. Are the sensors normally an expensive part?

Should I be safe driving it for a few days whilst I get it into the shop?

Steve

Quote:
Originally Posted by CREWZIN View Post
Usually when I here of your problem it's one of the sensors at the wheel that has gone bad and there's no easy way for you to tell which one. Pick a nice day and go for a ride since it's under warranty.

That's the fault for getting a deal on a car that's far away. It's an 04 so I take it that it's a dealer only warranty and not Chrysler. If Chrysler, you could go to any dealer.
Reply With Quote
  #4 (permalink)  
Old 05 Dec 2010, 02:44 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default Re: Swapped my PT, but have a new problem... ABS & TRAC OFF Lights on....

I'm not a mechanic. Never bought a sensor (if it IS the sensor) and since you DON'T have ABS or Traction Control when the lights are lit, I'd take it in ASAP.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 14 Dec 2010, 10:33 am
Fresh Cruiser
 
Join Date: Aug 2008
Location: Bristol, UK
Posts: 48
Default Re: Swapped my PT, but have a new problem... ABS & TRAC OFF Lights on....

Hi folks,

Hoping for some pointers.
My PT went into a local shop today - they've struggled to find the cause of the ABS light being on. They've:

1) Checked for fault codes (none found)

2) Checked the physical condition of the ABS Rings (all seem undamaged)

3) Checked the condition of the sensors - again no sign of visible problems

The mechanic who worked on the car said that the sensors would normally trigger a fault code, as would a wiring/circuit problem.
He's really reluctant at this stage to swap any parts out.

Anyone have any clever suggestions on how to narrow down the cause of this problem?

Thanks,
Steve
Reply With Quote
  #6 (permalink)  
Old 14 Dec 2010, 12:08 pm
Fresh Cruiser
 
Join Date: Aug 2008
Location: Bristol, UK
Posts: 48
Default Re: Swapped my PT, but have a new problem... ABS & TRAC OFF Lights on....

Spoke to a friend with a PT who suggested that the fault codes not showing up on the car display is not necessarily a sign that there are no faults for the ABS system stored... does that sound plausible?

Annoyingly the only place locally with a DRB3 scanner for Chrysler is Chrysler so may have to swallow an expensive bill to have it scanned...
Reply With Quote
  #7 (permalink)  
Old 14 Dec 2010, 12:36 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default Re: Swapped my PT, but have a new problem... ABS & TRAC OFF Lights on....

We were once told by a Master Certified Mechanic that owned his own shop that the fault codes only show a percentage of things that can go wrong so your friend is right and there can be problems that don't show up on the fault light system.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #8 (permalink)  
Old 16 Dec 2010, 08:27 am
Fresh Cruiser
 
Join Date: Aug 2008
Location: Bristol, UK
Posts: 48
Default Re: Swapped my PT, but have a new problem... ABS & TRAC OFF Lights on....

Sure enough the standard scanners saw no fault, but 2 mins connected to a Chrysler DRB3 scanner and they identified the left side ABS Sensor was faulty.

Part on order, should be all sorted Monday.

thanks for all the advice guys.

Steve
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lights Problem KKReimer Tech & Performance Forum 0 26 Aug 2010 09:12 am
2006 GT - Swapped Engine Vaccum Hose problem wendelltu General Turbo Discussions 8 12 Aug 2010 05:12 am
Map light problem + new lights slayerdarkcross Interior Accessories Forum 5 11 Dec 2008 12:04 am
swapped my wheels REDanan Turbo Wheels/Suspension/Handling 10 25 Oct 2007 11:13 am
Problem with fog lights TaylorMade General PT Cruiser Discussions 6 13 May 2004 07:41 am


All times are GMT -5. The time now is 08:15 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors