PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Speedometer jumping, fobs not working

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Dec 2010, 08:44 pm
Fresh Cruiser
 
Join Date: Jan 2008
Posts: 24
Default Speedometer jumping, fobs not working

OK, it's been cold, in the teens here lately and I'm not sure if this is weather related or not, but it all started happening at the same time.

The fob wouldn't unlock my door. I unlocked it with the key, and when I tried to start it, the car hesitated and the speedometer was jumping all over the place before the car started. It happened again the next day, but didn't start. I turned off the key then I tried it again and it started right up. So, I'm not sure if it's the cold temps or if something's going on with my car that's deactivated my fobs and causes the speedometer to go nuts.

Any ideas?
Reply With Quote
  #2 (permalink)  
Old 07 Dec 2010, 09:06 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default Re: Speedometer jumping, fobs not working

A weak battery causes all kinds of things to go bad.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 07 Dec 2010, 09:41 pm
Fresh Cruiser
 
Join Date: Jan 2008
Posts: 24
Default Re: Speedometer jumping, fobs not working

The battery's a little over 2 years old. The last one lasted at least 6 years.
(It's a 2002) You think it could be the battery already? Do they go bad faster in colder climes? (We moved north from Louisiana)
Reply With Quote
  #4 (permalink)  
Old 07 Dec 2010, 09:46 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default Re: Speedometer jumping, fobs not working

Cold does take it's toll on a battery. No harm in checking it out.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 07 Dec 2010, 10:02 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: Speedometer jumping, fobs not working

My 2003 Limited did the same thing--and the replacement battery was only a couple of years old. Corrosion at the battery cables, was my problem. My PT is a notorious corroder ....

The battery cable connectors were so bad off that I had to have them replaced (actually, the whole wiring harness), then I could unlock my locks with the fob, and the needles didn't dance, and the car would start.

Do as Crewzin says and check out the battery (even if it's new), and check the battery cables, too. Clean them with a suitable battery-cleaning tool (they're cheap). Then after connecting the cables back to the battery, spray the battery posts and cable ends with CRC Battery protector (it's the only stuff I've found that really works).

Good luck,

Tim
Reply With Quote
  #6 (permalink)  
Old 07 Dec 2010, 10:15 pm
Fresh Cruiser
 
Join Date: Jan 2008
Posts: 24
Default Re: Speedometer jumping, fobs not working

Thanks again. I'll have the battery checked. Just cleaned what amounted to very little corrosion off the cable connectors less than a month ago.
Reply With Quote
  #7 (permalink)  
Old 08 Dec 2010, 07:10 pm
Fresh Cruiser
 
Join Date: Jan 2008
Posts: 24
Default Re: Speedometer jumping, fobs not working

Update....my battery was bad. Had it replaced. So far, the speedometer's not jumping around but my fobs still don't work. It's going down to 9 tonight, so, I'll see what happens in the morning.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer and tach jumping worldtv Tech & Performance Forum 15 07 Apr 2014 05:05 pm
NEW BUYER QUESTION: JUMPING A PT CRUISER? Tazorac General PT Cruiser Discussions 1 12 Apr 2010 10:05 pm
2006 PT - Speedometer AND Odometer not working SweepTheLeg Tech & Performance Forum 8 04 Sep 2009 04:33 pm
Keys & Fobs ejstith General PT Cruiser Discussions 1 30 Aug 2009 10:57 am
Jumping PT suspension ?? Ctown Turbo Wheels/Suspension/Handling 7 24 Apr 2005 06:38 pm


All times are GMT -5. The time now is 12:29 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors