PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
All Electricity gone - Jump start fails also

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Dec 2010, 03:39 pm
Fresh Cruiser
 
Join Date: Dec 2010
Posts: 8
Default All Electricity gone - Jump start fails also

Hi:

I used the PT (2.2 CRD 40.000 miles, manual shifter) a few hours ago and no problems at all. Left it in my front door and then when tried to use it I noticed no electrical power because remote of the doors did not work. Opened it and when key inserted there is absolutely no lights or clicks or NADA inside (dashboard dead).

I tried to jump start it with my other carīs battery and the only thing that happened is that cables got smoking and lots of heat was generating.

Any ideas? Can it be a short INSIDE the battery?

Measuring with a multimeter the PT battery reads 0 Volt. The other car one 13 Volt, so I think the multimeter is fine and Iīm doing it correctly.
Reply With Quote
  #2 (permalink)  
Old 08 Dec 2010, 03:53 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default Re: All Electricity gone - Jump start fails also

We don't have your diesel engine in the U.S. but that shouldn't matter with your problem. It sounds like your battery went completely dead. Don't know why but if your not getting any reading from it, even a jump start won't help. I'd take it completely out and run it over to a shop that will fully check it out.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 08 Dec 2010, 04:36 pm
Fresh Cruiser
 
Join Date: Dec 2010
Posts: 8
Default Re: All Electricity gone - Jump start fails also

Thanks a lot. I will try to do it indeed. I was thinking about getting a new battery and just try to get it going. Can I burn a new battery if thereīs something wrong with the car?

Thanks again,

JP
Reply With Quote
  #4 (permalink)  
Old 08 Dec 2010, 05:29 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: All Electricity gone - Jump start fails also

YES btu most likely you wont unless there is like a DEAD SHORT someplace
Reply With Quote
  #5 (permalink)  
Old 08 Dec 2010, 05:45 pm
Fresh Cruiser
 
Join Date: Dec 2010
Posts: 8
Default Re: All Electricity gone - Jump start fails also

And can I check for dead shorts in some quick manner? What I´m trying to avoid is taking the PT to the mechanic. Here in Europe PTs are kind of strange stuff and I´m afraid of them inventing problems...
Reply With Quote
  #6 (permalink)  
Old 08 Dec 2010, 06:18 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default Re: All Electricity gone - Jump start fails also

If you have another vehicle you don't have to take the whole car in. Take the battery out and have them check it off the car. You need specialized equipment to do the tests I believe. If not, I'm not sure how you can do it yourself.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply

Tags
electricity


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine fails after Spark Plugs and Wires installation Pt_Magnesium Tech & Performance Forum 6 21 Aug 2010 04:05 pm
Jump Starting Issues myptc Tech & Performance Forum 3 22 Mar 2010 04:52 pm
Door lock problem after dead battery/jump start Mal Interior Accessories Forum 1 11 Jun 2009 09:32 pm
What happens when timing belt fails? lbullis Tech & Performance Forum 4 19 Jan 2009 05:28 pm
static electricity bluzcruz General PT Cruiser Discussions 12 31 Oct 2004 03:12 pm


All times are GMT -5. The time now is 08:59 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors