PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Dead Instrument Cluster

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Jan 2011, 10:16 pm
Fresh Cruiser
 
Join Date: Jan 2011
Posts: 3
Default Dead Instrument Cluster

After having the battery replaced on my 2001 PT Cruiser, the dash lights and gauges no longer work. Everything else is fine (horn, power locks, radio, sunroof, headlights, wipers, etc.) but the dash lights are out, the speedo, odo, tach, gas, temp gauges are dead. No door chimes, no dome light, but the map lights works. The shop that replaced the battery checked all the fuses and claims it is nothing they did and that I should take it to the dealer and get the cluster replaced $$$. Anyone have any ideas or suggestions.

Thanks.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument cluster lamps Nickatnite General PT Cruiser Discussions 6 06 Feb 2013 08:02 pm
Instrument cluster goes dead kwells44 Tech & Performance Forum 5 02 Dec 2012 06:08 pm
Instrument Cluster Lights kappa_kruiser Tech & Performance Forum 1 22 May 2008 01:03 am
02' Instrument Gauge Cluster CHROMEDCRUISER Classifieds: For Sale/Trade 0 15 May 2006 06:27 pm
Instrument Cluster needed PTloser Classifieds: For Sale/Trade 0 23 Jul 2002 06:42 pm


All times are GMT -5. The time now is 12:52 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors