PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
03 CRUISER man im lost

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 Feb 2011, 09:52 am
Fresh Cruiser
 
Join Date: Feb 2011
Posts: 1
Default 03 CRUISER man im lost

whenever its below 20 degrees in virginia my cruiser struggles to start,and once it starts man does it shake.once i get going she does fine however when i slow down at a stop light she gets to hiccupping.replaced wires and plugs about 10k ago and just finished doing the water pump timing belt job,because of pump failure.possible cts switch? no codes..help me !!!
Reply With Quote
  #2 (permalink)  
Old 06 Feb 2011, 11:47 am
VNT's Avatar
VNT VNT is offline
Senior Cruiser
 
Join Date: Jun 2009
Location: NE
Posts: 1,468
Default Re: 03 CRUISER man im lost

Remove Throttle body and clean it and the IAC motor.

These cost nothing and should be done on a yearly basis.

What kind of plugs and gap?

No codes??

How many miles on car and what engine?
__________________
VNT

86 TurboZ CS 2.2 T2 +20's A555
00 Durango SLT+ 5.9 4x4
02 Grand Cherokee 4.7 4x4
03 PT GT Black 5 sp Stg 1 sold
05 PT GT Silver 5 Spd Conv
06 PT GT Cool Vanilla 5 spd Conv
06 PT Base Marine Blue 40TE Conv
15 Grand Cherokee Overland 5.7 QD2
17 Challenger SRT A8 GoMango
18 JL Wrangler Sahara Punkn
20 JL Wrangler Rubicon Ocean Blue
Reply With Quote
  #3 (permalink)  
Old 06 Feb 2011, 12:16 pm
Banned
 
Join Date: Sep 2009
Location: south of Tampa, Florida
Posts: 3,037
Default Re: 03 CRUISER man im lost

1. Change your plugs and wires. As to plugs, Champion coppers gapped at 40 should be fine for you. Use practically any wires EXCEPT factory standard ones. The "blue" high performance factories are a good substitute. MSD is good. Crane is good, if you can find some still in stock somewhere. Taylor is good. Granitelli is good, in short almost any HP wire is better than stock.

Next, and probably most important is with those temps, use 0w30 or even 0w20 during the winter. This is a common practice amoung the northern pt owners. Word about this change got around over at "The Crew" years ago.

If you have "some" miles on your PT then you should, as has been said, also clean your TB (throttle body) and the IAC (idle air control). If you've got a lot of miles on your PT, I would change out the upstream 02 sensor while I was at it. Changing the sensor on high milage PTs also will help bring back your mpg to a more "happy" range.

Jerry
Reply With Quote
  #4 (permalink)  
Old 06 Feb 2011, 12:24 pm
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: 03 CRUISER man im lost

While I agree with the above, most of those instructions are for the NA version, if you have a turbo some of those work, some don't.

What does work in all cases is that you also need to look at your fuel treatment, regardless of engine type. I suggest you run some sta-bil in your next tank, but make sure you are driving after you drop it in, don't load it up and then let it sit. You need to at least spend a half hour moving around once you put it in your gas tank. The other issue is, if you do have any water in your fuel, you may be getting an intermittent ice clog at your fuel filter. There are a few ways around that but replacing it is the best idea.

Also, ditto on what wwpptc says, however, before you change your oil, put a half can of seafoam in the oil and the other half in your gas tank. Run that puppy until she's good and hot, at least a half hour. Then go immediately get your oil changed. Make darned sure they replace the filter!!!! Between this and the gas prep, you may cure your problems.

Just my suggestions for a car with tough start ups.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost acceleration PT_or_not_PT General Turbo Discussions 13 28 Oct 2010 02:06 am
lost all car key outdoorbloke General PT Cruiser Discussions 8 15 Dec 2007 03:02 pm
New and Lost fy9-03pt General Turbo Discussions 1 26 Apr 2003 07:02 pm


All times are GMT -5. The time now is 04:25 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors