PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
compass and outside temp

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Feb 2011, 10:41 am
Fresh Cruiser
 
Join Date: Feb 2011
Posts: 18
Default compass and outside temp

I've read thru just about every posting on this topic and still haven't found a definite answer. My problem is 2 parts

1st, outside temp reads -10F all the time. I disconnected the sensor and it reads -49f and if I jumper the wires it reads 140f. I tried a known good sensor and same results -10f. I measured resistance of sensor and it is right on for temp. I then heated the sensors with a hair drier and no change on the display.
2nd. Compass only shows direction of where ever the vehicle was when it was started. IE, my garage faces NE. That's what the compass says all the way to work driving south. then I start my car up at work which is facing west in the parking lot, the compass reads W all the way home as I drive north. I've done the calibration proceedure numerous times. I do not have any aftermarket stuff in the car that would crate magnetic interference.
Reply With Quote
  #2 (permalink)  
Old 08 Feb 2011, 12:29 pm
meder2487's Avatar
Regular Cruiser
 
Join Date: Oct 2010
Location: Freedom, PA
Posts: 130
Default Re: compass and outside temp

That may be a bad control module. I have never replaced one of these in a PT but I have in a Town and Country minivan. The fuel mileage and temp readings were off in the van and it turned out the controller, which was located behind the drivers side kick panel had gone bad. I do not know the location of the module on the PT. But it may be worth trying to find it and see if it is functioning.
__________________
Don't Blink
Reply With Quote
  #3 (permalink)  
Old 09 Feb 2011, 07:30 pm
Fresh Cruiser
 
Join Date: Feb 2011
Posts: 18
Default Re: compass and outside temp

All of a sudden the compass started working correctly , but the temp is still stuck on -10F. Again, I unplug the sensor and get -49F on the display and when I jumper the 2 leads for the sensor with a paperclip, I get 140F. But with any sensor plugged in, it always reads -10F. I even heated the sensor with a hair drier and no change to the display output.
Reply With Quote
  #4 (permalink)  
Old 09 Feb 2011, 07:52 pm
BladeRunner's Avatar
Cool Cruiser
 
Join Date: Nov 2010
Location: Innisfil Ontario Canada
Posts: 372
Default Re: compass and outside temp

You don't say what yr you have,but, it probably will be the same. It sounds kinda like the sensor is toast. But, because the compass started working again..maybe because you have been moving the wires around. It could be as simple as bad connections. I have an '01 I got last Oct. I needed to replace 3 bulbs in my dash cluster. I did all six and 3 still wouldn't light. I took the PDC ( power distribution center) under the hood apart. Under the bottom I found several "green" connections..corrosion After I cleaned and greased every connector all the dash lights were good. So, that might be a place to consider checking.
BTW, I have an '01 Caravan...very similar to the PT as far as electrics go, my outside temp display went nuts one day....very high temps..and it wasn't that hot outside.
Turns out the sensor has a plastic part that screws onto the center support in front of the rad...well that mount broke away somehow and the sensor was sitting against the rad. I ty wrapped it back in place and it's been fine ever since.
Reply With Quote
  #5 (permalink)  
Old 09 Feb 2011, 10:27 pm
Fresh Cruiser
 
Join Date: Feb 2011
Posts: 18
Default Re: compass and outside temp

yes, it's an 01. I said that I tried different sensors (using a known good sensor). Infact I put the PT sensor into minivan and it worked perfectly and I put the minivan sensor into the PT and same results -10F
Reply With Quote
  #6 (permalink)  
Old 10 Feb 2011, 04:37 pm
BladeRunner's Avatar
Cool Cruiser
 
Join Date: Nov 2010
Location: Innisfil Ontario Canada
Posts: 372
Default Re: compass and outside temp

Just for grins...take a look @ those connections under the PDC..you may be surprised what you find.
Reply With Quote
  #7 (permalink)  
Old 11 Feb 2011, 09:39 am
Fresh Cruiser
 
Join Date: Feb 2011
Posts: 18
Default Re: compass and outside temp

I did that and everything looks like brand new. Just seems wierd that everything checks out fine, (sensor Ohm's correct and tried a known good one, unplug sensor and -49F is correct for open circuit, 140F with jumper wire also correct). Weird that with any sensor plugged in it reads -10F. Inside my garge it's 60F and outside it was 12. with the car inside or out, no change in temp at all. When I heat up the sensor with a hair drier, no change on the display, yet the sensor(s) changed resistance which should have shown a change on the display... Yet still stuck at -10F
Reply With Quote
  #8 (permalink)  
Old 11 Feb 2011, 03:44 pm
Regular Cruiser
 
Join Date: Jan 2010
Posts: 157
Default Re: compass and outside temp

I would change the connector. It must not be making good contact with the sensor. Why it reads -10 and not -49 is the strange part.
Reply With Quote
  #9 (permalink)  
Old 11 Feb 2011, 04:35 pm
Fresh Cruiser
 
Join Date: Feb 2011
Posts: 18
Default Re: compass and outside temp

I back probed the wires with a potentiometer in the resistance range the temp sensors work off. Before I connected the Potentiometer, I have -49F (open circuit) I connect the Pot. and it reads -10F, I turned the pot. and thru the entire reistance range, the temp is stuck at -10F. The only way my outside temp display changes is when I open the circuit (-49F) or short the circuit (140F). To summarize, no sensor -49, with ANY sensor or resistance -10 with a shorted circuit 140. NO other number ever shows up other than those 3 I've listed.
Reply With Quote
  #10 (permalink)  
Old 20 Feb 2011, 09:44 pm
Fresh Cruiser
 
Join Date: Feb 2011
Posts: 18
Default Re: compass and outside temp

This thing is driving me nuts. Now the temp works fine but the compass is stuck. I drove 30 miles due north and the compass never changed from WEST. WTF
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ambient temp &compass C300392 Interior Accessories Forum 6 06 Dec 2010 04:11 pm
Is it possible to activate compass? 66CUDA Tech & Performance Forum 3 15 Jun 2009 08:00 am
compass/outside temp reading bandbpt General PT Cruiser Discussions 6 05 Jun 2008 03:36 pm
Compass and Temp aftermarket? neps Interior Accessories Forum 28 30 May 2004 10:14 pm
Overhead Compass/Temp too Dim - Try This Dalite Tech & Performance Forum 11 01 Jul 2003 10:42 pm


All times are GMT -5. The time now is 08:56 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors