PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Fuel Gage And Sending Unit Problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Apr 2011, 09:39 am
Fresh Cruiser
 
Join Date: Nov 2005
Location: Ontario Canada
Posts: 10
Unhappy Fuel Gage And Sending Unit Problems

Hoping for some direction on the my fuel gage problems - Gage has been "stuck" at low fuel reading with the low fuel light on, even with a full tank of gas. looked in forums and it appears to lead to a fuel sending unit problem - I did the self-check on the instrument panel and all gages worked fine. I took to Chrysler dealer and discussed with service advisor - indicated that fuel sender most likely faulty and needed replacing - One ordered and replaced in the tank at $120 and 2 hr labour = $300.00. This did not fix the fuel gage reading - it did briefly get to 1/4 tank reading at a full tank, but is back to original problem sitting at low fuel reading - The dealer is going to look at problem again - I am concerned that they will be looking to replace the gage cluster?? Is there any suggestions and idea on what to look at: ie loose ground wires, etc that I could do first

Thanks and appreciate everyone's insight

2005 PT Conv Inferno Red - turbo lite- 30000 KM

UPDATE: Went back to dealer - indicates that the gage cluster is OK - now suspects that there is a wiring problem from sending unit but will need to remove tank again to investigate - would have thought that they would check out wiring etc prior to replacing sending unit?? Need to run out tank of gas first and I will report back ------ any ideas??

Last edited by 05RAGTOP; 19 Apr 2011 at 02:41 pm. Reason: update on issue
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure Sending Unit DEEGO Tech & Performance Forum 20 22 Feb 2016 06:24 pm
fuel level sending unit dbcruiser General PT Cruiser Discussions 2 13 Aug 2010 12:17 pm
How do you know if it's a bad pump or sending unit? scrisp2 Tech & Performance Forum 4 18 Nov 2008 08:44 pm
Oil pressure sending unit littleblueGT Turbo Performance 3 27 Oct 2004 02:44 pm
Oil Sending Unit rockycruiser General Turbo Discussions 9 15 Oct 2003 11:30 am


All times are GMT -5. The time now is 05:57 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors