PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Hello, please help. My '06 is having strange dash problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Apr 2011, 11:46 am
Fresh Cruiser
 
Join Date: Apr 2011
Posts: 1
Question Hello, please help. My '06 is having strange dash problems

I have an '06 PT Touring edition. It has 66,000 miles on it. I have had the car for about 2 years now and have had no problems what so ever with this car. I love this car, and I just want it fixed.

Here is what has happened:

About 3 weeks ago I was rear ended on my way to work. Minor damage, and I kept driving it to work until I could get it to the shop.
A week later when I went to leave work the car started acting really strange. Started the car and all the dash lights came on, including one light I had never seen before which is this small red dot (which I have started calling the red dot of doom). The headlights, brake lights, and turn signals still worked but there was no noise when you turned the signal on. The odometer and spedometer also would not work. We drove the car about half way home and stoped at my sisters house because it was closer. I tried to look up and see if it was a fuse issue and I couldn't find anything. When we went back out to the car and tried to unlock it the alarm started going off. I managed to get it to turn off after putting the key in and turning it half way. The car started and we drove it home and parked in the drive way. The lights internally would not turn off, so we took anything valuble out of the car and left it unlocked incase the alarm wanted to act up again. The next morning it was dead.
Had it towed and the body shop that was doing the repairs fixed the car and told my insurance it was fine. Spoke to the shop and they said it was still acting weird. They did fix a wire that had been messed up on the reverse light after we were hit. So I drove it and it did the same thing a few days later. I took it to a mechanical shop and he can't figure out what it is. He said he pulled 21 codes and can't figure out what's going on, he's had the car for about 4 days now and he can't get it to act up. I trust him because he's good family and has been my reliable mechanic since I started driving. He has no idea what's going on and I'm at my wits end.

I love my car and I just want it working again. If anyone has any ideas or good advise, maybe someone else who's had this problem and had it fixed could tell me what they did and what it cost I would appreciate it so much.

-Jennifer
Reply With Quote
  #2 (permalink)  
Old 11 Apr 2011, 03:20 pm
Cool Cruiser
 
Join Date: Sep 2009
Location: Formerly NawLins
Posts: 246
Default Re: Hello, please help. My '06 is having strange dash problems

Sounds like the months of problems my kid had with her 01 after a rearender. There are lock sensors in the doors, at least the front doors and the rear hatch. They were damaged possible by the accident but probably by the repair technician .... surely for the door sensor since it was not hit directly and barely touched by the fender being pushed into it by the car she was pushed into.

Make sure this is all fixed or you will be resubmitting claims to the insurer, cost over $400 to get it all fixed and much time ... do it while they are renting you a car.
__________________

12 Regal Turbo
06 PT - Base with BLING! TRADED 5/27/13
01 PT LE - Kid's Car - TRADED 01/13
01 Beetle Sport - SilverSport - 150+ MPH
93 Del Sol - 32+ MPG
90 F150
73 Mach1
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash light problems Congturbo2005 Tech & Performance Forum 2 12 Apr 2011 08:50 am
Problems with Tail & Dash lights calabris General PT Cruiser Discussions 1 26 Jan 2011 12:05 pm
Strange Noise wedge22 Tech & Performance Forum 2 17 Jun 2009 12:42 pm
Strange problem... ado63 Tech & Performance Forum 5 10 Sep 2008 03:16 pm
My GT overheated. Very strange. coolvirus General Turbo Discussions 12 17 Jul 2007 12:08 pm


All times are GMT -5. The time now is 04:24 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors