PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Rear Wiper issues

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Apr 2011, 11:55 am
Fresh Cruiser
 
Join Date: Apr 2011
Posts: 3
Default Rear Wiper issues

I just picked up a 2004 PT Cruiser Limited Turbo and the rear wiper will work but sometimes either goes to far in either direction down onto the body, sometimes hanging almost straight down. Other time's it'll just go maybe half way across the window and then not all the way back.

Is this likely a dying motor, a loose nut, or is it somehow stripped possibly? Any ideas to help troubleshoot or if you've seen this before would be appreciated.
Reply With Quote
  #2 (permalink)  
Old 12 Apr 2011, 12:23 pm
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Rear Wiper issues

Oops, thought maybe you were discussing Charmin here....

Reply With Quote
  #3 (permalink)  
Old 12 Apr 2011, 12:28 pm
Fresh Cruiser
 
Join Date: Apr 2011
Posts: 3
Default Re: Rear Wiper issues

LOL yea looks like they're having rear wiper issues too.
Reply With Quote
  #4 (permalink)  
Old 12 Apr 2011, 03:44 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: Rear Wiper issues

Either it is stripped or the wiper nut could be loose.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 13 Apr 2011, 07:47 am
Fresh Cruiser
 
Join Date: Apr 2011
Posts: 3
Default Re: Rear Wiper issues

I took it off last night when I got home and it appears that the wiper arm is completely stripped as there are no teeth at all in it, albeit I've never seen one so I can't be positive what it should look like. I cleaned the teeth on the motor shaft out so they weren't filled with plastic and reattached the arm and it seems to be working right now although I don't think it'll hold for long but it's working for the time being at least.

Thank you.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear Wiper issues PTCMIAH62 General PT Cruiser Discussions 16 23 Apr 2011 11:04 am
Rear wiper Balljoint General PT Cruiser Discussions 6 01 Jul 2010 09:06 am
rear wiper motor fritz01 General PT Cruiser Discussions 1 08 Jan 2010 10:16 am
rear wiper DiesAl General PT Cruiser Discussions 1 23 Dec 2009 11:22 am
Rear Wiper MOD Gary04GT Exterior Accessories Forum 4 23 Feb 2004 02:11 am


All times are GMT -5. The time now is 01:37 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors