PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Need some help with a few issues!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Apr 2011, 03:55 pm
Fresh Cruiser
 
Join Date: Apr 2011
Posts: 11
Default Need some help with a few issues!

Hey everyone, I love my PT but I have a couple issues I need help with. Ive been a lurker here for a while but I decided I need some help from those that know the PT the best!

First off I have a 2005 Black PT, Manual Transmission, 120k. Oil change every 3k with a syn-blend.

My first issue is that a while back I scraped a steep driveway and split my lower air dam. For the longest time it was just there one side hanging about 3 inches from the ground. it became a big eye sore and i decided to go ahead and remove it. I was fine with this until while lurking around i found out that this peice of plastic served a purpose! I have never had any overheating issues with it absent or broken (knock on wood). Does anyone know of a DIY solution to replace it or of salvage yard in SOCAL where I can replace this part? Cheap place to get it? Anything! lol Heres a pic of the part im looking for.



My second issue is my oil light! It will come and go as it chooses!Ill check my levels and they'll be fine but the light will come on. It is very random.

My third issue is that occasionally when starting my car it will lose power at about 1000rpms. It will continue to lose power until I reengage the parking brake and start it again. I dont think it is the battery as i dont lose my radio or settings. How weird is that!? This happens mostly when starting the car but sometimes happens when coming to a stop? Any ideas?

Lastly,
My PT has been making this faint clicking/jingling sort of noise when accelerating. It isnt extremely loud but it doesnt sound lke it should be there. Ive uploaded a video that shows the noise. I really appreciate all the help everyone!

[youtube]

Last edited by dcsocal; 13 Apr 2011 at 05:57 pm. Reason: fixed video
Reply With Quote
  #2 (permalink)  
Old 13 Apr 2011, 04:40 pm
Excoastie's Avatar
Regular Cruiser
 
Join Date: Apr 2011
Location: Bossier City, LA
Posts: 192
Default Re: Need some help with a few issues!

hello and welcome to the forums.

I can't help you much with your first issue, sorry about that, but I'm sure someone will be along shortly who can.

Now I'm no expert, but it sounds to me like your oil sending unit is going out for your second issue. I know there are a few threads on here about replacing it, again I'm sure that someone who's more knowledgable than I will chime in

You're third issue is quite the puzzler. I'm guessing here, but it sounds like some sort of short to me. Perhaps in your ignition or fuel injection system. I wouldn't even begin to know where to look to fix that one.

good luck, and keep us posted on your progress

Exco
__________________
I tend to ramble and repeat myself, please try to over look my ignorance.


Bill
Reply With Quote
  #3 (permalink)  
Old 13 Apr 2011, 04:44 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Need some help with a few issues!

Welcome to the forum.

1. Have you tried just buying a new one from the dealer. If you don't know how much it is, how do you if you find a cheap one if you can. it's easy enough to take off. I do it about every other month because I covered it with chrome and I hit something with it and have to take it off to reshape it. Call the dealer. It's called an AIR DAM, part number 5288 792AA

2. You probably have to change the oil sender. It happen to owners all the time.
time.


3. Not sure why it's dyeing on you but just because you don't loose your pre-set radio stations doesn't mean it's not that. I take my negative battery cable off for 5 minutes every once in awhile and when everything is back together, the stations are still set.

4. As far as the noise, that U-tube video made me sick looking at it. The only only noise I heard sounding like somebody wrinkling up tin foil.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.

Last edited by CREWZIN; 13 Apr 2011 at 04:47 pm.
Reply With Quote
  #4 (permalink)  
Old 13 Apr 2011, 05:17 pm
Fresh Cruiser
 
Join Date: Apr 2011
Posts: 11
Default Re: Need some help with a few issues!

Quote:
Originally Posted by CREWZIN View Post
Welcome to the forum.

1. Have you tried just buying a new one from the dealer. If you don't know how much it is, how do you if you find a cheap one if you can. it's easy enough to take off. I do it about every other month because I covered it with chrome and I hit something with it and have to take it off to reshape it. Call the dealer. It's called an AIR DAM, part number 5288 792AA

2. You probably have to change the oil sender. It happen to owners all the time.
time.


3. Not sure why it's dyeing on you but just because you don't loose your pre-set radio stations doesn't mean it's not that. I take my negative battery cable off for 5 minutes every once in awhile and when everything is back together, the stations are still set.

4. As far as the noise, that U-tube video made me sick looking at it. The only only noise I heard sounding like somebody wrinkling up tin foil.
On the youtube video please make sure to skip to 2:00 to hear the noise. I couldnt figure out how to clip the video. From 2:00 on you can hear it.
Reply With Quote
  #5 (permalink)  
Old 13 Apr 2011, 05:23 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Need some help with a few issues!

Nope. Tried it twice and maybe it's my computer but it doesn't give my any time hacks so the first time I sat there through the whole shaky thing. Sorry, not doing that again. Just had pizza and want to keep it.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #6 (permalink)  
Old 13 Apr 2011, 05:40 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: Need some help with a few issues!

Quote:
Originally Posted by CREWZIN View Post
Nope. Tried it twice and maybe it's my computer but it doesn't give my any time hacks so the first time I sat there through the whole shaky thing. Sorry, not doing that again. Just had pizza and want to keep it.

Are you Seasick, Carey???
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #7 (permalink)  
Old 13 Apr 2011, 05:47 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Need some help with a few issues!

Quote:
Originally Posted by Hooligan View Post
Are you Seasick, Carey???

Me, seasick? An old Retired Navy geek with 11 months of ocean blue under these legs? Almost! Did you look at whole video?
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #8 (permalink)  
Old 13 Apr 2011, 05:58 pm
Fresh Cruiser
 
Join Date: Apr 2011
Posts: 11
Default Re: Need some help with a few issues!

Quote:
Originally Posted by CREWZIN View Post
Me, seasick? An old Retired Navy geek with 11 months of ocean blue under these legs? Almost! Did you look at whole video?
I shortened the video just for you ! I really appreciate the help! i edited the original post with the new video!

Last edited by dcsocal; 13 Apr 2011 at 05:58 pm. Reason: no more blair witch project video
Reply With Quote
  #9 (permalink)  
Old 13 Apr 2011, 06:17 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Need some help with a few issues!

I appreciate your efforts but it still doesn't sound like anything familiar. Clicking/jingling could be a number of things. Did you stand in front of the engine with the hood up and listen for the noise? Maybe you can pinpoint where it's coming from or even see something that could lead you to what's making the noise.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #10 (permalink)  
Old 13 Apr 2011, 06:55 pm
Senior Cruiser
 
Join Date: Nov 2010
Location: oak creek, wi
Posts: 1,149
Default Re: Need some help with a few issues!

as far as your first issue, i priced an air dam from a dealer here in wisconsin and was quoted $41.75 + tax. and, they amended the part number to ab instead of aa after the number. shouldn't matter.

rockauto has it for $13.71 but for some reason they wanted $62 shipping added on. don't understand that at all.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PCM issues I Think ??? Okuma Tech & Performance Forum 4 01 Mar 2011 05:05 pm
A/C issues... usmcwifey Tech & Performance Forum 8 07 Apr 2010 07:36 am
speaker issues, wattage of stereo, door speaker replacement issues fabes89 General PT Cruiser Discussions 9 02 Jun 2009 10:59 am
2 Issues - Need Help 07PTSilver General PT Cruiser Discussions 2 09 Dec 2008 03:45 pm


All times are GMT -5. The time now is 07:04 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors