PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Has this gone bad?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 Apr 2011, 06:26 am
Regular Cruiser
 
Join Date: May 2010
Posts: 131
Default Has this gone bad?

Please take a look at these pictures. Has that part gone bad? Is that part of the control arm? The reason I ask is because if you hit your brakes going down hill there is a loud rattling sound coming from the front left wheel area. I checked and nothing seems loose but I wasn't too sure about the part in the picture. Is it just from being jacked up? Thanks.



Reply With Quote
  #2 (permalink)  
Old 27 Apr 2011, 06:56 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Has this gone bad?

Looks like the bushing is worn away. Check to see what the other side looks like.

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 27 Apr 2011, 07:01 am
Dedicated Cruiser
 
Join Date: Mar 2011
Posts: 2,943
Default Re: Has this gone bad?

Yep everybody ,sooner or later, need to replace those bushings...You can replace the whole control arm assembly with a better one, from Moog for about $80 each or you can just replace the bushings with polyurethane, like I did...Just check my gallery
Reply With Quote
  #4 (permalink)  
Old 27 Apr 2011, 10:51 am
Cool Cruiser
 
Join Date: Sep 2009
Location: Formerly NawLins
Posts: 246
Default Re: Has this gone bad?

Does anyone here know of a company that makes and sells performance products for the PT and GT Cruiser for all performance areas of the car.

Sorry to keep going back to the VW, but there are many retailers selling OEM and performance parts and upgrades for all performance related areas of the VW and Audi, including Engine, Tranny, LSD's, Drive Shafts, Turbo Kits, SuperCharger Kits, Programming, Exhuast Systems, Stage 1 - 3 Motor Mounts and Flywheel Clutch kits, Suspension upgrades ... as well as all the dress it up and make it pretty parts and kits .... which is almost all I find for the PT. Anyone selling the Lower Control arm with Poly bushings already installed like I can get for my VW here SUSPENSION

Heck, the poly bushing install is the hardest part of the job!
__________________

12 Regal Turbo
06 PT - Base with BLING! TRADED 5/27/13
01 PT LE - Kid's Car - TRADED 01/13
01 Beetle Sport - SilverSport - 150+ MPH
93 Del Sol - 32+ MPG
90 F150
73 Mach1
Reply With Quote
  #5 (permalink)  
Old 01 May 2011, 12:12 pm
Regular Cruiser
 
Join Date: May 2010
Posts: 131
Default Re: Has this gone bad?

Update: We were driving in the Laurel Highlands and had to ride down some very steep hills. After getting to the bottom, the left wheel's brake pads were smokin and brake dust was everywhere. The right side is fine. Do you think this has something to do with my problem?
Reply With Quote
  #6 (permalink)  
Old 01 May 2011, 12:28 pm
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Has this gone bad?

If you take your photo, increase it's size, tweak your brightness and contrast, use an unsharp mask, then tweak your color saturation, then finally reverse the image you can see things more clearly like cracks, tears, splits, etc.

Your image was a pretty low pixel count but here's what it looks like just before reversing the image:


And afterwards, you can tell it's time to replace that bushing!


As to your brake problems, not sure, would have to have a look.
Reply With Quote
  #7 (permalink)  
Old 01 May 2011, 01:16 pm
Regular Cruiser
 
Join Date: May 2010
Posts: 131
Default Re: Has this gone bad?

Sorry about the low res pic, i just cropped from the other one and blew it up. But thanks, it looks like its not too bad a fix what do you think? I see the bushings aren't expensive either. Ill whip out the Chilton and see what I'm in for.
Reply With Quote
  #8 (permalink)  
Old 01 May 2011, 11:56 pm
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Has this gone bad?

You're probably going to need to soak the daylights out of that bolt, looks like it's never been pulled.
Reply With Quote
  #9 (permalink)  
Old 16 May 2011, 05:32 pm
Regular Cruiser
 
Join Date: May 2010
Posts: 131
Default Re: Has this gone bad?

I want to try to replace the bushing myself but my chilton manual only has directions to replace the whole control arm. Is all you have to do is take that bolt off and pop out the bushing? That sounds too good to be true...
Reply With Quote
  #10 (permalink)  
Old 16 May 2011, 07:36 pm
Dedicated Cruiser
 
Join Date: Mar 2011
Posts: 2,943
Default Re: Has this gone bad?

First you have to remove them from the car, then if you are going with Energy Suspension bushings, you can burn the old ones with a torch and put the new ones...but you you what OEM style bushings you will need to press them.

Watch this video:


Last edited by XtrmDC2; 16 May 2011 at 07:39 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:26 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors