PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Need some help

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 May 2011, 11:18 pm
03TibbyGuy's Avatar
Fresh Cruiser
 
Join Date: Oct 2010
Location: AZ
Posts: 35
Default Need some help

So I just drove my pt cruiser from Phoenix to my house which is about 80 miles. It ran fine all the way home but right when I got home and started to pull in the yard it died. When I try to start it, it just doesn't work. It sounds like it's trying to start. The radio works, lights, everything else and theres no clicking like it's the battery. The check engine light is on and the oil light is on too. So I thought maybe I had an oil leak and it ran out but I checked the oil and it's only like a quart low....any ideas?

Just trying to figure it out myself before I have it towed..
Reply With Quote
  #2 (permalink)  
Old 05 May 2011, 11:32 pm
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Need some help

Need to do the 'key dance' and find out what codes it's throwing. Search the forums for it as I'm too tired to try and explain it right now.....sorry....
Reply With Quote
  #3 (permalink)  
Old 05 May 2011, 11:36 pm
Fresh Cruiser
 
Join Date: May 2011
Posts: 4
Default Re: Need some help

03TibbyGuy,

Check for error codes using the manual error retrieval method of "key on-off-on-off- and back on" within five seconds. The error code will be display on the odometer. This may at least give you a starting point for where to start looking. Any other details you can provide may help; year, turbo or non, etc.

Last edited by mojoflattop; 05 May 2011 at 11:38 pm. Reason: missed telling him this must be done within five seconds, critical to know
Reply With Quote
  #4 (permalink)  
Old 05 May 2011, 11:42 pm
03TibbyGuy's Avatar
Fresh Cruiser
 
Join Date: Oct 2010
Location: AZ
Posts: 35
Default Re: Need some help

Did the key dance and it popped up and said "done". So it's not throwing me any codes.

It is a 2003 non turbo touring edition

Last edited by 03TibbyGuy; 06 May 2011 at 12:03 am.
Reply With Quote
  #5 (permalink)  
Old 05 May 2011, 11:45 pm
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Need some help

damn... remove the negative lead from your battery for 5 minutes, while it's off step on your brake pedal a couple of times to bleed off any residual. After reconnecting see if you can get it to start. There is a post somewhere here of this same exact problem and I'm so tired my brain isn't functioning clearly. You might try at PTCrew.com also, where the other PT wackos hang out.
Reply With Quote
  #6 (permalink)  
Old 05 May 2011, 11:48 pm
WolfmanG's Avatar
Veteran Cruiser
 
Join Date: Nov 2010
Location: San Antonio
Posts: 4,495
Send a message via Yahoo to WolfmanG
Default Re: Need some help

check your tire pressure and your gas cap, make sure it's all good. then i would suggest disconnecting the battery for about 5-10 min's then reconnect it. then see if you can start her up. what ever happens if the check engine light comes back on, do the key dance again and see if anything comes up.
__________________
-Danny Wolfman G
http://www.facebook.com/WolfmanG
Reply With Quote
  #7 (permalink)  
Old 05 May 2011, 11:52 pm
03TibbyGuy's Avatar
Fresh Cruiser
 
Join Date: Oct 2010
Location: AZ
Posts: 35
Default Re: Need some help

Thanks guys I'll check it out right now
Reply With Quote
  #8 (permalink)  
Old 06 May 2011, 12:02 am
03TibbyGuy's Avatar
Fresh Cruiser
 
Join Date: Oct 2010
Location: AZ
Posts: 35
Default Re: Need some help

K waiting 10 minutes now..

It's just weird cause it drove fine all the way home and then out of no where it just died and won't start back up..
Reply With Quote
  #9 (permalink)  
Old 06 May 2011, 12:05 am
03TibbyGuy's Avatar
Fresh Cruiser
 
Join Date: Oct 2010
Location: AZ
Posts: 35
Default Re: Need some help

Sorry I just realized I put it was a limited edition. It's actually a touring edition, not sure if it matters lol. I'm a little tired myself
Reply With Quote
  #10 (permalink)  
Old 06 May 2011, 12:05 am
WolfmanG's Avatar
Veteran Cruiser
 
Join Date: Nov 2010
Location: San Antonio
Posts: 4,495
Send a message via Yahoo to WolfmanG
Default Re: Need some help

Quote:
Originally Posted by 03TibbyGuy View Post
K waiting 10 minutes now..

It's just weird cause it drove fine all the way home and then out of no where it just died and won't start back up..
yeah i think there's was someone else who went through that too a few months ago. cant remember who it was tho.
__________________
-Danny Wolfman G
http://www.facebook.com/WolfmanG
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:14 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors