PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Another A/C Problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10 May 2011, 12:20 pm
Fresh Cruiser
 
Join Date: Mar 2011
Location: Northeast FL
Posts: 2
Default Another A/C Problem

Hello All,

I have been lingering on the site for a few months, not posting due to my knowledge of the PT Cruiser line..

A little background to my PT:

Purchased in February with 51,000 miles on her. She is a 2008 base model, nothing fancy.. I needed something a little more reliable than my car (01 Dodge Intrepid R/T Motorsports Edition) for my Fiancee and Son. In late October of 2010 my son was diagnosed with Congenital Heart Disease. Since Early November my son has been thru a lot more than most people. 2 open heart surgeries, 1 Heart Stint, 1 life flight and a whole lot of love and support.

I purchased the PT because of the A/C and Heater working. Little did I know, the A/C went out just a month after purchase. The dealership wont honor it..

Long story short, I have included a picture and video of my problem..


The pressure of the "Low" line is right about 100psi with the car off..




Once you turn the car on and put the A/C on High it begins to cycle:




The "Low" line becomes cold like it should, but there is no cold air blowing in the Cabin.. Any ideas?


Thanks to the raging fires in the swamp my vehicles are covered in ash and soot!
Reply With Quote
  #2 (permalink)  
Old 10 May 2011, 04:06 pm
VNT's Avatar
VNT VNT is offline
Senior Cruiser
 
Join Date: Jun 2009
Location: NE
Posts: 1,466
Default Re: Another A/C Problem

It could be a number of things.

The H-valve could be clogged.

If you dont have the expertise I would bring it to a shop that does.

Believe it or not I know a couple of techs at my local dealer and if I have an AC problem I bring it there, they don rip me off. I had to have the H-valve repalced on my jeep and I believe on my 03 PT they had to add some refrigerant. It has worked for a number of years since with no issues.

You dont want over charge the system so sometimes it is best to bring to a shop that had the manifold and guages to look at both pressures to see what is going on.
__________________
VNT

89 Shadow ES 2.5 T2 +20's A555 sold
86 TurboZ CS 2.2 T2 +20's A555
90 Daytona ES 2.5 T1 A523
90 Datyona Shelby VNT needs work
00 Durango SLT+ 5.9 4x4
02 Grand Cherokee 4.7 4x4
03 PT GT Black 5 sp Stg 1
05 PT GT Silver 5 Spd Conv
06 PT GT Cool Vanilla 5 spd Conv
06 PT Base Marine Blue 40TE Conv
15 Grand Cherokee Overland 5.7 QD2
Reply With Quote
  #3 (permalink)  
Old 12 May 2011, 11:25 am
themadgreek187's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: Jax FL
Posts: 104
Default Re: Another A/C Problem

u wouldn't happen to be in Jax would u? make sure ur radiator fan comes on both speeds and change your relays in the fuse box.
Reply With Quote
  #4 (permalink)  
Old 12 May 2011, 04:11 pm
Fresh Cruiser
 
Join Date: Mar 2011
Location: Northeast FL
Posts: 2
Default Re: Another A/C Problem

Quote:
Originally Posted by themadgreek187 View Post
u wouldn't happen to be in Jax would u? make sure ur radiator fan comes on both speeds and change your relays in the fuse box.
Just north of Jax by about 20 miles. Nassau County to be exact.


That would solve the problem for no A/C while Idling, but it has also stopped blowing cold while driving at speeds of 50-80 mph. Sorry if I didnt include that.


Thanks!
Reply With Quote
  #5 (permalink)  
Old 13 May 2011, 10:43 am
themadgreek187's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: Jax FL
Posts: 104
Default Re: Another A/C Problem

Quote:
Originally Posted by surfin_mopar View Post
Just north of Jax by about 20 miles. Nassau County to be exact.


That would solve the problem for no A/C while Idling, but it has also stopped blowing cold while driving at speeds of 50-80 mph. Sorry if I didnt include that.


Thanks!
oh nice. i know where nassau county is. Fernandina? prolly gonna be your low/highspeed fan.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
is it a balljoint problem or a wheel bearing problem? phtech Tech & Performance Forum 2 05 Mar 2011 04:33 pm
No one knows what the problem is?? will21 Tech & Performance Forum 6 30 Oct 2009 07:41 pm
Another A/C problem resiurcPT Tech & Performance Forum 7 25 Jun 2008 10:03 pm
Cat problem?? ggd PT Cruiser Convertible Forum 0 30 May 2005 09:53 pm
Will this cause a problem? crazie.eddie General PT Cruiser Discussions 9 24 Oct 2004 05:29 am


All times are GMT -5. The time now is 01:13 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors