PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Well, it finally happened (as I knew it eventually would)

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 Jun 2011, 07:01 pm
Young Cruiser
 
Join Date: Sep 2007
Location: OxCx - SO CAL
Posts: 71
Default Well, it finally happened (as I knew it eventually would)


I went to start my car like any other day and the car blew more smoke out the exhaust than in the movie Uncle Buck.
I thought the thing was on fire there was so much smoke. I turned it off.
tow truck came and we started it just fine, yet it was still smoking but not as bad.
took it to the mechanic and the said it's leaking oil internally and it needs a new engine.
3900 for the engine, 230 for the hoses. it's a 2.4 turbo engine.

for those unfamilar with my woes with this car I've had the AC fixed, radiator replaced, rack and pinion replaced, motor mounts replaced, sensors replaced, coil pack and plugs replaced.

only system mods are mopar cold air intake and different muffler.

i'm up against the wall. can't decided if I should spend any more money on this thing or just junk it for cash.
__________________
2005 2.4L Turbo Limited
Original FEMALE owner - 86,000 miles
Mopar CAI, removed muffler, hidden exhaust, ceramic brake pads, 15" custom House of Kolor, Purple Baby Moons, rear dropped 2", roll pan, rocket lights AAAAND every repair under the sun for my little lemon
Reply With Quote
  #2 (permalink)  
Old 06 Jun 2011, 07:07 pm
Senior Cruiser
 
Join Date: Feb 2008
Location: Stanton, CA
Posts: 1,030
Send a message via AIM to slayerdarkcross Send a message via MSN to slayerdarkcross
Default Re: Well, it finally happened (as I knew it eventually would)

Ive seen your PT in person and its very nice! Unfortunate situation you have there though I had that happen to me while I was driving home from my 21st birthday. Including the smoke billowing out the back as I was on the freeway. I was still under warranty fortunately and my PT was in repair for about a month. I ended up having the block, head gasket, radiator, transmission cooler, serpentine belt, etc. replaced.

My PT ended up being towed about 3 times. Used up all my free AAA towing at the time >.>
Reply With Quote
  #3 (permalink)  
Old 06 Jun 2011, 07:17 pm
Young Cruiser
 
Join Date: Sep 2007
Location: OxCx - SO CAL
Posts: 71
Default Re: Well, it finally happened (as I knew it eventually would)

Thanks, SlayerDarkCross.

i love my baby, hate to let it go....my mechanic is giving it a thorough inspection for all other components of the car, transmission etc to see if they spot any other trouble spots that could be foreseeable..
__________________
2005 2.4L Turbo Limited
Original FEMALE owner - 86,000 miles
Mopar CAI, removed muffler, hidden exhaust, ceramic brake pads, 15" custom House of Kolor, Purple Baby Moons, rear dropped 2", roll pan, rocket lights AAAAND every repair under the sun for my little lemon
Reply With Quote
  #4 (permalink)  
Old 06 Jun 2011, 08:08 pm
Senior Cruiser
 
Join Date: Feb 2008
Location: Stanton, CA
Posts: 1,030
Send a message via AIM to slayerdarkcross Send a message via MSN to slayerdarkcross
Default Re: Well, it finally happened (as I knew it eventually would)

Yeah good idea my dealership initially just replaced the head gasket and I brought the PT back in a week.
Reply With Quote
  #5 (permalink)  
Old 08 Jun 2011, 10:46 pm
Young Cruiser
 
Join Date: Sep 2007
Location: OxCx - SO CAL
Posts: 71
Default Re: Well, it finally happened (as I knew it eventually would)

ok so
my mechanic said that the aside from the oil leaking internally the engine was good and he really wanted to try something other than replace the entire engine.
so they cleaned and reintalled the induction system, said there was a pool of oil inside past the air intake (again I don't know a ton about cars so I'm doing my best to relay the info ) they added engine oil additive as the seals were allowing the oil into where the result was the smoke coming out the exhaust.
they let it run for 3 hours and it stopped the smoke.
he said it should be good to go from now on as long as i add it every other oil change.
he looked at tranny everything looks good, all fluids are fine and I got my baby back tonight. no smoke and running fine. only thing i noticed is it smells a little like the old (for those familiar) Autopia cars from Disneyland...the old ones, that had that distinctive smell. kinda like a go cart smell. not drastic smell or overwhelming, just a hint of if.
my mechanic has had my car since friday and I'm sure has put more hours into it than two - they only charged me for 2 hours labor, no diagnostic fee.
i really trust them and hope everyone has a mechanic as nice and honest. if anyone is in the north orange county area and needs a good mechnic I can post the info.
__________________
2005 2.4L Turbo Limited
Original FEMALE owner - 86,000 miles
Mopar CAI, removed muffler, hidden exhaust, ceramic brake pads, 15" custom House of Kolor, Purple Baby Moons, rear dropped 2", roll pan, rocket lights AAAAND every repair under the sun for my little lemon
Reply With Quote
  #6 (permalink)  
Old 09 Jun 2011, 08:32 am
Excoastie's Avatar
Regular Cruiser
 
Join Date: Apr 2011
Location: Bossier City, LA
Posts: 192
Default Re: Well, it finally happened (as I knew it eventually would)

glad to hear that you're back on the road again.

A good honest mechanic is hard to find, glad that you've found one! keep him happy, and he'll keep you happy

Exco
__________________
I tend to ramble and repeat myself, please try to over look my ignorance.


Bill
Reply With Quote
  #7 (permalink)  
Old 09 Jun 2011, 11:05 am
RaineMan's Avatar
Cool Cruiser
 
Join Date: Aug 2010
Location: SL,UT
Posts: 271
Default Re: Well, it finally happened (as I knew it eventually would)

If you are having to put additive in every time you change the oil you really need to get the vehicle properly fixed. The additive is a quick fix and won't last forever. Sounds like your seals need to be replaced.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Something happened polira General PT Cruiser Discussions 6 25 Apr 2009 08:04 pm
It finally happened............ CruisnHskrJim General PT Cruiser Discussions 8 20 Jun 2008 05:51 pm
I was dreading the day I knew was coming CruisnHskrJim General PT Cruiser Discussions 0 16 May 2008 06:12 pm
i knew it JaxPT Sound and Security Forum 1 19 Jan 2004 01:09 am


All times are GMT -5. The time now is 01:34 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors