PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Confusing idle issue on 2001 PT Cruiser

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Jun 2011, 11:02 pm
Fresh Cruiser
 
Join Date: May 2011
Posts: 6
Default Confusing idle issue on 2001 PT Cruiser

I've checked some of the other forums but can't quite find the issue I'm having with my 2001 PT. I bought the car with the head disassembled and and put it back together with new gasket set, timing belt, and plugs. The car now runs quite well but has an erratic idle in that sometimes it idles perfectly and responds well upon acceleration but other times it idles a bit rough and will stall at stop lights. It will always start right up again and then it will run without stalling for a while and then it will stall again. There is no miss at all at cruising/passing speed. I'm not sure how long the motor had been sitting apart and wasn't sure if it might be an injector issue or something. I pulled the throttle body and thoroughly cleaned all the ports and seats and changed the idle speed motor (after I destroyed the original with over aggressive cleaning...lesson learned) and that seemed to help at first but now it's back to behaving the same way. I was thinking that I maybe installed the timing belt a tooth off but tonight the car was idling absolutely smooth and perfect. It almost seems like an intermittent vacuum leak but I've rechecked everything or have I obviously missed something? No codes have come up so I'm really at a loss here. Anybody got any ideas?
Thanks in advance!
Reply With Quote
  #2 (permalink)  
Old 14 Jun 2011, 12:19 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Confusing idle issue on 2001 PT Cruiser

Try replacing the camshaft Position sensor - but get it from the dealer. It often doesn't throw a code like it should, but can give symptoms like yours.
Easy to replace and not expensive.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 & 2005 cooling fan issue ptcruiserdad Tech & Performance Forum 12 03 Jul 2011 07:26 pm
2001 PT cruiser issue captainstan Tech & Performance Forum 3 04 Nov 2010 12:12 pm
Hot start issue with 2001 Rlundstrom General PT Cruiser Discussions 1 11 Oct 2010 02:52 pm
rough idle in AM, in 2001 PT gychang General PT Cruiser Discussions 1 09 Sep 2009 06:42 am
2005 PT Cruiser GT only 6500 miles idle issue... batlin General Turbo Discussions 4 18 May 2007 07:35 pm


All times are GMT -5. The time now is 06:50 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors