PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Air conditioning only works on high setting

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Jan 2012, 11:04 pm
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 4
Default Air conditioning only works on high setting

Air conditioning only works on high setting.
I replaced the blower motor resistor today but same thing. Even when I fully unplugged it, it did the same thing. What could it be? I'm thinking wires or something. Thanks
Reply With Quote
  #2 (permalink)  
Old 08 Jan 2012, 11:42 am
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 4
Default Re: Air conditioning only works on high setting

Anyone???
Reply With Quote
  #3 (permalink)  
Old 08 Jan 2012, 12:40 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Air conditioning only works on high setting

I don't know what's wrong but I can show you how it works.

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 08 Jan 2012, 08:01 pm
Young Cruiser
 
Join Date: Jun 2011
Posts: 72
Default Re: Air conditioning only works on high setting

I had the same problem on my old Dodge Dakota. Replaced the resistor, which didn't work. Ended up replacing the control unit in the dash. That one had a slider type control instead of a dial like on the PT. I don't know if this helps, but there it is.
__________________

2002 Limited Edition, 5 speed
Reply With Quote
  #5 (permalink)  
Old 08 Jan 2012, 10:36 pm
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 4
Default Re: Air conditioning only works on high setting

Quote:
Originally Posted by PianoTunerCruiser View Post
I had the same problem on my old Dodge Dakota. Replaced the resistor, which didn't work. Ended up replacing the control unit in the dash. That one had a slider type control instead of a dial like on the PT. I don't know if this helps, but there it is.
Ok, so just the main control unit? I'll see if I can find it online.
Reply With Quote
  #6 (permalink)  
Old 08 Jan 2012, 11:55 pm
Young Cruiser
 
Join Date: Jun 2011
Posts: 72
Default Re: Air conditioning only works on high setting

That's what fixed my truck. I can't be sure what 's wrong with your car, but it had the same symptom. In my case, the blower only worked on high, but it wasn't just air conditioning. It was that way with heat too. Everything I read said that it should have been the resistor, but it wasn't.
__________________

2002 Limited Edition, 5 speed
Reply With Quote
  #7 (permalink)  
Old 08 Jan 2012, 11:58 pm
Young Cruiser
 
Join Date: Jun 2011
Posts: 72
Default Re: Air conditioning only works on high setting

I bought the new contol unit from the Dodge dealer. It wasn't cheap, maybe a couple hundred bucks? It's been a while, so I don't remember exactly.
__________________

2002 Limited Edition, 5 speed
Reply With Quote
  #8 (permalink)  
Old 22 Jul 2012, 05:07 pm
Fresh Cruiser
 
Join Date: Jun 2012
Posts: 14
Default Re: Air conditioning only works on high setting

Quote:
Originally Posted by PianoTunerCruiser View Post
That's what fixed my truck. I can't be sure what 's wrong with your car, but it had the same symptom. In my case, the blower only worked on high, but it wasn't just air conditioning. It was that way with heat too. Everything I read said that it should have been the resistor, but it wasn't.
Mine just started acting up, same thinmg, only working on high setting.
How hard is to replace?
Where to get the part?

Anyone have any photo's or instructions handy?

Many thanks!
Reply With Quote
  #9 (permalink)  
Old 22 Jul 2012, 05:25 pm
Cool Cruiser
 
Join Date: Jun 2010
Posts: 252
Talking Re: Air conditioning only works on high setting

The dash center section isn't the same for all years, so before anyone can tell you how to remove it, we need to know the model year of the PT.
Reply With Quote
  #10 (permalink)  
Old 22 Jul 2012, 06:29 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: Air conditioning only works on high setting

Quote:
Originally Posted by loulou View Post
Mine just started acting up, same thinmg, only working on high setting.
How hard is to replace?
Where to get the part?

Anyone have any photo's or instructions handy?

Many thanks!
Like said above we need to know what year you have. But before you start tearing the dash apart I would replace the blower motor resistor or at least check it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 Non Turbo Cooling Fan works on high speed only Johnnyvolvo Tech & Performance Forum 6 13 Apr 2010 02:45 pm
Setting The Inside she_so Interior Accessories Forum 4 22 Mar 2009 05:19 pm
What is the best comfort setting? Ctown Wheels, Tires, Suspension 2 18 Oct 2004 12:41 pm
Setting new standards turbomangt The Detail Shop 0 03 Jul 2004 08:34 am


All times are GMT -5. The time now is 07:21 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors