PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
starter?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 Jan 2012, 05:12 pm
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 1
Default starter?

My PT cruiser won't start today...just get a series of clicks and no turn-over. Recently, I got an engine light and when did the OBD the codes said two things were wrong - "air/fuel mixture inappropriate" and "battery disconnected in last 50 starts".... battery checked fine, started several times after engine light came on, but won't start today...long series of clicks.
Reply With Quote
  #2 (permalink)  
Old 06 Jan 2012, 05:28 pm
davea300's Avatar
Cool Cruiser
 
Join Date: Aug 2011
Location: Scotland UK
Posts: 306
Default Re: starter?

Do the lights and other electrics work? On first glance sounds like flat batt to me.
__________________
2005 2.4 PT CRUISER (UK SPEC)
Short ram intake, chrome grill, chrome belt line, drilled/slotted discs, few flames, engine dress up, chrome bits and pieces.
67,000 miles
Reply With Quote
  #3 (permalink)  
Old 06 Jan 2012, 06:06 pm
mityqwik's Avatar
Senior Cruiser
 
Join Date: Sep 2010
Location: Hampton roads Va.
Posts: 1,966
Thumbs up Re: starter?

x2 what he said or your battery term.are corroded also look at your battery cables are they in good shape and the battery ground check check to make sure it is making good contact,
__________________
It takes 8,460 bolts to assemble an automobile,
and one nut to scatter it all over the road
Reply With Quote
  #4 (permalink)  
Old 06 Jan 2012, 06:15 pm
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: starter?

x3 ditto
Reply With Quote
  #5 (permalink)  
Old 07 Jan 2012, 05:26 am
Fanatic Cruiser
 
Join Date: Jun 2009
Location: Rochester, Michigan
Posts: 669
Default Re: starter?

x4...bad battery and/or cables and connections.
Reply With Quote
  #6 (permalink)  
Old 07 Jan 2012, 02:15 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: starter?

Battery disconnected is also a shared code with 'Beginning of sequence'

They just don't tell you that.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
remote starter 4SPEED General Turbo Discussions 7 27 Dec 2011 10:10 am
Bad starter?? jdmickies Tech & Performance Forum 8 06 Sep 2010 11:01 pm
Starter Modifications chasetag87 Tech & Performance Forum 10 26 Feb 2010 04:54 pm
How do I get to the starter? 2003 PT 2.4L phonon Tech & Performance Forum 3 20 Dec 2009 09:04 pm
Possible bad starter morrises Tech & Performance Forum 7 17 Jun 2008 09:07 pm


All times are GMT -5. The time now is 05:34 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors