PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
2001 PT Cruiser troubleshooting....

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01 Feb 2012, 10:03 am
Fresh Cruiser
 
Join Date: May 2011
Posts: 29
Default 2001 PT Cruiser troubleshooting....

So I've been having a problem with my 01 Cruiser. It's was idling really roughly, even sometimes just shutting off while idling at an intersection. I had just got the vehicle back from my mechanic for a cracked head when this idling problem started. The CEL light came on, so I pulled a 0300 code, misfire detected...well hmm. Mechanic told me is most likely my ignition coil from water spilling on it when my heads cracked. No problem i replaced it...still idling rough. Then he says its my idle air control motor...so i replaced it along with my MAP sensor since it threw a code for that as well. It ran okay for about a day then tripped the CEL for insufficient flow from the EGR system. So i replaced the EGR Valve like 3 days ago. It was running perfect until this morning. CEL light came back on with 0300 code again, and even idled out a light!!!

I was hoping someone could give me any ideas as to what I can do. What could be causing the misfire or how can I get down to the real source of my problems? So far since august of last year I've had to replace pretty much everything in this car...lower end completely rebuilt (crank kit and all) all new cooling system components, all new charging system components, upper end rebuilt, and the heads machined, new gaskets etc.... I just don't get why I can't get this damn car running good for more than a few days. Seriously am considering getting rid of it!!!
Reply With Quote
  #2 (permalink)  
Old 01 Feb 2012, 05:34 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: 2001 PT Cruiser troubleshooting....

Your mechanic sounds like he has no idea what's wrong and is having you trow parts at it in hopes of getting the right one. Has he hooked up and OBDII scanner to see if that can pinpoint something? You haven't said anything about plugs and wires or looking for a vacuum leak.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 01 Feb 2012, 11:59 pm
Fresh Cruiser
 
Join Date: May 2011
Posts: 29
Default Re: 2001 PT Cruiser troubleshooting....

Yes it has new wires and the plugs look to be fine.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
troubleshooting help codes 340/1193 jbptcruzn Tech & Performance Forum 6 04 Jun 2011 11:29 pm
Overheating troubleshooting, what to do? Mulligandog Tech & Performance Forum 16 28 Apr 2011 06:42 am
2001 pt cruiser jdp01 General PT Cruiser Discussions 1 08 Jul 2009 02:48 pm
Help Troubleshooting the EVAP system geronimo Tech & Performance Forum 6 09 Mar 2009 09:46 am


All times are GMT -5. The time now is 09:40 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors