PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Sporadically Needs Jump Start

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Feb 2012, 07:40 pm
Regular Cruiser
 
Join Date: Dec 2011
Posts: 136
Default Sporadically Needs Jump Start

I've searched and couldn't find any answers.

Here's the situation:
Cruiser will not start randomly after having started within the past hour. For example, it will take her to the grocery store but will not start on the way back. Car had similar problems last winter but she wasn't driving it regularly so we just figured it had something to do with that. She got a new Die Hard battery last winter. This has occurred twice at this point but we need to find out what is going on so she stops getting stranded.

Battery and alternator have been tested and passed.

*whoops misspelled title.

Last edited by CREWZIN; 17 Feb 2012 at 08:47 pm.
Reply With Quote
  #2 (permalink)  
Old 17 Feb 2012, 08:10 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,886
Question Re: Sporaticly Needs Jump Start

Quote:
Originally Posted by ankit View Post
I've searched and couldn't find any answers.

Here's the situation:
Cruiser will not start randomly after having started within the past hour. For example, it will take her to the grocery store but will not start on the way back. Car had similar problems last winter but she wasn't driving it regularly so we just figured it had something to do with that. She got a new Die Hard battery last winter. This has occurred twice at this point but we need to find out what is going on so she stops getting stranded.

Battery and alternator have been tested and passed.

*whoops misspelled title.
Doesn't crank or cranks but doesn't fire?
Reply With Quote
  #3 (permalink)  
Old 17 Feb 2012, 09:10 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: Sporadically Needs Jump Start

Since you mentioned you got a new Die Hard battery, I can assume that Sears put that in. I had Sears put in a Die Hard for me and their serviceman broke off one of the prongs on the bottom of my air box. He also did not put any battery protector of any kind on the clamps and posts. Therefore, within a year the corrosion was so bad on the terminals that my clamps were eaten through. I had to get a new wiring harness as a result.

When getting a new battery for a PT that has the airbox covering the posts, it's always a good idea to spray some battery protectant on the clamps and posts. Otherwise, it's amazing how fast the corrosion occurs on our PT's.

P.S. Sears also threw away my battery thermal blanket.

Tim
Reply With Quote
  #4 (permalink)  
Old 18 Feb 2012, 10:35 am
Regular Cruiser
 
Join Date: Dec 2011
Posts: 136
Default Re: Sporadically Needs Jump Start

It doesn't really crank. There is corrosion on the terminals but I don't know if it enough to cause this problem, though it would explain the good battery and such. I will start by replacing those and see where we get.

Yeah I have learned through her experiences with sear's not to take it there anymore. She had rear brakes done and now they make a loud knocking noise everytime she stops, and this started when she pulled out of the Sear's parking lot after getting the work done. THey say it's not their fault and don't know what is causing the noise.
Reply With Quote
  #5 (permalink)  
Old 18 Feb 2012, 05:26 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,886
Thumbs up Re: Sporadically Needs Jump Start

Clean those terminals. Try to save your originals. Cutting them off an using those clamp on replacements just create an extra connection to corrode.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Jump Start a problem? niel General PT Cruiser Discussions 7 29 Aug 2011 04:55 pm
'04 Cruiser won't start. failed jump attempt TrinityLayne Tech & Performance Forum 4 08 Aug 2011 06:15 pm
Not even a jump worked! Any ideas? durhamchic Tech & Performance Forum 11 16 Jun 2011 04:06 pm
All Electricity gone - Jump start fails also JPGP General PT Cruiser Discussions 5 08 Dec 2010 06:18 pm
Door lock problem after dead battery/jump start Mal Interior Accessories Forum 1 11 Jun 2009 09:32 pm


All times are GMT -5. The time now is 05:37 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors