PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
07 pt fan keeps running

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Mar 2012, 09:42 pm
Fresh Cruiser
 
Join Date: Mar 2012
Posts: 1
Angry 07 pt fan keeps running

Car fan stays on after engine is shut off. First time it happened drained battery all the way down. From what Ive read so far its either temp sensor or low speed fan relay.It only shuts off when fuse is pulled. Located relays on fan shroud but can't figure out how to remove outer boxes, it must be some kind of squeeze and pull routine. Also located temp sensor but it looks almost impossible to get to . PLEASE HELP
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
02 running a little hot... 02ptlimited Tech & Performance Forum 8 22 Jun 2009 09:47 pm
Car Not Running - Help plang1975 Tech & Performance Forum 8 28 Oct 2008 12:15 pm
Has anyone tried running E85 in the GT? Cvette54 Turbo Performance 6 09 Sep 2008 10:37 am
up and running again careyk Canada PT Forum 1 19 Feb 2008 01:31 am
XM up and running CHROMEDCRUISER Sound and Security Forum 4 07 Jan 2005 07:22 pm


All times are GMT -5. The time now is 09:40 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors