PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Multiple problems after replacing the battery

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 31 Mar 2012, 08:56 pm
Fresh Cruiser
 
Join Date: Mar 2012
Location: independence mo
Posts: 7
Angry Multiple problems after replacing the battery

HI everyone, I have a 2006 touring 140k miles on it. I replaced my battery 2 days ago, I put a duralast 26R-DL . I drove back home and everything was fine. Last night when I started my car the headlights didnt come on. This morning I checked the car and I see these problems (I never had them before);

when I put the key on and turn it (didnt start the engine just turn it), airbag light comes on and check engine light starts blinking for 5-6 times and then airbag light turns off and check engine light stops blinking and stay still. When I turn on the engine, it starts and works fine and check engine light goes away as normal.
When I want to turn on my headlights, they are not working.
Turn signals are not working and no arrows on the dashboard.
Emergency flashers are not working.
Front and rear windshield wipers are not working.
Rear window thermostat is not working.
Compass is not working.( there is -- instead of N,S,W,E)

Horn is working.
Brake lights are working.
Illuminated approach works fine and when I lock the car headlights come on.
when I locked and unlock the doors, turn signals work good.
Light bulbs are ok.
I drove the car for 10 miles and no check engine light come on. No airbag light come on.
I checked the fuses and they are fine.
I checked and replaced the battery terminals when I installed the new battery so there is no corrosion.
I disconnect the battery cables and wait for 5 min. Connect them again and it didnt fix anything.

I dont know what to do next. Any ideas??
Reply With Quote
  #2 (permalink)  
Old 31 Mar 2012, 10:23 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: Multiple problems after replacing the battery

Still sounds like a bum battery. Many items pull only a fraction of battery power--so they still work ... sometimes even your headlights (although dimmer).

If you replaced your battery terminal(s), do you mean to say that you replaced the entire wiring harness?--since the positive cable is essentially a harness with several leads. And, if so, are all your connections good and snug?

Still, your problem sounds like the new battery.

Tim
Reply With Quote
  #3 (permalink)  
Old 31 Mar 2012, 10:46 pm
Fresh Cruiser
 
Join Date: Mar 2012
Location: independence mo
Posts: 7
Default Re: Multiple problems after replacing the battery

Hi Tim,
thank you for the reply. My old battery was a walmart everstart one. The cold weather killed it. I was able to jumpstart the car and drive it with none of those problems.I used my car several times, jump starting and driving before I replaced the battery but again never had these problems even with an old battery. I didnt replace the entire wiring harness , I replaced the clamps which holds the - and + battery heads. I think I did it when I had the old battery because there was corrosion. I checked the connection of the cables and they look fine.
It sounds like the new battery I know because they started the next day I put the new battery.
Reply With Quote
  #4 (permalink)  
Old 31 Mar 2012, 11:23 pm
06ptvert's Avatar
Fresh Cruiser
 
Join Date: Feb 2012
Location: Tampa,FL.
Posts: 38
Default Re: Multiple problems after replacing the battery

check the alt, with running it off of a jump start for lengths of time you may have burnt out or weakened the regulator in the alternator....when the battery is dead the alternator's regulator kicks into hi gear (so to speak) so do a charging system check so make sure it is putting out what its supposed to
Reply With Quote
  #5 (permalink)  
Old 01 Apr 2012, 01:31 am
Fresh Cruiser
 
Join Date: Mar 2012
Location: independence mo
Posts: 7
Default Re: Multiple problems after replacing the battery

Quote:
Originally Posted by 06ptvert View Post
check the alt, with running it off of a jump start for lengths of time you may have burnt out or weakened the regulator in the alternator....when the battery is dead the alternator's regulator kicks into hi gear (so to speak) so do a charging system check so make sure it is putting out what its supposed to
But I think the battery power suppose to be enough to power the wipers or emergency flashers even the car is not working. right? By the way,when the engine is on or off: radio is working so as the interior lights.. power mirrors are working, fan blows air, power windows are working..
Reply With Quote
  #6 (permalink)  
Old 30 Apr 2012, 11:14 pm
Fresh Cruiser
 
Join Date: Mar 2012
Location: independence mo
Posts: 7
Default Re: Multiple problems after replacing the battery

Hi, I couldnt update because of family reasons. Here is what happened lately:
First I checked the battery cables again and checked ground connections. They were fine. After I wanted to check the TIPM but didnt want to mess with it. There were no corrosions , I mean it look fine. I was checking the light bulbs , I forget to disconnect the battery cable so the when I was trying to put the headlight back to its socket, I think it did some kind of short circuit and both headlights turned on themselves. I couldnt turned them off by the multifunctional switch so I disconnect the battery and wait for a day. The next day, I connect the battery and turned on the engine, car was working fine and there were no problems !! But then I noticed that when I pull my hand break, headlights turned themselves off and wipers stop working and flashers stop working... Weird right? So I decided to not to use my hand break unless it is not necessary.. After a week I had no electrical problems.. Strange thing is, now , the hand break is also NOT affecting anything.. I think there was something wrong with the TIPM module and it shot down some circuits, but when I was messing with the headlight, short circuit did some thing.. Interesting right?
Reply With Quote
  #7 (permalink)  
Old 30 Apr 2012, 11:16 pm
Fresh Cruiser
 
Join Date: Mar 2012
Location: independence mo
Posts: 7
Default Re: Multiple problems after replacing the battery

now, everything works fine .( knock the wood ))
Reply With Quote
  #8 (permalink)  
Old 01 May 2012, 12:10 am
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Multiple problems after replacing the battery

I'm having to trace lines inside my car all over the place. Had bizarre events occur after replacing my battery too. About a month ago my line to the cig lighter burned out, literally. How that happens without blowing a fuse is beyond me. So right now I'm running some leads through a fuseable link to the battery to keep a few things working. I have to pull everything out in the center console and around the shifter to trace what the heck is going on.... too weird....
Reply With Quote
  #9 (permalink)  
Old 03 May 2012, 06:59 am
Fresh Cruiser
 
Join Date: Mar 2012
Location: independence mo
Posts: 7
Default Re: Multiple problems after replacing the battery

Quote:
Originally Posted by Chromenut View Post
I'm having to trace lines inside my car all over the place. Had bizarre events occur after replacing my battery too. About a month ago my line to the cig lighter burned out, literally. How that happens without blowing a fuse is beyond me. So right now I'm running some leads through a fuseable link to the battery to keep a few things working. I have to pull everything out in the center console and around the shifter to trace what the heck is going on.... too weird....
possessed by demons ?? )) I was thinking the same thing for my car.. I had too many electronic problems before, one time I had problems with the headlights and I took my car to the dealer and they had to flash the TIPM.. I guess most of the multiple electronic problems are related with the TIPM thing..
Reply With Quote
  #10 (permalink)  
Old 03 May 2012, 10:23 am
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: Multiple problems after replacing the battery

i just foud out on my Pontiac that the headlights are always on BUT when you put the car in park they go off in the day time i thought that was odd
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.2 CRD Battery Problems saveloy Welcome New PT Cruiser Members 9 26 Apr 2014 02:33 am
New Battery = problems CREWZIN Tech & Performance Forum 7 02 Feb 2012 04:36 am
Multiple Problems and error codes wwelbourn Tech & Performance Forum 3 26 Jul 2009 12:18 pm
Wiring multiple wires to car battery? DIYPTGUY Interior Accessories Forum 7 27 Nov 2008 05:50 pm
02 Cruiser...Multiple Problems (1 odd/dumb question) Silver02 Tech & Performance Forum 2 13 Aug 2008 05:09 pm


All times are GMT -5. The time now is 04:56 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors