PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Help!!! smoke and belt problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 28 Sep 2012, 02:50 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 26
Default Help!!! smoke and belt problem

Driving 03 pt home and all the sudden car startes to idel ruff smoke from belt burning and a loud noise... any help would be great...
Reply With Quote
  #2 (permalink)  
Old 28 Sep 2012, 03:24 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: Help!!! smoke and belt problem

Was the AC on and did you turn it off if it was?
Reply With Quote
  #3 (permalink)  
Old 28 Sep 2012, 03:27 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: Help!!! smoke and belt problem

Quote:
Originally Posted by webstertroy View Post
Driving 03 pt home and all the sudden car startes to idel ruff smoke from belt burning and a loud noise... any help would be great...
if i were you i'd slip off the serpentine belt and see if the pulleys on the AC compressor and power steering both spin freely.
Reply With Quote
  #4 (permalink)  
Old 28 Sep 2012, 03:42 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Help!!! smoke and belt problem

You definitely have your problems. Your first couple of posts said you overheated and your father-in-law tested the wrong part of the fan harness. You never said if that issue was ever corrected. Now the smoke, smell and loud noise. I'm with the two guys above. Sounds like something (A/C, PS) might have locked up causing those symptoms. We can guess all night but somebody has to get their hands dirty and find out which belt was burning and what caused the noise.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 28 Sep 2012, 04:12 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 26
Default Re: Help!!! smoke and belt problem

OK guys fan isnt working.. last time it over heated I changed the low speen relay and the fan started working agine...this time When I changed it it didnt do anything going to test the fan when I get home and see if it is working or not...
Reply With Quote
  #6 (permalink)  
Old 28 Sep 2012, 06:33 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 26
Default Re: Help!!! smoke and belt problem

Ok guys just tested the fan and it works.... need some help I dont know where go to from here.. Fan will not come on when car is started and ac is on...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Timing belt instilation problem. Futurechrysler Tech & Performance Forum 4 15 Nov 2011 10:27 am
A different kind of Timing Belt problem Quicksilver Tech & Performance Forum 7 15 May 2011 03:48 pm
Changed timing belt, New Problem starrlyte99 Tech & Performance Forum 2 27 Apr 2010 07:13 pm
02 2.4L timing belt problem ronwins3 Tech & Performance Forum 18 15 Dec 2008 08:57 pm
Fixed timing belt now another problem EvilWRX Tech & Performance Forum 1 13 Feb 2007 09:35 am


All times are GMT -5. The time now is 02:00 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors