PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
p0522 code engine oil pressure or sensor voltage 2003 PT

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Oct 2012, 03:16 pm
oldorange's Avatar
Fresh Cruiser
 
Join Date: Sep 2010
Posts: 24
Default p0522 code engine oil pressure or sensor voltage 2003 PT

Daughter Got the oil light on while driving early this morning on a less than 2 mile trip, but it did not cause the car to stop while driving. It started fine for me about 20 minutes later when I got to it, no oil light either. So I did the key dance and it came up a p0522 code engine oil pressure or sensor voltage. The oil was just changed about 2 weeks ago to a partial synthetic and was full. There may be some leaking cause I can smell it sometimes, but do not see any on the ground after driving or while idling. So....

I Disco'd/reco'd the battery and that cleared the code. Drove about 4 or 5 miles, no new code or light. Is there a chance it's transient and not a real problem? I am not familiar with how this engine pumps oil and if a oil pump can actually fail on this motor. I did not touch the sensor or look at the wiring harness yet or the sensor, or the connections.

Also, this may be a 2004 PT engine that was put in this 2003 by the seller.

Any advice on this? Thank you all! So sorry we even need such a forum!
__________________
My 2003 PTOS... ...Will it ever STOP Squeaking & Creaking???!!! And 21 MPG, what's up with that?

Last edited by oldorange; 13 Oct 2012 at 09:10 pm.
Reply With Quote
  #2 (permalink)  
Old 13 Oct 2012, 03:34 pm
podo2000's Avatar
Cool Cruiser
 
Join Date: Sep 2012
Location: Arizona
Posts: 266
Default Re: p0522 code engine oil pressure or sensor voltage 2003 PT

Had a similar issue when i changed mine to synthetic. P0522 within 10 miles of changing oils. Cleared the codes and checked oil pressure. Everything was fine. That was about 12k miles ago. Have not had it go off again.

No reason why it went off.

2005 Touring 110Kmiles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
'04 limited turbo throws code p0522 and p0508 Blugirl Tech & Performance Forum 5 06 Dec 2010 04:24 am
P0452 Fuel Tank Pressure Sensor Error Code dornstar Tech & Performance Forum 0 22 Aug 2007 12:08 am
P0452 Fuel Tank Pressure Sensor Circuit Low Voltage dornstar General PT Cruiser Discussions 0 22 Aug 2007 12:05 am
P0325 Engine Error Code on 2003 PT Turbo intim3 General Turbo Discussions 0 12 Aug 2007 08:06 pm
Which is easier to hook up-Voltage or Oil Pressure wyzard Interior Accessories Forum 2 22 Apr 2004 05:46 pm


All times are GMT -5. The time now is 12:16 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors