PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Newbie Questions

 
Like Tree1Likes
  • 1 Post By quicksilverdon

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Nov 2012, 09:11 pm
Fresh Cruiser
 
Join Date: Nov 2012
Posts: 3
Default Newbie Questions

Just bought my first PT Cruiser. It's a 2002, ltd, with 40,000 miles. As I drive it, I notice two issues:

(1) It randomly stalls while idling at a red light. There's no shuddering or rough idle; it just quietly cuts out. Starts easily and runs fine - until next time.

(2) At other random times, the car lurches and the check engine light comes on. It runs fine with the engine light on and eventually that light goes off. Then, a week or so later, it happens again. Today it happened while driving 70+ on the highway. Quite a jolt.

Any suggestions for my mechanic?
Reply With Quote
  #2 (permalink)  
Old 24 Nov 2012, 10:16 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,749
Default Re: Newbie Questions

If the engine light comes on, you should have a fault code or two stored in the computer. Follow the instructions and let us know what codes you come up with.

How to retrieve fault codes.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 26 Nov 2012, 06:17 pm
Fresh Cruiser
 
Join Date: Nov 2012
Posts: 3
Default Re: Newbie Questions

0340 - 1595 - 1684 - 1685

Doesn't sound too good!
Reply With Quote
  #4 (permalink)  
Old 26 Nov 2012, 06:22 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,749
Default Re: Newbie Questions

P0340 = Camshaft Sensor

P1595 = Speed Control Solenoid Circuits

P1684 says the computer has lost battery voltage in the last 50 starts, and

P1685 means the security code in the key is not valid.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 26 Nov 2012, 06:59 pm
Fresh Cruiser
 
Join Date: Nov 2012
Posts: 3
Default Re: Newbie Questions

Thank you so much, Crewzin!
Reply With Quote
  #6 (permalink)  
Old 27 Nov 2012, 06:36 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Newbie Questions

Most likely the Cam position sensor is causing the death - be sure and get a Mopar sensor - a lot of Chrysler dealers have online parts so you can shop for price - but don't get a mystery brand.
twistedsista1 likes this.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie Questions Bigjoedo Tech & Performance Forum 4 01 Jan 2012 11:17 am
Newbie with a vertie! And some questions! Purevil PT Cruiser Convertible Forum 16 25 Feb 2011 12:08 am
Questions Questions..newbie DaShado PT Cruiser Convertible Forum 0 01 Apr 2006 12:22 am
2 Questions from a newbie BPfromFLA General PT Cruiser Discussions 17 22 Dec 2003 01:46 am
Questions from a newbie azptcruiser Stage Turbo Kits 1 10 Nov 2003 03:47 am


All times are GMT -5. The time now is 07:14 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors