PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Dash reads no fuse

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Jan 2013, 05:32 am
Fresh Cruiser
 
Join Date: Jan 2013
Posts: 1
Cool Dash reads no fuse

I was putting in a new stereo in my '03 cruiser and crossed some wires. My radio, int lights, power locks no longer worked. Obviously I blew a fuse. I changed the fuse that was blown. It was the fuse box inside the engine behind the batt. Not the interior one. "IOD 20 A". I still had dash read out, "NO FUSE"....arg. Perhaps I'm missing a reset button? I had my car jockey boxed about a year ago and my manual was stolen. Eventually I took it to my tire guy, (his co-worker does electric,) It cost me 65$ to have him find the reset button. It's behind the fuse box on the interior of the car. But you need to take out the box (without disconnecting the wires of course) and follow the wires to the reset button. I would have loved to have had my manual so I could find it myself. I hope someone can get some use out of this.
Reply With Quote
  #2 (permalink)  
Old 23 Jan 2013, 06:08 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,749
Default Re: Dash reads no fuse

Candi, thanks for the information. This is the first I've heard of a "reset button". The Manual, if your talking about the "Owners Manual" wouldn't have helped becuase it doesn't mention anything about that button.

We've had many people with the "No Fuse" problem and usually changing the "IOD" fuse in the PDC under the hood sets things right.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 23 Jan 2013, 09:56 am
Fresh Cruiser
 
Join Date: Jan 2013
Location: Bellflower, California
Posts: 43
Default Re: Dash reads no fuse

Yeah I had this problem a while ask and it was the IOD fuse
__________________
03 Pt 5spd and lovin it!
Reply With Quote
  #4 (permalink)  
Old 23 Jan 2013, 12:04 pm
Senior Cruiser
 
Join Date: Sep 2002
Location: Just south of the Mason/Dixon line
Posts: 1,713
Default Re: Dash reads no fuse

my 'no fuse' light was fixed with a battery replacement

Never heard of this reset button in over 10 years as a PT owner
__________________
.....................................
'03 GT base w/175k and a 2 speed autostick (read: trans is shot) and powered by a hybrid MOPAR S3 with DSP untuned
1st Forward Motion E1 powered PTGT w/Psi-Fi Power pack fuel tuner back in '07
FS: '03 GT Elec Blue w/rear suicide doors or '03 auto PCM, S3 turbofold, WGA, 3.5" o2 & 3" DP - make offer

Last edited by OurPTGT; 23 Jan 2013 at 12:08 pm.
Reply With Quote
  #5 (permalink)  
Old 23 Jan 2013, 09:30 pm
Fanatic Cruiser
 
Join Date: Jun 2009
Location: Rochester, Michigan
Posts: 675
Default Re: Dash reads no fuse

Hmmm...Reset Button???
Reply With Quote
  #6 (permalink)  
Old 24 Jan 2013, 07:55 am
PTJunkie's Avatar
Fanatic Cruiser
 
Join Date: Aug 2012
Location: Lewisville, Texas
Posts: 788
Default Re: Dash reads no fuse

Quote:
Originally Posted by Carl48 View Post
Hmmm...Reset Button???
Yeah!..is right next to the Flux-capacitor.
__________________
William____
2004 Bright Silver PT Cruiser Turbo GT H.O

Reply With Quote
Reply

Tags
auto locks, int lights, no fuse, radio, reset


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
code reads po300 echillie1 Tech & Performance Forum 6 03 Mar 2012 07:46 pm
Odometer reads all 8's waynemann General PT Cruiser Discussions 7 26 Jan 2012 08:16 am
HELP with Wiring Fuse 7 (No feed to fuse) No A/C, Electric Windows, Rear fogger??? ptcruisershoreham General PT Cruiser Discussions 3 08 Mar 2011 08:06 pm
Compass always reads W/nw/sw// but never E/ne/se... matthewmilbut General PT Cruiser Discussions 9 07 Aug 2010 10:23 am
temp reads 84F when it's 103F outside Blue7cruz Tech & Performance Forum 1 17 May 2008 07:38 pm


All times are GMT -5. The time now is 02:46 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors