PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
EGR Info Needed

 
Like Tree1Likes
  • 1 Post By Jdwags

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Feb 2013, 01:09 pm
Young Cruiser
 
Join Date: Aug 2012
Location: Camp Hill, PA
Posts: 52
Default EGR Info Needed

Hi everyone! About a year ago my CEL popped on with the 0401 code. I cleared it (and did nothing) to see if it would pop back on or not. I didn't until about 5 weeks ago. I cleared it again, and about 2 days later it came back. I removed the egr valve and cleaned it (it wasn't really dirty at all). I put it back on, cleared the code, and it came on again 2 days later. So this time I cleaned the egr again along with the egr tube. I also cleaned the ports where the gases enter and exit the engine. Again, all was very clean. I cleared the code, but it came back on 2 days later. One thing I did notice...I am not getting any suction on the vacuum tube that controls the egr valve. I even slowly increased rpm's (up to about 3000) while holding my thumb over the end. Nothing.

Here's what I do know:

The egr components I removed were very clean even before cleaning.
The egr valve holds vacuum.
The valve moves freely.
The motor stalls right away when the valve is opened manually at idle.

The car is an '01, non-turbo, with about 168K miles.

Should there be a bit of suction on the vacuum line even at idle? Shouldn't I at least have suction at higher rpm's? If the solenoid or transducer are bad, I will probably just get the complete kit for around $60 at AZ. Any thoughts?

Last edited by Jdwags; 14 Feb 2013 at 01:21 pm.
Reply With Quote
  #2 (permalink)  
Old 14 Feb 2013, 01:51 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: EGR Info Needed

i used to have that code pop up randomly as well, just as you describe it actually. i started like you by cleaning the EGR. got some black crap out of it and i could tell it still moved freely. still had the code though.


about 8 months ago i changed the transducer only on mine. it's been fine ever since. no codes no issues. if you want to go this route, rock auto has it cheap:


link to part: DORMAN Part # 911201
oh, and the shipping was only $2.60


..

Last edited by rob342; 14 Feb 2013 at 03:01 pm.
Reply With Quote
  #3 (permalink)  
Old 22 Feb 2013, 06:47 am
Young Cruiser
 
Join Date: Aug 2012
Location: Camp Hill, PA
Posts: 52
Default Re: EGR Info Needed

Thanks for the info! I was able to change out the transducer/solenoid yesterday. The old trans was definitely bad. Also, there was water in it?! Maybe it was in there from all the rain and slop we have been having here. Anyway, hopefully this takes care of it. Thanks again!
rob342 likes this.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Antenna Info needed Bobster Exterior Accessories Forum 6 13 Apr 2014 01:37 pm
Dash info needed sonocativo General PT Cruiser Discussions 10 06 Jul 2012 11:11 pm
Tune up info needed... sonocativo General PT Cruiser Discussions 18 06 Jul 2012 02:14 am
Wastegate Info Needed GTPT Turbo Performance 10 05 Dec 2003 12:16 am
Wiring Info Needed GTPT General Turbo Discussions 3 15 May 2003 11:01 pm


All times are GMT -5. The time now is 09:43 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors