PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
power assist not working on brakes

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Mar 2013, 08:43 am
Fresh Cruiser
 
Join Date: Feb 2012
Posts: 10
Default power assist not working on brakes

When I went to leave a store my power assist had stopped working on my brakes....does any one have an idea where to start looking and what the most likely cause is!!
Reply With Quote
  #2 (permalink)  
Old 13 Mar 2013, 09:10 am
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: power assist not working on brakes

Check to make sure the vacuum line is connected. If it is you can pull it to see if you are getting vacuum and if you are then the vacuum booster might have failed.
Reply With Quote
  #3 (permalink)  
Old 13 Mar 2013, 09:16 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,901
Default Re: power assist not working on brakes

Yes do as Ray says. Check all the big vac hoses, from the booster out to where they go. A hose could have split and fell off.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #4 (permalink)  
Old 13 Mar 2013, 03:56 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,749
Default Re: power assist not working on brakes

Is the idle high and jumping all around? That's just what happened to mine when the vacuum hose parted at a junction along with loosing the assist in braking. Check all the lines connected to the booster as was just mentioned above.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
power mirrors not working ricksatluz Tech & Performance Forum 9 10 Dec 2012 04:59 am
2007PT Head/Brakes Working, Tailights Out PurplePT2007 General PT Cruiser Discussions 0 14 Apr 2012 12:16 pm
Overheating issue. Please assist! sjzdx Tech & Performance Forum 18 27 Jun 2011 08:16 pm
Power locks not working! JHCT General PT Cruiser Discussions 1 30 Nov 2008 04:03 pm


All times are GMT -5. The time now is 05:44 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors