PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
My Starting Problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 Mar 2013, 04:11 am
Fresh Cruiser
 
Join Date: Jul 2011
Posts: 5
Default My Starting Problem

Hi, I have a 2002 PT Cruiser that I love very much, but it is starting to be a problem.
Back last summer it failed to start. I turned the ignition and the starter just clicked. I tried hitting the starter, jumping the car and in the end I bumped it to get it going. For 4 months I had no problems and then out of the blue it happened again. This time i changed the starter and it was fine for about 2 weeks then the same happened again. The starter came out and i connected it straight to a battery and it worked fine. Put it back on and still click and no starting. I then put a jump lead from the earth terminal to the starter casing and it started on the key. Got an electrician to look at it and he could find nothing wrong. It now started fine for a week and then the problem returned. Electrician came out again and has now changed the wire that goes from the starter relay to the starter. Thought it was ok until yesterday and same problem. Anyone got any ideas? Could it be the immobilizer?
Reply With Quote
  #2 (permalink)  
Old 18 Mar 2013, 09:49 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,902
Default Re: My Starting Problem

You need to clean all the connections on the battery to the starter and battery to the ground on the block. Also clean the grounds on the inner finder above the air filter box. Treat these with a battery terminal anti corrosion product. This should eliminate the under hood stuff. Had battery been tested when this happens? Any alternator light on?
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #3 (permalink)  
Old 18 Mar 2013, 10:14 am
Fresh Cruiser
 
Join Date: Jul 2011
Posts: 5
Default Re: My Starting Problem

Hi, have cleaned the battery terminals and earth to starter but not the earth block so will try that. Battery has been checked and alternater and no warning lights were on.
Thanks.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
starting problem skinnyp Tech & Performance Forum 10 09 Apr 2016 04:46 pm
starting problem cookie General PT Cruiser Discussions 4 17 Jun 2009 07:38 am
Starting problem Elrodion Tech & Performance Forum 0 18 May 2009 07:49 am
01 PT Problem with starting car Vengence General PT Cruiser Discussions 1 04 Apr 2009 01:29 pm
starting up problem packrat007 Tech & Performance Forum 11 15 Aug 2008 04:38 am


All times are GMT -5. The time now is 05:32 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors