PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
HELP!!! Possible radiator issue

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Apr 2013, 12:20 am
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 4
Default HELP!!! Possible radiator issue

Hi there,
Yes my radiator is leaking so I've been putting water in everytime I use the car (2001 Limited Edition PT Cruiser). I don't want antifreeze leaking everywhere. I can't take it in until the end of April. Now, that's been working fine but suddenly after driving it for about 10 minutes it starts to make a clicking sound that slows down when I'm stopped at a red light and speeds up as I drive. It gets louder and louder as I go and then sounds like it's going to die. The first time it happened I was almost home so I got to my parking spot and turned off the headlights and the engine died; I had not turned the ignition off yet. I tried to start the car and it wouldn't start. It turned over a bit but it was weak. I spoke to my boss who knows a bit about cars the next day and while he was there I tried to start it again and it started fine. This may have been dumb but I took it out again to see if this would happen again and within 10 minutes it started clicking again and started sounding like it was going to die.

Anyone know what this might be?

Any help would be appreciated.
Reply With Quote
  #2 (permalink)  
Old 09 Apr 2013, 07:12 am
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: HELP!!! Possible radiator issue

Quote:
Originally Posted by faguin View Post
Hi there,
Yes my radiator is leaking so I've been putting water in everytime I use the car (2001 Limited Edition PT Cruiser). I don't want antifreeze leaking everywhere. I can't take it in until the end of April. Now, that's been working fine but suddenly after driving it for about 10 minutes it starts to make a clicking sound that slows down when I'm stopped at a red light and speeds up as I drive. It gets louder and louder as I go and then sounds like it's going to die. The first time it happened I was almost home so I got to my parking spot and turned off the headlights and the engine died; I had not turned the ignition off yet. I tried to start the car and it wouldn't start. It turned over a bit but it was weak. I spoke to my boss who knows a bit about cars the next day and while he was there I tried to start it again and it started fine. This may have been dumb but I took it out again to see if this would happen again and within 10 minutes it started clicking again and started sounding like it was going to die.

Anyone know what this might be?

Any help would be appreciated.

Sounds to me like one of 3 things.

Stuck lifters in the engine.

Slipping serpentine belt

Partially broken timing belt.


Did the vehicle ever overheat with the leaking issue?
Reply With Quote
  #3 (permalink)  
Old 09 Apr 2013, 01:05 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 4
Default Re: HELP!!! Possible radiator issue

Yes, unfortunately, but for only a couple of minutes or so a couple of times before I realized how bad the leak was.
Reply With Quote
  #4 (permalink)  
Old 09 Apr 2013, 01:28 pm
Teekypt's Avatar
Senior Cruiser
 
Join Date: May 2008
Location: Houston, TX
Posts: 1,428
Send a message via Skype™ to Teekypt
Default Re: HELP!!! Possible radiator issue

Check your alternator as well? May not be your main issue, but it's worth looking at as well. Hopefully, where ever you take it, they'll run a diagnostic on it. Also, if you eva get into a jam where it's overheating fast, blast your heater. If your fans are working, it'll cool the engine, blowing the heat off of it. This has saved me a couple of times. And be careful w/turning your car off if it's already hot...this can be when the engine gets it's hottest and you don't want a cracked head. <3
__________________
2003, GT, "ShuggaPlum", xenon bumper kit, custom grey/black CoverKing seat covers (front & back).
Sunrise: July 2002
Sunset: June 2018

http://www.math.uh.edu/~tai/Today/Clean3.jpg

Last edited by Teekypt; 09 Apr 2013 at 01:30 pm.
Reply With Quote
  #5 (permalink)  
Old 09 Apr 2013, 01:36 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 4
Default Re: HELP!!! Possible radiator issue

Alternator was just fixed a couple of months ago. My boss has one of those diagnostic machines and nothing showed. I just really hope it's not a major fix.

Thanks for your reply!
Reply With Quote
  #6 (permalink)  
Old 09 Apr 2013, 01:45 pm
Teekypt's Avatar
Senior Cruiser
 
Join Date: May 2008
Location: Houston, TX
Posts: 1,428
Send a message via Skype™ to Teekypt
Default Re: HELP!!! Possible radiator issue

Sounds good I've taken a pic of your post and texting it to my mechanic...gonna see what he says. not sure how soon he will answer but it's worth a start. I'll post if/when he replies.
__________________
2003, GT, "ShuggaPlum", xenon bumper kit, custom grey/black CoverKing seat covers (front & back).
Sunrise: July 2002
Sunset: June 2018

http://www.math.uh.edu/~tai/Today/Clean3.jpg
Reply With Quote
  #7 (permalink)  
Old 09 Apr 2013, 01:51 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: HELP!!! Possible radiator issue

im going to say the clicking is the water leaking and getting on the belts also this wil cause them to slip and the alt will not charge depending on how bad the leak is it could be spraying water on the motor
Im guessing you dont want to tackle changing the radiator it is really one of the easiest fixes on a PT but you should really not drive it till its fixed if it overheats verry many times it will be a MAJOR repair
Reply With Quote
  #8 (permalink)  
Old 09 Apr 2013, 02:35 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 4
Default Re: HELP!!! Possible radiator issue

Thank you so much for your responses. You guys are so nice. And Teekypt thanks for doing that for me. I really appreciate it. I'll will wait patiently
Reply With Quote
  #9 (permalink)  
Old 09 Apr 2013, 06:40 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: HELP!!! Possible radiator issue

Quote:
Originally Posted by faguin View Post
Thank you so much for your responses. You guys are so nice. And Teekypt thanks for doing that for me. I really appreciate it. I'll will wait patiently
If you've over heated it a few times. I would severely suggest a compression check at the shop. If you have a cracked head, it could cause severe issues including the ones your having
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radiator Bleed Valve issue JoJoChan Tech & Performance Forum 7 25 Jul 2012 07:24 pm
The radiator fan [again] bogaz Tech & Performance Forum 43 23 Aug 2011 06:43 pm
Radiator fan mash35231 Tech & Performance Forum 3 14 Oct 2010 09:38 pm
radiator fan bbromero Tech & Performance Forum 4 08 Jun 2010 03:58 pm
Radiator 4b316 Tech & Performance Forum 3 26 Dec 2008 05:56 pm


All times are GMT -5. The time now is 04:27 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors