PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Turn signal is not working

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 28 Jun 2013, 07:48 pm
Fresh Cruiser
 
Join Date: Jun 2013
Posts: 3
Default Turn signal is not working

Hello, I hope that everyone is doing well!!! My 2006 PT cruiser have some electrical problems. The turn signal is not working, but its still flashing on the dashboard, I also tried the hazard light, its didn't work as well. First I thought the bulbs were blown up or something, but when I checked the fog-light , it was working fine.

I'm not really good with the electrical issue, If someone could help me out, I would be really appreciate
Reply With Quote
  #2 (permalink)  
Old 28 Jun 2013, 08:12 pm
Young Cruiser
 
Join Date: Apr 2013
Location: danville, va
Posts: 64
Default Re: Turn signal is not working

I would almost say it's the multi function switch but you say it flashes on the dash, I would try to disconnecting the battery and then hold the brake for a few seconds to drain any residual. Then reconnect battery, could be in the computer.
__________________
02' Touring
Reply With Quote
  #3 (permalink)  
Old 28 Jun 2013, 09:21 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Thumbs up Re: Turn signal is not working

Quote:
Originally Posted by robh View Post
I would almost say it's the multi function switch but you say it flashes on the dash, I would try to disconnecting the battery and then hold the brake for a few seconds to drain any residual. Then reconnect battery, could be in the computer.
I second that!.....I've read alot of posts relating a number of problems to the MFS....i.e-Headlights,Turn Signals,and especially Fog Lights.
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #4 (permalink)  
Old 29 Jun 2013, 08:29 am
Cool Cruiser
 
Join Date: Mar 2012
Location: Gibraltar, Michigan
Posts: 400
Default Re: Turn signal is not working

Quote:
Originally Posted by lichking00 View Post
Hello, I hope that everyone is doing well!!! My 2006 PT cruiser have some electrical problems. The turn signal is not working, but its still flashing on the dashboard, I also tried the hazard light, its didn't work as well. First I thought the bulbs were blown up or something, but when I checked the fog-light , it was working fine.

I'm not really good with the electrical issue, If someone could help me out, I would be really appreciate
The signal and 4 way flasher are the same filament, so if they are not working (and explain which one is not working), it is probably the bulb or socket.

Mine had a cooked socket on the right rear, and is replaceable, and available through the dealer for about $15.

The fog light is a total different animal, and has nothing to do with your signals.
__________________
A still runnin' 01 Limited,,all with a little prayer, and a lotta elbow grease
Red tint tails, chrome trimmed grille, custom towel rack buttonless flamed shifter, auto dimming rear view, Homelink remote transmitter, driver seat drawer, MOPAR sub, lowered 1" rear, MOPAR/Borla dual tipped exhaust, chrome trimmed GT gauge/airbag surround, front 35% tint, and the ever so important Fuzzy Dice
Reply With Quote
  #5 (permalink)  
Old 29 Jun 2013, 09:02 am
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: Turn signal is not working

i also had a bad socket. try turning on the hazards, then get out and tweak the bulb in the socket to see if it starts working. i bent the contact in the socket and it's been fine ever since.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield Wipers Turn On With Turn Signal or Bump... NewPTCruiserInPA General PT Cruiser Discussions 8 17 Dec 2013 09:10 am
Turn signal activates signal...and wipers? TF3 General PT Cruiser Discussions 2 19 Feb 2013 12:48 pm
Right front turn signal not working rctjroy Tech & Performance Forum 3 15 Sep 2012 04:26 pm
Turn Signal jmack General PT Cruiser Discussions 5 12 Apr 2005 11:57 am
blue turn signal bulbs that turn orange when in us Capt Kidd General PT Cruiser Discussions 1 04 Jun 2004 10:10 pm


All times are GMT -5. The time now is 11:29 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors