PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Well my cruiser is still alive! Minor issues need help with.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Jul 2013, 05:56 pm
Young Cruiser
 
Join Date: Apr 2009
Posts: 58
Default Well my cruiser is still alive! Minor issues need help with.

Im happy to say i got a second opinion on my crusier thanks to all of your suggestions on this thread here Valve chatter getting worse

I had a friend of a friend check it all out and it turns out it was the headgasket! He took the head off had to shave it down because there was a slight warp on it. he got it back from the machine shop and in perfect shape. He put a new water pump on her and new head gasket cleaned it all up and VOILA shes running again! Now its not perfect but its definately A LOT better than before. The problem's i am facing now are minor in my eyes but i wanted to run them past the fine group on these forums. You guys have helped me time and time again with advice that has been DEAD ON! So i cant thank you all enough for saving me thousands of dollars honestly thousands at this point.

Problem one is she used to turn over on a dime i mean no issue starting at all. Now its a bit of a struggle i can post video of it if you all like. But once she starts we are good. Timing issue maybe?

Problem 2 she overheats but not fully overheats know what i mean vern? After running for say an hour with the AC on she will start to climb in temp. It will get to the line just above the halfway point then i shut the ac off for 10 minutes while driving and shes good to go. Until i put the ac back on that is, and after about another 10-15 minutes she does the im getting hot needle dance. I have fully flushed the radiator and put new 50/50 mix in about a week ago and still same thing. AC Fan turns on high when it should but its not enough to keep her cool.

Any ideas on any of this would be appreciated if you need video let me know ill post it. You guys/gals really are the best thanks so much for any advice and help.
Reply With Quote
  #2 (permalink)  
Old 02 Jul 2013, 08:26 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,886
Default Re: Well my cruiser is still alive! Minor issues need help with.

Quote:
Originally Posted by invidious View Post
Im happy to say i got a second opinion on my crusier thanks to all of your suggestions on this thread here Valve chatter getting worse

I had a friend of a friend check it all out and it turns out it was the headgasket! He took the head off had to shave it down because there was a slight warp on it. he got it back from the machine shop and in perfect shape. He put a new water pump on her and new head gasket cleaned it all up and VOILA shes running again! Now its not perfect but its definately A LOT better than before. The problem's i am facing now are minor in my eyes but i wanted to run them past the fine group on these forums. You guys have helped me time and time again with advice that has been DEAD ON! So i cant thank you all enough for saving me thousands of dollars honestly thousands at this point.

Problem one is she used to turn over on a dime i mean no issue starting at all. Now its a bit of a struggle i can post video of it if you all like. But once she starts we are good. Timing issue maybe?

Problem 2 she overheats but not fully overheats know what i mean vern? After running for say an hour with the AC on she will start to climb in temp. It will get to the line just above the halfway point then i shut the ac off for 10 minutes while driving and shes good to go. Until i put the ac back on that is, and after about another 10-15 minutes she does the im getting hot needle dance. I have fully flushed the radiator and put new 50/50 mix in about a week ago and still same thing. AC Fan turns on high when it should but its not enough to keep her cool.

Any ideas on any of this would be appreciated if you need video let me know ill post it. You guys/gals really are the best thanks so much for any advice and help.




This is a good pic of the timing.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #3 (permalink)  
Old 03 Jul 2013, 02:53 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,266
Default Re: Well my cruiser is still alive! Minor issues need help with.

invid; check your coolant level before starting the car in the morning. The coolant level at the radiator cap should be within 1" of the top. The coolant in the reservoir tank should be about 1/3 full. This has nothing to do with hard starting. --- The radiator might be getting tired.
Reply With Quote
  #4 (permalink)  
Old 03 Jul 2013, 06:05 pm
Young Cruiser
 
Join Date: Apr 2009
Posts: 58
Default Re: Well my cruiser is still alive! Minor issues need help with.

Quote:
Originally Posted by pt06 View Post
invid; check your coolant level before starting the car in the morning. The coolant level at the radiator cap should be within 1" of the top. The coolant in the reservoir tank should be about 1/3 full. This has nothing to do with hard starting. --- The radiator might be getting tired.
Yeah they are 2 separate issues I know that. As far as coolant goes its not leaking anywhere and i have check both the reservoir and the radiator and both are at perfect levels.
Reply With Quote
  #5 (permalink)  
Old 03 Jul 2013, 10:04 pm
Young Cruiser
 
Join Date: Oct 2011
Posts: 81
Default Re: Well my cruiser is still alive! Minor issues need help with.

Quote:
Originally Posted by invidious View Post
Yeah they are 2 separate issues I know that. As far as coolant goes its not leaking anywhere and i have check both the reservoir and the radiator and both are at perfect levels.
Can you pulll the radiator from the car, the fault may be in the radiator. You can have it checked by a rad company for flow. Check the price of new rads if they say you need one at online shops.

With the hard starting these cas have a crank position sensor located above the starter. This could be par tof the problem, but check the coil for good spark and plug condition.
Reply With Quote
  #6 (permalink)  
Old 04 Jul 2013, 01:49 am
Young Cruiser
 
Join Date: Apr 2009
Posts: 58
Default Re: Well my cruiser is still alive! Minor issues need help with.

New coil plugs and wires put in when the head got put on.
Reply With Quote
  #7 (permalink)  
Old 04 Jul 2013, 12:36 pm
Cool Cruiser
 
Join Date: Sep 2009
Location: Formerly NawLins
Posts: 246
Default Re: Well my cruiser is still alive! Minor issues need help with.

Since the engine sounds like it was taken apart - new head gasket, head work, waterpump and hopefully timing belt and tensioner - I would go around to the back of the vehicle and smell for a leak! That is, be sure you are using antifreez, the orangish colored stuff, and smell for it coming through the exhaust. I had this problem with a car once.

Other than that - the cooling could be your cooling fan. They are electric and don't last forever. I replaced the one on my 06 about a month before I found the sweet deal I traded her in on. It could be started by hand - stick really - but would not start on its own. That was about $400 for part and labor, first non Mopar electric part I ever put in that car but it had a year warrantee and the mopar one only 90 day. Car had almost 100K on it at the time and a southern summer was coming.
__________________

12 Regal Turbo
06 PT - Base with BLING! TRADED 5/27/13
01 PT LE - Kid's Car - TRADED 01/13
01 Beetle Sport - SilverSport - 150+ MPH
93 Del Sol - 32+ MPG
90 F150
73 Mach1
Reply With Quote
  #8 (permalink)  
Old 04 Jul 2013, 03:33 pm
Young Cruiser
 
Join Date: Apr 2009
Posts: 58
Default Re: Well my cruiser is still alive! Minor issues need help with.

I'm using the green 50/50 mix not orange. As far as the the fan i had a new one installed "still under warranty btw" about 8 months ago. The fan does click on high when it starts to get hot like clockwork every time. I did take your advice and smelled for any leaking coolant after 20 minutes nothing.
Reply With Quote
  #9 (permalink)  
Old 04 Jul 2013, 07:47 pm
Cool Cruiser
 
Join Date: Sep 2009
Location: Formerly NawLins
Posts: 246
Default Re: Well my cruiser is still alive! Minor issues need help with.

Quote:
Originally Posted by invidious View Post
I'm using the green 50/50 mix not orange. As far as the the fan i had a new one installed "still under warranty btw" about 8 months ago. The fan does click on high when it starts to get hot like clockwork every time. I did take your advice and smelled for any leaking coolant after 20 minutes nothing.
Green works great in my fully cast iron 4.9L Straight Six, or my 351 Cleveland, but is not a good mix for the metals of the 2.4L Mopar engine in your car, even though it would have matched my paint better.

Glad there is no smell from the exhaust, it is hard to get with the Cat conveters these days. I am glad you got the fan done already too, but if I remember correctly (I had my mech change mine) there are 2 fans in the housing, the main one comes on whenever you turn on the A/C and the other when the engine is getting hot. My car was not overheating, the A/C just was not putting out good cold air when that fan was not running - and it blew off some 134a refrigerant when the system pressure got too high.
__________________

12 Regal Turbo
06 PT - Base with BLING! TRADED 5/27/13
01 PT LE - Kid's Car - TRADED 01/13
01 Beetle Sport - SilverSport - 150+ MPH
93 Del Sol - 32+ MPG
90 F150
73 Mach1

Last edited by SilverSport; 04 Jul 2013 at 07:50 pm.
Reply With Quote
  #10 (permalink)  
Old 07 Jul 2013, 12:21 am
Young Cruiser
 
Join Date: Apr 2009
Posts: 58
Default Re: Well my cruiser is still alive! Minor issues need help with.

Ok so i ran it by my mechanic friend today. He said and i quote "Because the head was milled down .2 mill i have a higher pressure in my cylinder heads. This is what is causing my long starts now." He said there is a trick to fix that by doubling up the head gasket to compensate for the metal that was shaved off the head. Is this correct has anyone of you heard of or done this yourselves?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Minor Details LovingMyPTCruiser Exterior Accessories Forum 6 04 Jun 2013 12:54 am
2003 CHRYSLER PT CRUISER TOURING. NO MOT. NOT. MINOR DAMAGE. EXCELLENT RUNNER/DRIVER deanweir Classifieds: For Sale/Trade 0 09 Dec 2012 06:35 am
Yes! Minnesota PT Cruiser Club is alive! Iamcaddy Midwest PT Forum 0 06 Jul 2010 11:12 am
help with a minor issue please!!! boother Tech & Performance Forum 3 06 Jul 2009 11:19 am
New Minor Mod.... Gear_Head Interior Accessories Forum 8 27 Sep 2003 01:25 am


All times are GMT -5. The time now is 03:16 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors