PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Engine Revs up and down by itself

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Jul 2013, 11:14 am
Fresh Cruiser
 
Join Date: Aug 2009
Posts: 15
Default Engine Revs up and down by itself

On engine start, the engine revs from about 800 rpm to about 1500 rpm. After it warms a bit it does settle down but still moves up and down. Any ideas.
BTW, this is the wife's car. I can't stand it as it is an engineering failure in my view.
Reply With Quote
  #2 (permalink)  
Old 23 Jul 2013, 11:54 am
Senior Cruiser
 
Join Date: Nov 2010
Location: oak creek, wi
Posts: 1,149
Default Re: Engine Revs up and down by itself

sounds like a vacuum leak to me.
__________________
2005 Toyota Camry LE Salsa Red (Wife's)
2002 Automatic N/A (Mine) Inferno Red
2016 Kia Soul Plus Black
Reply With Quote
  #3 (permalink)  
Old 23 Jul 2013, 12:06 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Engine Revs up and down by itself

Quote:
Originally Posted by soyomb View Post
sounds like a vacuum leak to me.
Me too. Check the lines coming from the brake booster. That's where I found the vacuum leak on mine.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 23 Jul 2013, 12:51 pm
Fanatic Cruiser
 
Join Date: Sep 2012
Location: Carson City NV
Posts: 675
Default Re: Engine Revs up and down by itself

Quote:
Originally Posted by rigger45 View Post
On engine start, the engine revs from about 800 rpm to about 1500 rpm. After it warms a bit it does settle down but still moves up and down. Any ideas.
BTW, this is the wife's car. I can't stand it as it is an engineering failure in my view.
Oh the old it's the wife's car bit! Yeah I was gonna go with that but now I find that I like the goofy little PT!

But sounds like a vacuum leak to me also. When I did the spark plugs (an adventure in itself!) A hose on the back of the manifold fell off and the car was doing what you described. I also found the PCV hose was cracked at both ends not causing a problem and will be replaced. There is an o ring that is held in place with a bracket that holds the throttle body to the manifold on the back right hand side of the manifold. I had to undo that bolt and bracket and it held a metal tube that goes into the manifold that has an O ring in and the O ring was broken but I stuffed it back in till I get it replaced.

Basically if you do the spark plugs which it might need anyway? Youd find these hoses as you go along.

The old school way to find a vacuum leak is just get a can of throttle body cleaner (02 safe). And spray the crap out of everything that looks like a vacuum line! If the rpm goes up...you've found your leak!

Some of the younger crowd voiced concern about this method but I've done it for years and haven't blown anything up yet! So consider yourself warned!
Reply With Quote
Reply

Tags
engine rpm


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto Trans problem? Engine revs, no go tlturbo Tech & Performance Forum 6 25 Jul 2013 05:06 am
Weird noise when engine revs luckymagruder Tech & Performance Forum 2 20 Oct 2012 02:19 pm
Engine Revs and then dies at start Chas777 Tech & Performance Forum 3 12 Jun 2011 06:53 pm
Engine revs up automatically ProDigit General PT Cruiser Discussions 2 07 Feb 2011 07:09 pm
Engine revs while idling when air or heat is on mags593 Tech & Performance Forum 2 14 Apr 2010 09:34 pm


All times are GMT -5. The time now is 07:37 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors