PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
having electrical issues

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Sep 2013, 02:58 pm
Fresh Cruiser
 
Join Date: Sep 2013
Posts: 3
Question having electrical issues

Hello fellow PT owners. I have a two electrical issues that I just can't figure out the problem or the solution to. If I could get any input and suggestions, it would be greatly appreciated.

1) When I was given the car, the door locks would lock and unlock randomly by themselves 24/7. I took the car to the dealership to do an electrical diagnostic, but nothing concrete came out. They replaced the RKE (remote keyless entry) module and remote but those didn't solve the problem. So for now, I have the wires unplugged from the RKE module, due to the fact that the constant locking and unlocking was draining my battery.

2) I noticed on my old multifunction switch, my fog lights weren't working. So this past April, I decided to buy a new one to replace it. When I did so, the fog lights started working, but then the hazards and turn signals stopped working altogether. I replaced the flasher relay on the back of the switch with 3 new ones, but they didn't help. So as of now, I'm riding around with no turn signals or hazards and I would love to have them back. Does anyone have an idea as to why they would stop working after swapping the switches?....Also, my dad and I thought it was just a blown fuse. But supposedly, when he would put a new fuse in its spot, it would blow once it was locked in place.

I love my PT to death, but she's not showing me any love back! lol. Can somebody PLEASE tell me what's going with my baby?
__________________
'01 Limited Edition - "Lola", 8000K SuperVision HIDs, Hella Optilux Yellow Fogs, Kenwood Head Unit

Last edited by PT_L01A; 03 Sep 2013 at 03:03 pm.
Reply With Quote
  #2 (permalink)  
Old 03 Sep 2013, 05:07 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,886
Default Re: having electrical issues

If you are blowing a fuse, you have a short to ground. You need to check that circuit . I would check the plug in the column and the replacement switch. For the new problem.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #3 (permalink)  
Old 03 Sep 2013, 06:12 pm
Fresh Cruiser
 
Join Date: Sep 2013
Posts: 3
Default Re: having electrical issues

Someone else had mentioned the possibility of a short to ground as well, so I think I will check that out. I hope it works!! Much obliged!
__________________
'01 Limited Edition - "Lola", 8000K SuperVision HIDs, Hella Optilux Yellow Fogs, Kenwood Head Unit
Reply With Quote
  #4 (permalink)  
Old 04 Sep 2013, 08:24 am
chigger_ns's Avatar
Cool Cruiser
 
Join Date: May 2010
Posts: 278
Default Re: having electrical issues

Door locks- Check for broken wires around the door hinge area. of the front doors. Could be a chafed wire too.
__________________
2001 PT 5 speed Touring Edition
Eibach Pro Springs, Energy Suspension HyperFlex Master Kit bushings, 17" RTX Euro wheels, K&N drop in air filter, MotoMaster flat plate AGM battery, KYB GR2 shocks and struts, Booger standard shifter bushings, Ooogah horn.
Reply With Quote
  #5 (permalink)  
Old 04 Sep 2013, 10:15 pm
Fresh Cruiser
 
Join Date: Sep 2013
Posts: 3
Default Re: having electrical issues

Roger that. I'll try to take a look at it this weekend. Thanks for the suggestions you two.
__________________
'01 Limited Edition - "Lola", 8000K SuperVision HIDs, Hella Optilux Yellow Fogs, Kenwood Head Unit
Reply With Quote
Reply

Tags
2001 limited edition, door locks, electrical problems, hazards, turn signals


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 pt cruiser electrical issues deck60 Tech & Performance Forum 3 19 Dec 2012 08:25 pm
'01 Electrical Issues Mabel General PT Cruiser Discussions 1 15 Apr 2012 06:22 pm
no headlights and intermittent electrical issues seanparola Tech & Performance Forum 1 20 Mar 2011 04:01 pm
Help Please ! Electrical issues. thegooch2 Tech & Performance Forum 5 16 Aug 2010 06:53 am
Electrical Issues? SillyEB Tech & Performance Forum 5 02 Jul 2009 10:52 am


All times are GMT -5. The time now is 07:53 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors