PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
PT starting Issues

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04 Sep 2013, 10:46 pm
SaberLima's Avatar
Fresh Cruiser
 
Join Date: Sep 2013
Location: Texas
Posts: 1
Default PT starting Issues

HI there! I have a 2004 Touring Limited Edition and recently I been having issues starting the car. Its not the battery, I checked already, basically when I turn the key in the ignition to start the car it does nothing, the battery is fine like I said, because the radio and lights and windows or even the ac work, but the engine wont start! Its doesnt do anything! Sometimes if I leave it for a while and try again it will start, other times I have to push down the brake real hard and force the key to start the car, but usally all these tricks work once or twice..... I think it might be the alarm but I took it to the dealer and they said it has nothing to do with the alarm, they said it might be a switch in the ignition..... they told me I needed to pay aroun 700 to fix it.... anyone might have and idea before I break the bank? .... I not quite convinced with the dealers explanation and I really want to fix this! Please help!
Reply With Quote
  #2 (permalink)  
Old 04 Sep 2013, 11:59 pm
Fresh Cruiser
 
Join Date: Aug 2013
Posts: 15
Default Re: PT starting Issues

In my previous starting problems(6 times or so), it would mostly end up being grounding problems(and I recently read about the positive cable giving problems and needing replaced). I would have problems of little or no cranking, all lights going out, dash gauges flopping back and forth, clicking,etc.

Last time was a few weeks ago. This time I had someone go in and clean 8 or so grounding points(battery, starter, frame, etc), plus they applied contact protector on each. It's been much better now. Brighter lights, no dash light flickering, etc.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting Issues - please help selkov Tech & Performance Forum 5 10 Sep 2013 09:15 am
Starting issues ... *sigh* nickdel Tech & Performance Forum 20 07 Feb 2013 01:35 am
Starting Issues pinoyPT General PT Cruiser Discussions 8 23 Nov 2012 06:19 pm
01 PT Cruiser starting issues rampagent69 Tech & Performance Forum 1 28 Jun 2011 09:12 am
2006 PT starting issues thebriarman Tech & Performance Forum 5 25 Jul 2010 10:13 pm


All times are GMT -5. The time now is 05:31 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors