PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
turn signals

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Sep 2013, 06:44 pm
Fresh Cruiser
 
Join Date: Feb 2013
Posts: 10
Default turn signals

So my daughter calls me and tells me her 2006 pt is not running, has a flat, and turn signals are acting up. Bought new tire, found her battery cable had shorted against tranny fill tube, replaced one ruined battery, now for the turn signals left front and rightr rear will not flash and i can not find a flasher in her car. any ideas or help would be greatly appreciated. Thanks yukon phoenix az
Reply With Quote
  #2 (permalink)  
Old 07 Sep 2013, 09:28 pm
fy9-03pt's Avatar
Cool Cruiser
 
Join Date: Apr 2003
Location: Maryland, USA.
Posts: 293
Default Re: turn signals

You have a fuse panel under the hood .ID marking are on the inside of cover. Should be over right near the Battery . You might want to check the other fuses while in there. If it shorted out your lucky.
__________________
Robert
Reply With Quote
  #3 (permalink)  
Old 08 Sep 2013, 06:47 pm
Fresh Cruiser
 
Join Date: Feb 2013
Posts: 10
Default Re: turn signals

thanks robert
Reply With Quote
  #4 (permalink)  
Old 08 Sep 2013, 08:27 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,613
Cool Re: turn signals

Turn Signals!
They still have those on cars.
Most of the SUVs and pickup around here don't have any.


Check the obvious - shorted bulbs
Then #3....MF switch.
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
  #5 (permalink)  
Old 08 Sep 2013, 08:31 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: turn signals

It's an 06 so it doesn't have fuses for the turn signals nor much else. It uses the TIPM to manage the circuits. You can try unhooking the battery and letting the TIPM reset. If that doesn't work then it will need to go to the dealer. They can reflash it and see if that works or it may need replacing which is very expensive. The 06's are notorious for TIPM issues. They seem to have figured it out in later years.
Reply With Quote
  #6 (permalink)  
Old 10 Sep 2013, 11:01 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: turn signals

The flasher is a small module that plugs onto the turn signal arm - but it isn't your problem since only 1 front and one rear don't work - I assume you replaced bulbs and examined the bulb sockets? Try swapping the bulbs from working to non-working sides to check.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #7 (permalink)  
Old 10 Sep 2013, 01:13 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: turn signals

Quote:
Originally Posted by quicksilverdon View Post
The flasher is a small module that plugs onto the turn signal arm - but it isn't your problem since only 1 front and one rear don't work - I assume you replaced bulbs and examined the bulb sockets? Try swapping the bulbs from working to non-working sides to check.
There is no flasher on the 06 and ups. At not least one I can find. My guess is it too is built into the TIPM. Where you are describing is on the first generation. When I installed my cruise control on my 09 I was surprised to find that there was no flasher module there.
Reply With Quote
  #8 (permalink)  
Old 10 Sep 2013, 01:44 pm
Regular Cruiser
 
Join Date: Aug 2013
Location: OC by the Sea
Posts: 144
Default Re: turn signals

Quote:
Originally Posted by Ray_Dockrey View Post
There is no flasher on the 06 and ups. At not least one I can find. My guess is it too is built into the TIPM. Where you are describing is on the first generation. When I installed my cruise control on my 09 I was surprised to find that there was no flasher module there.
You are correct. Flashing and all exterior illumination is controlled by the TIPM. A short to ground or voltage on the circuit will set a code. OP - have you checked for any codes set?

Some possible codes would be:
B163B - Front Left Turn Control Circuit Low
B163C - Front Left Turn Control Circuit High
B163F - Front Right Turn Control Circuit Low
B1640 - Front Right Turn Control Circuit High
B1643 - Rear Left Turn Control Circuit Low
B1644 - Rear Left Turn Control Circuit High
B1647 - Rear Right Turn Control Circuit Low
B1648 - Rear Right Turn Control Circuit High

The circuits will need to be tested for a short to ground, short to voltage or an open circuit. An open circuit means that there is no continuity between the connector at the TIPM and the suspect lamp location. You may need a long jumper wire to perform these tests.

The driver circuit is on pin 1 at the bulb location.

TIPM locations are listed below:
Front left TIPM location is C4, pin 1.
Front right TIPM location is C4, pin 2.
Rear left TIPM location is C3, pin 4.
Rear right TIPM location is C3, pin 6.

If all wiring checks out fine and there are no shorts to ground, voltage or open circuits, then the TIPM drivers are bad and the TIPM will need to be replaced.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PT turn signals (or lack of) dgranros Tech & Performance Forum 6 05 Jan 2015 01:54 pm
Changed MFS now no turn signals. Help! Mstickle General PT Cruiser Discussions 3 03 Oct 2012 06:47 pm
turn signals AlexJB Exterior Accessories Forum 6 12 May 2008 08:12 pm
Help with Stealth turn signals toplessPT Exterior Accessories Forum 4 16 Mar 2005 10:43 am


All times are GMT -5. The time now is 01:40 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors