PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
ANOTHER RANDOM CODE???????

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01 Oct 2013, 10:47 pm
Fresh Cruiser
 
Join Date: Oct 2013
Location: Ft. Worth, Tx.
Posts: 13
Default ANOTHER RANDOM CODE???????

I have been pulling what I have left of my hair over the issues I keep having with my wife's Pt. We bought it new in "04. It's a touring 2.4 turbo with 115k on it. Couple months back the mil light came on and the trac control, abs, brake, and airbag. Codes were for iac module and o2 sensor.
Funny thing is, is that the car isn't equipped with abs or trac control. I bought an after market iac module. Yeah I know, wasted money. Three days later it wouldn't idle. So off to the dealership to get an oem iac module. Everything seemed fine for about a week(except the abs, brake, and trac lights still on). I think the fluid sensor in the brake reservoir must be bad. Then the mil comes on, the speedometer quits and it dies every time you stop. Clear codes everything is fine in the morning. In the evening having the same issue. Keeps popping random codes. 0032, 0038, random misfire, oil sensor, evap system, ect. Today I checked wiring, installed new plugs, and a new gas cap. Drove for about and hr. let it idle in the drive for about an hr. No problems except the brake, abs, and trac lights still on. So this eve we were going up the street to a friends.
We drove the wife's car because I wanted to insure her it was good to drive to work tomorrow. Started to leave and poop, the mil light comes on, won't excelerate, speedometer won't work, running erratic, airbag light, and dies when I stop.
Codes were 0032, 0038, and 0508. I cleared the codes and left my reader plugged in. I drove about a half mile and the mil light came back on. Codes were 0032 and 0038 again. I know what all these codes are, so please don't give me a list. I'm hoping someone on here can point me in the right direction as to why I keep getting random codes. I'm thinking MAP sensor or the ecm has lost it's mind. The only codes that have been consistent are the o2 sensor codes. My code reader says the o2 sensors pass when tested. I'm ready to here some opinions to what everyone thinks could be causing this. I should mention that I replaced the cam shaft sensor when I replaced the iac module because it had a code.
Spence

Last edited by rcjunky007; 01 Oct 2013 at 10:50 pm.
Reply With Quote
  #2 (permalink)  
Old 01 Oct 2013, 11:11 pm
Banned
 
Join Date: May 2011
Location: Dallas Texas
Posts: 3,722
Default Re: ANOTHER RANDOM CODE???????

Hello

Welcome to the forum

What took you so Long to get here?

What made you purchase the pt? Style? Love at first sight?

Post some pics of your pt

Have you done any mods?

Hopefully you aren't just using us a resource and never intend to come back.

Once again, post some pics
randyincctx likes this.
Reply With Quote
  #3 (permalink)  
Old 02 Oct 2013, 06:44 am
Fresh Cruiser
 
Join Date: Oct 2013
Location: Ft. Worth, Tx.
Posts: 13
Default Re: ANOTHER RANDOM CODE???????

Actually, we have owned two cruisers. I bought the wife her first pt for mothers day in '02. She was solid black. In '04 when the turbo model came out, I had to test drive one. Pulled in the dealership and there set a two tone black and silver touring addition. A salesman met me at the door and asked if he could help me? I replied sure. I want to test drive that one. The next day I told my wife her 02 had a recall and traded it in on the 04. Happy anniversary I told her when I drove the 04 into the drive. Man I did not realize my wife had such a led foot. 305hp! So you see, we have been a pt family for a while now. I'll try to get a pic up later. I searched for this forum last night after clearing the codes again. I understand that there are people out there that "diy" and don't want anyone else under THEIR hood.
Spence
Reply With Quote
  #4 (permalink)  
Old 02 Oct 2013, 08:00 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: ANOTHER RANDOM CODE???????

Reminded me of this recent thread:
2004 PT, NON TURBO, Need help with 0032, 0038 and at times 0300, many parts replaced.

hope it helps.

Also, at 115K miles, hope you have done your timing belt - I don't see that being you current problem, just a side note.
I have 116K on mine, had belt done at about 90K miles.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles

Last edited by quicksilverdon; 02 Oct 2013 at 08:02 am.
Reply With Quote
  #5 (permalink)  
Old 02 Oct 2013, 08:41 am
Fresh Cruiser
 
Join Date: Oct 2013
Location: Ft. Worth, Tx.
Posts: 13
Default Re: ANOTHER RANDOM CODE???????

Water pump started leaking at 84k. I had the timing belt replace since it had to be removed anyway to get to the water pump. Thanks for the link. I searched the forum for results to my issue before starting this thread but must have missed it. I'm leaning towards the ecu being the culprit. I have changed a few sensors, but know that random codes are usually the sign for something else wrong. Especially o2 sensors. Most any of the other sensors can cause an o2 code. I am thinking of replacing the wiring harness and the ecu. Back in '89 (yeah I'm old) I bought my wife a olds cutty tbi. After the warranty ran out the check engine light came on. A friend showed me how to jump a+b and the mil would blink the codes. I must have spent $1k on sensors over the next couple months. My cousin works at a gm dealership and electronics is his specialty. I called him and he tells me "check the O ring on the injector sitting in top of the throttle body. It's probly cracked and dripping." Sure enough a 10cent O ring was the problem. I learned to look past the codes and check for another issue that could cause that code pop. But the only consistence with my issue is the o2 codes.
Spence
Reply With Quote
  #6 (permalink)  
Old 02 Oct 2013, 08:42 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,886
Default Re: ANOTHER RANDOM CODE???????

Quote:
Originally Posted by rcjunky007 View Post
I have been pulling what I have left of my hair over the issues I keep having with my wife's Pt. We bought it new in "04. It's a touring 2.4 turbo with 115k on it. Couple months back the mil light came on and the trac control, abs, brake, and airbag. Codes were for iac module and o2 sensor.
Funny thing is, is that the car isn't equipped with abs or trac control. I bought an after market iac module. Yeah I know, wasted money. Three days later it wouldn't idle. So off to the dealership to get an oem iac module. Everything seemed fine for about a week(except the abs, brake, and trac lights still on). I think the fluid sensor in the brake reservoir must be bad. Then the mil comes on, the speedometer quits and it dies every time you stop. Clear codes everything is fine in the morning. In the evening having the same issue. Keeps popping random codes. 0032, 0038, random misfire, oil sensor, evap system, ect. Today I checked wiring, installed new plugs, and a new gas cap. Drove for about and hr. let it idle in the drive for about an hr. No problems except the brake, abs, and trac lights still on. So this eve we were going up the street to a friends.
We drove the wife's car because I wanted to insure her it was good to drive to work tomorrow. Started to leave and poop, the mil light comes on, won't excelerate, speedometer won't work, running erratic, airbag light, and dies when I stop.
Codes were 0032, 0038, and 0508. I cleared the codes and left my reader plugged in. I drove about a half mile and the mil light came back on. Codes were 0032 and 0038 again. I know what all these codes are, so please don't give me a list. I'm hoping someone on here can point me in the right direction as to why I keep getting random codes. I'm thinking MAP sensor or the ecm has lost it's mind. The only codes that have been consistent are the o2 sensor codes. My code reader says the o2 sensors pass when tested. I'm ready to here some opinions to what everyone thinks could be causing this. I should mention that I replaced the cam shaft sensor when I replaced the iac module because it had a code.
Spence
I would say that given the wide scope of codes. That your problem is the PCM. You can order these buy the number on the one in the car. They are remanufactured. They program to your vin and just plug and play. Unhook the battery first. And then you send them your old one in the box your new one came in. I found mine through a vender on eBay. Look for free shipping both ways. My diagnoses is my opinion and given I can't put hands on and make this determination for myself. It is just my humble opinion. But you could still a a legitament code to deal with in the case of the continuous code.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #7 (permalink)  
Old 02 Oct 2013, 08:56 am
Fresh Cruiser
 
Join Date: Oct 2013
Location: Ft. Worth, Tx.
Posts: 13
Default Re: ANOTHER RANDOM CODE???????

I can deal with a continuous code. But the random codes will drive you crazy. LOL!

Anyone know a good place to purchase a new wiring harness for the pcm?
Spence
Reply With Quote
  #8 (permalink)  
Old 02 Oct 2013, 03:23 pm
Banned
 
Join Date: May 2011
Location: Dallas Texas
Posts: 3,722
Default Re: ANOTHER RANDOM CODE???????

305hp?

What mods have you done????

Pics of this beast , particulary the engine!

Sounds like a beast!!!


Quote:
Originally Posted by rcjunky007 View Post
Actually, we have owned two cruisers. I bought the wife her first pt for mothers day in '02. She was solid black. In '04 when the turbo model came out, I had to test drive one. Pulled in the dealership and there set a two tone black and silver touring addition. A salesman met me at the door and asked if he could help me? I replied sure. I want to test drive that one. The next day I told my wife her 02 had a recall and traded it in on the 04. Happy anniversary I told her when I drove the 04 into the drive. Man I did not realize my wife had such a led foot. 305hp! So you see, we have been a pt family for a while now. I'll try to get a pic up later. I searched for this forum last night after clearing the codes again. I understand that there are people out there that "diy" and don't want anyone else under THEIR hood.
Spence
Reply With Quote
  #9 (permalink)  
Old 06 Feb 2014, 12:26 pm
Fresh Cruiser
 
Join Date: Oct 2013
Location: Ft. Worth, Tx.
Posts: 13
Default Re: ANOTHER RANDOM CODE???????

Wanted to update.

I installed a ground strap from the battery to the strut. Cleared the codes and took the car into a friends shop. He had it for ten days. Driving every day. Called me with updates every day. He could not get it to pop a code. Seems I fixed my own issue. Several months have gone by and no codes.

I do however still have the abs, trac, and brake lights on. When they first came on last year I pulled both the front wheels to check sensors. Guess what? The car isn't equipped with abs or traction control. So I turned my attention to the sensor in the brake fluid reservoir. The foam float that the level sensor reads was stuck. So I pulled the reservoir and cleaned it. The lights are still on. I've been shopping for a reservoir but everyone wants to sell the master cylinder with it. The dealership wants $73 for that little plastic tank. I finally found a salvage yard willing to sell just the reservoir for $25. I'll update if this solves the issue with the lights. I read on a couple of forums that the cluster can cause these lights to come on as well. So I'm hoping that isn't my issue.
Reply With Quote
  #10 (permalink)  
Old 06 Feb 2014, 12:30 pm
Fresh Cruiser
 
Join Date: Oct 2013
Location: Ft. Worth, Tx.
Posts: 13
Default Re: ANOTHER RANDOM CODE???????

Quote:
Originally Posted by Busa_Powered View Post
305hp?

What mods have you done????

Pics of this beast , particulary the engine!

Sounds like a beast!!!
I was told by the salesman that was the horse power. After your post I done a little research to find it only puts out 230hp stock. Sorry for the confusion.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
random stalling TicketMagnet Tech & Performance Forum 4 19 Jun 2017 02:51 pm
random shudder edb General PT Cruiser Discussions 4 18 Dec 2012 06:57 pm
1/13 Random PT art Chromenut General PT Cruiser Discussions 7 21 Oct 2012 10:44 pm
Random PT Art for 1/12 Chromenut General PT Cruiser Discussions 1 12 Jan 2012 02:31 pm
error code ques-... got a p0300- random misfire... batta Tech & Performance Forum 4 18 Apr 2010 03:26 pm


All times are GMT -5. The time now is 07:36 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors