PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Coolant questions!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Nov 2013, 08:20 pm
Fresh Cruiser
 
Join Date: Nov 2013
Location: Harrison, New York
Posts: 33
Default Coolant questions!

Hi,
Just bought my PT and I am already having trouble with the heater. When I got it it blew hot air for a while, then cold, but as of today it is blowing only lukewarm air. I noticed that my coolant level is a little low, and the !diot who I bought it from replaced the coolant with some blue stuff. Could the incorrect coolant destroy the heater core? Is this a common problem with these cars? (heater core) How difficult it is to replace it in a 06? Any help would be greatly appreciated!
Reply With Quote
  #2 (permalink)  
Old 07 Nov 2013, 08:27 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Coolant questions!

I suppose it's possible the wrong coolant could clog, but more likely you have air in the system...
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 07 Nov 2013, 09:56 pm
2step's Avatar
Senior Cruiser
 
Join Date: Oct 2004
Location: New Braunfels, Texas.
Posts: 1,672
Default Re: Coolant questions!

I'm not sure what to tell you about the coolant. To be safe, replace it with the correct stuff.

If your coolant level is low enough, that can cause the heater to blow cold. Do the simple things first. Get your coolant at the correct level and see if that gets the heat working. A thermostat stuck open can also cause the system to not quite heat up and you will feel the difference in the heater output.

Usually a failed heater core will leak and it's less common for it to be plugged. Inspecting the "blue" stuff when you dump it should give you a clue to the possibility of any plugging. Changing a heater core is a big deal on just about any car. I hope you don't have to go there.
Reply With Quote
  #4 (permalink)  
Old 07 Nov 2013, 11:12 pm
Fresh Cruiser
 
Join Date: Nov 2013
Location: Harrison, New York
Posts: 33
Default Re: Coolant questions!

Thanks for the quick reply. Well, I am going to the dealer tomorrow to flush the system and put the correct stuff in it, and then we will see. I really hope it is just that and not something more serious. I did replace a heater core in my '78 Deville a couple months ago, but I rather not do it on this car...
Reply With Quote
  #5 (permalink)  
Old 08 Nov 2013, 09:07 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,895
Default Re: Coolant questions!

Quote:
Originally Posted by yenciny View Post
Thanks for the quick reply. Well, I am going to the dealer tomorrow to flush the system and put the correct stuff in it, and then we will see. I really hope it is just that and not something more serious. I did replace a heater core in my '78 Deville a couple months ago, but I rather not do it on this car...
I think you need to find out why you are loosing coolant. No mater what color it is. You will keep loosing fluid until you address the why.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #6 (permalink)  
Old 08 Nov 2013, 04:21 pm
Fresh Cruiser
 
Join Date: Nov 2013
Location: Harrison, New York
Posts: 33
Default Re: Coolant questions!

I was not losing coolant, it was low when I got it a couple days ago.
Just got it back from the dealer, system flushed out, still lukewarm air comes out, no leaks, technician says it is probably the heater core. I am really really disappointed right now. I think I will have to get rid of it. Winter is here, and there is no way I will spend another thousand $ on this one. Any ideas?
I could still try and change the thermostat, but they say that it is fine...
Reply With Quote
  #7 (permalink)  
Old 08 Nov 2013, 05:27 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: Coolant questions!

what does the temp guage on the instrument panel say? if it is right in the middle, not hot, not cold, straight horizontal, the thermostat is fine. for sure.

are you sure the temperature adjustment knob on the heater control panel is functioning properly? maybe something stupid is disconnected, or not actuating all the way. i've NEVER read on here about cool heat due to a heater core. ive read about them leaking, but never clogging. it could still have air in the system, i doubt it, but it can happen.

Last edited by rob342; 08 Nov 2013 at 05:32 pm.
Reply With Quote
  #8 (permalink)  
Old 08 Nov 2013, 05:32 pm
Fresh Cruiser
 
Join Date: Nov 2013
Location: Harrison, New York
Posts: 33
Default Re: Coolant questions!

On the way home from the dealership I noticed, that if I pushed the car, the heat would work fine, but standing at a light the air would turn cold again. The car does not overheat, stays at halfway, and warms up there pretty quick. But the engine does not seem to be warm enough for me. After driving it about 5 miles pretty hard, the hoses are not very hot. And it is not freezing out there. Besides this car gets terrible gas mileage, about 16 miles a gallon average, and I put Shell V-power in it... So I am still thinking it could be the thermostat, but the dealer says it is fine. Any thoughts on that?
Reply With Quote
  #9 (permalink)  
Old 08 Nov 2013, 05:37 pm
Fresh Cruiser
 
Join Date: Nov 2013
Location: Harrison, New York
Posts: 33
Default Re: Coolant questions!

Actually, the heater adjuster button makes a funny "thump" when I twist it all the way to max heat. I never really payed much attention to that I thought was normal, never had a Chrysler of this vintage. Have to check it out tomorrow. But there is no leak, for sure, the dealership confirmed it as well. How hard it is to take that panel apart to get access to that knob?
Reply With Quote
  #10 (permalink)  
Old 08 Nov 2013, 05:41 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: Coolant questions!

Quote:
Originally Posted by yenciny View Post
Actually, the heater adjuster button makes a funny "thump" when I twist it all the way to max heat. I never really payed much attention to that I thought was normal, never had a Chrysler of this vintage. Have to check it out tomorrow. But there is no leak, for sure, the dealership confirmed it as well. How hard it is to take that panel apart to get access to that knob?
mine makes no thump. the air sound just gets a little quieter when i turn it from cool to hot.

to get the panel off, you pry out the window switch from the top and remove a screw, that's it. then you pull the panel off and all the knobs fall on the floor. it's kinda funny, and it's easy.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant flush questions. konadave Tech & Performance Forum 5 15 Jul 2013 03:56 am
Troubleshoot coolant leak: Photo of Coolant on top of engine radiator cap MarcusO Tech & Performance Forum 7 27 Apr 2013 09:16 am
2001 PT Timingbelt and coolant questions White93z34 Tech & Performance Forum 8 07 Jan 2013 12:58 am
2 more questions..noobe questions.. BarbieCar General Turbo Discussions 9 20 May 2012 07:32 pm
Flushed the coolant today, got questions. Dill Tech & Performance Forum 12 12 Jun 2011 11:44 am


All times are GMT -5. The time now is 04:08 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors