PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Well, THAT didn't take long...

 
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 Nov 2013, 06:06 pm
Fresh Cruiser
 
Join Date: Oct 2013
Posts: 42
Unhappy Well, THAT didn't take long...

I've had the PT for just over a month. Today, on my way home from work, I notice the engine warning light is on.

*sigh*

I see the owner's manual says to have it serviced if "...the light stays on through several of your typical driving cycles." So, I'm trying not to let it get me down.
Reply With Quote
  #2 (permalink)  
Old 21 Nov 2013, 06:11 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Well, THAT didn't take long...

NO, NO, NO.

Follow the steps I've outlined in this link and get the fault code yourself. Then come back here and let us know what you found out. We can walk you through almost any fault you come up with.

How to retrieve fault codes.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 21 Nov 2013, 06:17 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,895
Default Re: Well, THAT didn't take long...

Quote:
Originally Posted by CREWZIN View Post
NO, NO, NO.

Follow the steps I've outlined in this link and get the fault code yourself. Then come back here and let us know what you found out. We can walk you through almost any fault you come up with.

How to retrieve fault codes.
Yes yes yes, what CREWZIN said.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #4 (permalink)  
Old 21 Nov 2013, 06:25 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,823
Default Re: Well, THAT didn't take long...

There are several places in your home town in IL that you can get a free diagnostic scan and DTC reset.

IMO you should get this done with a proper Diagnostic scan tool. Make sure to write down all the DTC's that may come up before they are cleared.

Have the any codes cleared and recheck again after you cycle the engine at least one time. Many codes could be because of anomalies and may have correct themselves. So by clearing them and rechecking you save your self looking in area's that were not an issue.

I personally do not care for the self key check for DTCs as they are not always accurate.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #5 (permalink)  
Old 21 Nov 2013, 06:37 pm
rckstein's Avatar
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: Well, THAT didn't take long...

Quote:
Originally Posted by Travler View Post
I've had the PT for just over a month. Today, on my way home from work, I notice the engine warning light is on.

*sigh*

I see the owner's manual says to have it serviced if "...the light stays on through several of your typical driving cycles." So, I'm trying not to let it get me down.
Yeah, don't give up so easliy! I've had the "check engine" light come on for something as silly as the gas cap. Several years ago I had replaced the stock cap with an aftermarket locking cap. The vehicle was fine for quite some time then the "check engine" light started coming on. Then I read somewhere where PT's don't like aftermarket gas caps so I then replaced it with a Chrysler locking cap. All has been fine since then.

You'll learn to love your PT!

Reply With Quote
  #6 (permalink)  
Old 21 Nov 2013, 07:01 pm
Fresh Cruiser
 
Join Date: Oct 2013
Posts: 42
Thumbs up Re: Well, THAT didn't take long...

OK OK OK

Thanks for the tip! The code is P0551. After it showed that code, it then stated it was donE, so at least it doesn't appear that there are multiple things wrong.

A quick search of this site suggests that P0551 is a power steering pressure sensor switch; is that correct? If so, what remedy is suggested for a rather mechanically-impaired PT owner?
Reply With Quote
  #7 (permalink)  
Old 21 Nov 2013, 07:13 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,895
Default Re: Well, THAT didn't take long...

Quote:
Originally Posted by Travler View Post
OK OK OK

Thanks for the tip! The code is P0551. After it showed that code, it then stated it was donE, so at least it doesn't appear that there are multiple things wrong.

A quick search of this site suggests that P0551 is a power steering pressure sensor switch; is that correct? If so, what remedy is suggested for a rather mechanically-impaired PT owner?
Check the fluid level and get the code cleared. wait till to see if it happens again.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #8 (permalink)  
Old 21 Nov 2013, 07:34 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Well, THAT didn't take long...

Quote:
Originally Posted by Busted_PT View Post
Check the fluid level and get the code cleared. wait till to see if it happens again.
Yup.
What year is your PT? All but the earliest ones use ATF+4 in power steering.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #9 (permalink)  
Old 21 Nov 2013, 07:41 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Well, THAT didn't take long...

If or when you want to do something about it after the code comes back and you want to do it yourself, we can try to help.

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #10 (permalink)  
Old 21 Nov 2013, 07:56 pm
Fresh Cruiser
 
Join Date: Oct 2013
Posts: 42
Question Re: Well, THAT didn't take long...

Quote:
Originally Posted by quicksilverdon View Post
Yup.
What year is your PT? All but the earliest ones use ATF+4 in power steering.
Don, it's a 2005 GT.

Crewzin, assuming the fluid isn't low and that the light doesn't go out on its own, would it be a reasonable first troubleshooting step to unplug the switch, ensure that the contacts are clean, reattach switch, and see if the light goes out?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed Motor Mount-That didn't last long royleroyleroy General PT Cruiser Discussions 8 20 Jul 2012 02:25 pm
Didn't know this.... turbomangt Stage Turbo Kits 5 19 Jan 2007 12:07 pm
Why Oh Why didn't I buy it? jmack General PT Cruiser Discussions 3 02 Sep 2004 11:01 am
It's a long, long drive to Germany... Ed Lim Exterior Accessories Forum 0 05 Jun 2003 03:33 am


All times are GMT -5. The time now is 07:16 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors