PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
HELP! New PT owner having issues

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Nov 2013, 08:20 pm
Fresh Cruiser
 
Join Date: Nov 2013
Posts: 10
Default HELP! New PT owner having issues

I have a 2005 Chrysler PT Cruiser Turbo. It's is acting like a rev limiter is on it if I get into the gas. Usually around 3500-4000 RPMs and mostly from 2 to 3 gear. It was throwing a code for the map sensor (biometric sensor) Replaced that. Now saying it's the throttle sensor. And now blowing white smoke and loses power and sometimes shuts off. If let idle it runs then stutter at low RPMS and shuts off. Is it the throttle sensor causing that?!

Thanks!
Reply With Quote
  #2 (permalink)  
Old 23 Nov 2013, 09:43 pm
Banned
 
Join Date: May 2011
Location: Dallas Texas
Posts: 3,722
Default Re: HELP! New PT owner having issues

Guess you like monk huh?

Pretty sad when dr Kroger died?
He died in real life, sad
Reply With Quote
  #3 (permalink)  
Old 24 Nov 2013, 08:11 pm
Fresh Cruiser
 
Join Date: Nov 2013
Posts: 10
Default Re: HELP! New PT owner having issues

Haha. Yeah. I know what your talking about!

The smoking was the valve gasket leaking oil. Bought. Replaced.

But still have the studder thing like a rev limiter if I get into it. Did the Cruiser have shift sensor problems? Is it simply that?
Reply With Quote
  #4 (permalink)  
Old 25 Nov 2013, 02:28 am
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Exclamation Re: HELP! New PT owner having issues

Quote:
Originally Posted by krogerfresh View Post
I have a 2005 Chrysler PT Cruiser Turbo. It's is acting like a rev limiter is on it if I get into the gas. Usually around 3500-4000 RPMs and mostly from 2 to 3 gear. It was throwing a code for the map sensor (biometric sensor) Replaced that. Now saying it's the throttle sensor. And now blowing white smoke and loses power and sometimes shuts off. If let idle it runs then stutter at low RPMS and shuts off. Is it the throttle sensor causing that?!
Both the turbo and non-turbo have the rev limiter (around 4K) that limits the revs while at idle. There's also a limiter on top speed on both cars set by the computer,usually around 105-110mph on the non-turbo,around 120-130mph on the turbos.
But,based on a couple of things in your description;I don't think that's your issue.
Normally white smoke can be the result of a serious issue like a blown head gasket, a damaged cylinder head, or a cracked engine block.....
The power loss & shutting down,could be a result of one,or more spark plugs,getting 'drowned-out' with coolant.
Have you noticed if you've been losing any coolant?
You may want to pull the spark plugs,and look(fouled and/or wet) & smell them(coolant will smell kinda sweet)
You might do a compression test,because if you do have a problem with the head gasket,or the head itself,and a compression test will tell you if & where it may be.
One thing you might want to try as a temporary fix,if you do have a blown head gasket,just until you get a chance to fix it is this:


Photo courtesy of: BustedPT


I wouldn't recommend some of the 'cheapy',or 'off' brands,as they can end up sealing things you really DON'T want getting sealed.
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #5 (permalink)  
Old 25 Nov 2013, 07:28 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: HELP! New PT owner having issues

Quote:
Originally Posted by randyincctx View Post

One thing you might want to try as a temporary fix,if you do have a blown head gasket,just until you get a chance to fix it is this:


I'm pretty sure we've seen owners come to the forum after buying their "New-To-Me" cruiser that didn't know the previous owner had thrown a bottle or two of that stuff in before trading in their car.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #6 (permalink)  
Old 25 Nov 2013, 10:23 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,895
Default Re: HELP! New PT owner having issues

Quote:
Originally Posted by CREWZIN View Post
I'm pretty sure we've seen owners come to the forum after buying their "New-To-Me" cruiser that didn't know the previous owner had thrown a bottle or two of that stuff in before trading in their car.
Actually this and the others similar to it. Do a good job without causing any side affects. That said I still see these as a temporary fix that I would get fixed. just me.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Are you a PT owner or a Chrysler owner? purple04 General PT Cruiser Discussions 55 04 Sep 2014 09:57 pm
UK MOT issues davea300 Europe PT Forum 16 15 Jul 2013 02:43 am
Need some help with a few issues! dcsocal General PT Cruiser Discussions 11 13 Apr 2011 07:59 pm
speaker issues, wattage of stereo, door speaker replacement issues fabes89 General PT Cruiser Discussions 9 02 Jun 2009 10:59 am


All times are GMT -5. The time now is 12:38 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors