PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
No break lights

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Dec 2013, 09:01 pm
Fresh Cruiser
 
Join Date: Feb 2013
Posts: 2
Default No break lights

Have a 2004 cruiser and all 3 break lights dont work,replaced all the bulbs,break switch ,fuses are good ,and i have power to the break switch, all the other lights on the car work just not the break lights, any ideas
Reply With Quote
  #2 (permalink)  
Old 07 Dec 2013, 10:11 pm
Banned
 
Join Date: May 2011
Location: Dallas Texas
Posts: 3,722
Default Re: No break lights

Did you break the brake bulbs?




Quote:
Originally Posted by bearrug View Post
Have a 2004 cruiser and all 3 break lights dont work,replaced all the bulbs,break switch ,fuses are good ,and i have power to the break switch, all the other lights on the car work just not the break lights, any ideas
Reply With Quote
  #3 (permalink)  
Old 08 Dec 2013, 12:33 am
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Lightbulb Re: No break lights

Quote:
Originally Posted by bearrug View Post
i have power to the break switch
Possible bad ground.......If voltage is present when the brake pedal is depressed,you need to check for a bad ground;Using a jumper wire connected to a good ground,probe the ground terminal at the tail light connector;If the brake lights come on,repair the ground circuit(Follow the ground wires from the tail light housing).
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #4 (permalink)  
Old 08 Dec 2013, 12:54 am
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,004
Default Re: No break lights

Hello, welcome to the forum. From what you have told us of your brake light problem, I suggest you check the C106 connector, a known electrical problem.

Look under the dash, behind the code reader plug, below the fuse block.
Find the large grey connector (next to a white one). It has a black lever lock to release and separate the halves. Look for heat damage, melting, etc.
Standard operating procedure-disconnect battery first.

These are related threads.
can't see the road!
Instrument cluster "no buss" fix


Quote:
Originally Posted by bearrug View Post
Have a 2004 cruiser and all 3 break lights dont work,replaced all the bulbs,break switch ,fuses are good ,and i have power to the break switch, all the other lights on the car work just not the break lights, any ideas
Reply With Quote
  #5 (permalink)  
Old 08 Dec 2013, 12:49 pm
Fresh Cruiser
 
Join Date: Feb 2013
Posts: 2
Default Re: No break lights

Ok i will check out that connector
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Running lights/break lights leigh General PT Cruiser Discussions 2 25 Apr 2013 09:21 pm
How to break into my PTC? mr_ed Sound and Security Forum 7 13 Mar 2011 12:09 pm
Break Down CREWZIN Tech & Performance Forum 10 30 Jun 2005 10:09 am
Break in Thoughts Of Others, LAF General Turbo Discussions 3 16 Feb 2004 04:23 am
ok, Break it down for me. PTucker Stage Turbo Kits 10 28 Dec 2003 11:43 pm


All times are GMT -5. The time now is 03:06 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors