PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
MFS Plastic connector issue

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Mar 2014, 09:37 am
Fresh Cruiser
 
Join Date: Mar 2014
Location: Amarillo, Texas
Posts: 4
Unhappy MFS Plastic connector issue

Have 01 PT Limited bought new, usually trouble free, have had recurring issues w/multifuntion switch involving headlights. First time around cured by cleaning lighting plug connector, few months later replaced MFS. Had low beam headlights go out again, replaced switch but lighting connector plug was so brittle, it crumbled to pieces upon removal. Got another plug from salvage and changed out plug (quite a chore as the terminals were retained by plastic tabs that mostly broke off) and after plugging in and verifieing all operations, secured wiring w/silicone. Now 6 months later have lost low beams again, checked wiring to be sure terminals had not seperated, found replacement plug becoming brittle but wiring ok. I am assuming new switch is now bad but plug (22 pin) is too brittle to change out switch again. Does anyone know of a replacement plug available any way other than salvage or new (cost prohibitve) harness? Also during troubleshooting could not locate headlamp relay, nothing labeled as such in box under hood and removal of 2 relays under fuse panel inside had no effect on headlights, where am I missing it? THANX, Roger

Last edited by BURPLE; 24 Mar 2014 at 09:57 am. Reason: missed notification tab
Reply With Quote
  #2 (permalink)  
Old 24 Mar 2014, 02:54 pm
sanatanadharma's Avatar
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,069
Default Re: MFS Plastic connector issue

Fuses (dash) #19 and #20 (both 10 amp) control the low beams.
Dash fuse #1 (25 amp) and hi-beam PDC fuse #16/17 (15 amp) should be checked.
The head light relay is at the bottom of the fuse block (so is heated-seat relay). Head light relay is left side. The relay directs power to the low beam bulbs when hi-beams are engaged. It also kills power to fog light circuit when hi-beams are turned on.

All possible problem sources: MFS, fuses, relays, wiring connectors, bulbs, grounds.
Good luck

Quote:
Originally Posted by BURPLE View Post
Have 01 PT Limited bought new, usually trouble free, have had recurring issues w/multifuntion switch involving headlights. First time around cured by cleaning lighting plug connector, few months later replaced MFS. Had low beam headlights go out again, replaced switch but lighting connector plug was so brittle, it crumbled to pieces upon removal. Got another plug from salvage and changed out plug (quite a chore as the terminals were retained by plastic tabs that mostly broke off) and after plugging in and verifieing all operations, secured wiring w/silicone. Now 6 months later have lost low beams again, checked wiring to be sure terminals had not seperated, found replacement plug becoming brittle but wiring ok. I am assuming new switch is now bad but plug (22 pin) is too brittle to change out switch again. Does anyone know of a replacement plug available any way other than salvage or new (cost prohibitve) harness? Also during troubleshooting could not locate headlamp relay, nothing labeled as such in box under hood and removal of 2 relays under fuse panel inside had no effect on headlights, where am I missing it? THANX, Roger
__________________
Please refer to the forum guidelines for posting content

Last edited by sanatanadharma; 09 Nov 2016 at 09:58 am.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
I need a connector Chrisd069 Classifieds: Want To Buy 25 27 May 2012 10:23 pm
Plastic guard under front right side is hanging// strut issue too thinkinboutit General PT Cruiser Discussions 5 19 Dec 2010 09:06 am
Connector removeal afaszholz General PT Cruiser Discussions 1 16 Aug 2010 02:13 am
ipod connector for 03 GT strangelove General Turbo Discussions 13 02 Mar 2006 06:48 am
ipod connector Neo Ion strangelove Sound and Security Forum 2 05 Nov 2005 05:21 am


All times are GMT -5. The time now is 08:41 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors