PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Much needed help about instrumental cluster

 
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Apr 2014, 07:31 pm
Fresh Cruiser
 
Join Date: Apr 2014
Posts: 8
Angry Much needed help about instrumental cluster

So I did a check engine light reset on my 2003 pt cruiser. Which I took off the negative cable then the positive and turned the lights on for 5 mins. Then turned the lights off put the positive back on then the negative. Now nothing on my instrumental cluster works, gas, oil, speedometer, mileage. . Everything else works. Please help.
Reply With Quote
  #2 (permalink)  
Old 15 Apr 2014, 07:40 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Much needed help about instrumental cluster

I guess you mean your instruments don't light up?
When you turned on/off the lights, you must've twisted the instrument panel dimmer on the stalk - turn it back on.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 15 Apr 2014, 07:43 pm
Fresh Cruiser
 
Join Date: Apr 2014
Posts: 8
Default Re: Much needed help about instrumental cluster

I thought it could have been that but it's all the way up. All fuses are good as well. Maybe a bulb?
Reply With Quote
  #4 (permalink)  
Old 15 Apr 2014, 08:00 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Question Re: Much needed help about instrumental cluster

Quote:
Originally Posted by Kwiemanntx View Post
All fuses are good as well
May be a long shot.....Did you check the IOD fuse in the PDC?
I'm also curious about 2 other things:
#1.)Why & what were the reason for the CEL?.....What were the codes?
#2.)Is your PT equipped with factory fog lights?.....and/or any aftermarket alarm/anti-theft devices & lighting?
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~

Last edited by randyincctx; 15 Apr 2014 at 08:03 pm.
Reply With Quote
  #5 (permalink)  
Old 15 Apr 2014, 08:04 pm
Fresh Cruiser
 
Join Date: Apr 2014
Posts: 8
Default Re: Much needed help about instrumental cluster

Well i don't know much about cars. So what's the IOD and PDC fuse?
Reply With Quote
  #6 (permalink)  
Old 15 Apr 2014, 08:05 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Much needed help about instrumental cluster

There's more than 1 bulb.
I'd play with the switch - maybe it has a dead spot.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #7 (permalink)  
Old 15 Apr 2014, 08:08 pm
Fresh Cruiser
 
Join Date: Apr 2014
Posts: 8
Default Re: Much needed help about instrumental cluster

Well I went to get my state inspection and the guy said it was a h20 sensor as to why the cel was on. It does not have aftermarket anything on it. It's from a small dealership owned by bikers lol
Reply With Quote
  #8 (permalink)  
Old 15 Apr 2014, 09:09 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Post Re: Much needed help about instrumental cluster

Quote:
Originally Posted by Kwiemanntx View Post
the guy said it was a h20 sensor as to why the cel was on.
I think you might mean O2 sensor,correct?......and your PT doesn't have fog lights?
As for the IOD fuse(Ignition Off Draw),it controls most the interior lighting,and the PDC(Power Distribution Center) is the black box looking thing located behind the air filter/box.


Here's what you need to look for(check those fuses):


PT_PDC.jpg


Here's a better photo of the guide located on the underside of the PDC cover:

PT_power_distribution_center_fuse_panel_cover.jpg
Kwiemanntx likes this.
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #9 (permalink)  
Old 15 Apr 2014, 09:39 pm
Fresh Cruiser
 
Join Date: Apr 2014
Posts: 8
Talking Re: Much needed help about instrumental cluster

Your a life saver, THANK YOU SO MUCH . I took it out, and put it back in and everything is working. Now is it hard to replace a O2 sensor?
Reply With Quote
  #10 (permalink)  
Old 15 Apr 2014, 09:45 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,326
Default Re: Much needed help about instrumental cluster

Quote:
Originally Posted by Kwiemanntx View Post
Your a life saver, THANK YOU SO MUCH . I took it out, and put it back in and everything is working. Now is it hard to replace a O2 sensor?
Before you do that, you might want to check the trouble codes yourself. You can either do the "key dance" to get the codes or take it to Autozone or similar and have them read your codes for you. Make sure the code you have is really for the oxygen sensor.
__________________
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Could it just be the instrument cluster? ukbeachbum General PT Cruiser Discussions 21 17 Sep 2015 08:50 pm
Will a 2nd gen cluster fit in a 1st gen? Lucas Interior Accessories Forum 9 04 Mar 2014 11:51 am
Cluster Issues?? Ghsthntr07 General PT Cruiser Discussions 5 03 Dec 2013 06:29 pm
Airbox, airbag cover, and gauge cluster cover needed cruisin03pt Classifieds: Want To Buy 5 26 Nov 2012 12:26 pm
Instrument Cluster needed PTloser Classifieds: For Sale/Trade 0 23 Jul 2002 06:42 pm


All times are GMT -5. The time now is 09:18 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors