PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Overheating, losing fluid after parking, squealimg

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 May 2014, 12:31 am
Fresh Cruiser
 
Join Date: May 2014
Posts: 3
Unhappy Overheating, losing fluid after parking, squealimg

I bought an 01 cruiser in the end of February. The day I brought it home, we noticed the smell of coolant and upon investigation, realized the heater core was bad and there was rust in the radiator. I returned it to the carlot and told him I wanted it fixed and the cooling system flushed. A week later he told me it was done and I came back for the car. I'm not jonestly sure he did anything.

I didn't notice any problems from then(first week of March) until Easter weekend when I suddenly noticed it was losing coolant somewhere and getting a bit hot. Not pegged red or anything, but it was hot. We also noticed a sort of squealing noise in the front right side.

A few days later, my dad looked at it and we realized that the hose from the radiator to the overflow tank was completely blocked with chunky orange stuff(possibly rust, idk). He got that clear, thought that was the problem, but it didn't stop.

Since then if I drive more than 10/15 minutes it overheats. There is coolant in it, I checked before we left, and I heard what sounded like it boiling inside when.i pulled in today for an.appointment. I didn't notice it leaking anything while running, but when.i came out of my appointment, there was a pool of coolant there. luckily the weather has been warm the past few days, because I have just been topping it off with water every time I go anywhere and not driving more than I must.

I recently lost my job andneed this car to get to a new one, but I can't afford a giant garage bill right now. Please tell me one of you fabulous people has an idea what this could be? I have had a few people guess everything from the head(fyi, no white smoke, no milky oil), a water pump, the radiator, or a hose.

Oh one more thing, my heater isn't working now, its just not getting hot. Idk if that info is important.
Reply With Quote
  #2 (permalink)  
Old 07 May 2014, 01:13 am
Senior Cruiser
 
Join Date: Nov 2010
Location: oak creek, wi
Posts: 1,149
Default Re: Overheating, losing fluid after parking, squealimg

I'd say you have air in the system. bleed the heck out of it, then bleed it some more. good chance that should remedy the situation.
__________________
2005 Toyota Camry LE Salsa Red (Wife's)
2002 Automatic N/A (Mine) Inferno Red
2016 Kia Soul Plus Black
Reply With Quote
  #3 (permalink)  
Old 07 May 2014, 01:14 am
Fresh Cruiser
 
Join Date: May 2014
Posts: 3
Default Re: Overheating, losing fluid after parking, squealimg

Ok I will Google how tobdo that, thank you so much.
Reply With Quote
  #4 (permalink)  
Old 07 May 2014, 10:40 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Overheating, losing fluid after parking, squealimg

Cheapest is a radiator cap - hard to visually see if it's bad, just replace it.
Some info about your PT - miles on it?
Does the engine fan come on when it warms up? If not, there's your problem.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #5 (permalink)  
Old 08 May 2014, 08:25 am
Fresh Cruiser
 
Join Date: May 2014
Posts: 3
Default Re: Overheating, losing fluid after parking, squealimg

The fan is working.

There are 108,000 miles on the car.
Reply With Quote
Reply

Tags
losing coolant, no heat, overheating


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Losing oil bhunt41 Tech & Performance Forum 6 14 Mar 2012 07:28 pm
Losing Oil Kochtaters Northeast PT Forum 3 15 Nov 2010 04:09 pm
Losing coolant... stek2008 General PT Cruiser Discussions 15 15 Nov 2010 03:37 pm
RE: Losing Air kennybopaloo Turbo Wheels/Suspension/Handling 20 04 Dec 2007 08:10 am
Losing coolant and overheating when stopped dornstar General PT Cruiser Discussions 3 24 Aug 2007 06:16 pm


All times are GMT -5. The time now is 09:25 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors