PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Help! Weird oil pressure issue

 
Like Tree11Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Sep 2014, 08:05 pm
Fresh Cruiser
 
Join Date: Nov 2011
Posts: 42
Default Help! Weird oil pressure issue

A few weeks ago, immediately after an oil change, my low oil pressure light started coming on intermittently, mostly as the car slowed to an idle-- I first noticed it in stop and go traffic on the San Francisco bay bridge. After I got off the bridge I checked the oil and it seemed to be fine. (Of note: I switched to synthetic oil with this oil change.)

For a couple of days after that I would sometimes get low oil pressure warning lights when I slowed to idle. I could make the light go off by dropping the car into neutral and giving it just a small amount of gas.

It started happening again yesterday. I was due for an oil change anyway so I just pulled into a random oil change shop and had it done. I had them switch back to dino oil this time. After the oil change I drove about a mile and a half through San Francisco and still got the light at idle, but since that I haven't seen it at all.

The car is a 2005 Touring convertible with around 75K on the clock., and I'm not an aftermarket modding sort of person.


Any idea what might be going on with this? Should I worry about it, or assume it's just some weird fluke?
Reply With Quote
  #2 (permalink)  
Old 15 Sep 2014, 08:40 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Help! Weird oil pressure issue

Lots of owners had problems with the Oil Pressure Sending Unit. If it starts acting up again, I'd just have that changed.

boonie2 likes this.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 15 Sep 2014, 09:17 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,308
Default Re: Help! Weird oil pressure issue

When the oil pressure light is on are there any unusual noises coming from the engine>
Reply With Quote
  #4 (permalink)  
Old 16 Sep 2014, 10:29 am
Fresh Cruiser
 
Join Date: Nov 2011
Posts: 42
Default Re: Help! Weird oil pressure issue

The engine seems to be running normally when the oil pressure light comes on. I haven't let it stay on for more than a few seconds at a time, but when this happens I've been fairly vigilant about paying attention to how the car is running. If I'd heard Bad Engine Noises or sensed anything unusual I'd be approaching this much differently.

The one thing that seems weird to me is that this correlates almost perfectly with my last oil change. Could they have done something that messed with the sending unit?
Reply With Quote
  #5 (permalink)  
Old 16 Sep 2014, 10:54 am
Regular Cruiser
 
Join Date: Aug 2013
Location: Az
Posts: 169
Default Re: Help! Weird oil pressure issue

Problem maybe started when you changed oil
Just a freak of the times just change oil sending unit
Reply With Quote
  #6 (permalink)  
Old 16 Sep 2014, 11:05 am
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,705
Default Re: Help! Weird oil pressure issue

Ok.... this is important.

If the oil light comes on this is a WARNING to you to get the engine checked ASAP.

DON"T assume that it is the sender. Think worst scenario in this case a failing oil pump or a restriction in the engines oiling. It may only be a sender which is the most common part that fails, but you are better to be overly cautious and get it check from someone that has experience than to second guess and melt you engine down.

DO NOT always expect to hear a sound before catastrophic engine failure either.
VNT likes this.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #7 (permalink)  
Old 16 Sep 2014, 11:43 am
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,344
Default Re: Help! Weird oil pressure issue

Quote:
Originally Posted by Hoser View Post
A few weeks ago, immediately after an oil change, my low oil pressure light started coming on intermittently, mostly as the car slowed to an idle-- I first noticed it in stop and go traffic on the San Francisco bay bridge. After I got off the bridge I checked the oil and it seemed to be fine. (Of note: I switched to synthetic oil with this oil change.)

For a couple of days after that I would sometimes get low oil pressure warning lights when I slowed to idle. I could make the light go off by dropping the car into neutral and giving it just a small amount of gas.

It started happening again yesterday. I was due for an oil change anyway so I just pulled into a random oil change shop and had it done. I had them switch back to dino oil this time. After the oil change I drove about a mile and a half through San Francisco and still got the light at idle, but since that I haven't seen it at all.

The car is a 2005 Touring convertible with around 75K on the clock., and I'm not an aftermarket modding sort of person.


Any idea what might be going on with this? Should I worry about it, or assume it's just some weird fluke?
Viscosity of the oil is what you want to look at. Were you using 5w20 then switched to 0w20 syn?

My 03 light was coming on and I went to 10w25 and no more OPS light.
I would be suprised if it didn't come on at 5 lb pressuer

I ran a 1 ton for a few years with just a few lb at idle for several years, had a guage, never did knock.
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #8 (permalink)  
Old 16 Sep 2014, 12:05 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,705
Default Re: Help! Weird oil pressure issue

Quote:
Originally Posted by JoeX View Post
Viscosity of the oil is what you want to look at. Were you using 5w20 then switched to 0w20 syn?

My 03 light was coming on and I went to 10w25 and no more OPS light.
I would be suprised if it didn't come on at 5 lb pressuer

I ran a 1 ton for a few years with just a few lb at idle for several years, had a guage, never did knock.
You have a problem somewhere that you never found?

The viscosity of the oil does not control the oil pressure to drop below a point to activate a factory OP sender or switch.

In the late 70's early 80's we would run sewing machine oil in the race car (A/A Gas Altered) because it was Iso-22 viscosity. That would equate to a few tenths of the ET. And never an oil light. The oil pressure was also connected to a pressure sender that would shut the engine off at or below 20lbs oil pressure.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #9 (permalink)  
Old 16 Sep 2014, 01:59 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,344
Default Re: Help! Weird oil pressure issue

Quote:
Originally Posted by NitroPT View Post
You have a problem somewhere that you never found?

The viscosity of the oil does not control the oil pressure to drop below a point to activate a factory OP sender or switch.

In the late 70's early 80's we would run sewing machine oil in the race car (A/A Gas Altered) because it was Iso-22 viscosity. That would equate to a few tenths of the ET. And never an oil light. The oil pressure was also connected to a pressure sender that would shut the engine off at or below 20lbs oil pressure.
(A/A Gas Altered) because it was Iso-22 viscosity. That would equate to a few tenths of the ET. And never an oil light.

Not a guage? , You running what 8-9000 RPM and relying on a low oil pressure light?
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #10 (permalink)  
Old 16 Sep 2014, 05:59 pm
Fresh Cruiser
 
Join Date: Nov 2011
Posts: 42
Default Re: Help! Weird oil pressure issue

Nitro, you make an excellent point.

I have been sort of trusting the instructions in the owners manual, which mentions doing that if the light comes on and stays on. Because this is so intermittent and brief it smells to me like a problem that isn't engine-about-to-seize low oil pressure and that's why I want to get a better understanding of the possible causes before I take it to a mechanic.

One of the downsides of being a middle-aged woman is that some shops see dollar signs when I walk in. I'm an engineer, and I have a halfway decent general knowledge of mechanics plus a really good general aptitude for troubleshooting and problem isolation, so I'm not as much of a mark as they think I am. However, my specific mechanical knowledge is limited, and when something feels like a weird problem rather than a routine one I like to have my ducks in a row before putting my checkbook on the line.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
very weird rad fan issue barthek Tech & Performance Forum 18 16 Dec 2013 04:11 am
Weird idle/ac issue. Ced_56 Tech & Performance Forum 4 08 Jun 2013 08:18 pm
weird issue Johns03PT General PT Cruiser Discussions 5 14 Dec 2012 08:15 pm
weird a/c issue bogie2929 Tech & Performance Forum 2 05 Aug 2012 09:54 am
Weird issue Opiate General PT Cruiser Discussions 4 09 Aug 2008 10:05 pm


All times are GMT -5. The time now is 11:13 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors