PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
P0601 code again!!

 
Like Tree1Likes
  • 1 Post By JoeX

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Sep 2014, 06:13 pm
Young Cruiser
 
Join Date: Aug 2012
Location: Camp Hill, PA
Posts: 52
Default P0601 code again!!

Hi all. I replaced my pcm 3 weeks (1500 miles) ago on my 01 non-turbo b/c the old one was giving me a p0601 code. The new one has been working fine until tonight. Drove home an hour from work, went out to run an errand an hour later, started the engine to come back home and BING...check engine light on startup. The 0601 code is back again!!

Most of what I have been able to find suggests the cause cold either be a bad pcm or low voltage. By low voltage do they mean that the battery is starting to putter out? I never notice any other issues. It always starts right away. Does anyone have any suggestions?

Thanks everyone!
Reply With Quote
  #2 (permalink)  
Old 17 Sep 2014, 06:36 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,344
Default Re: P0601 code again!!

Check your grounds & the PCM plugs.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #3 (permalink)  
Old 17 Sep 2014, 06:40 pm
Young Cruiser
 
Join Date: Aug 2012
Location: Camp Hill, PA
Posts: 52
Default Re: P0601 code again!!

The grounds are good to go. I checked them when I replaced the pcm. I also checked the plugs.
Reply With Quote
  #4 (permalink)  
Old 17 Sep 2014, 07:09 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,309
Default Re: P0601 code again!!

Quote:
Originally Posted by Jdwags View Post
The grounds are good to go. I checked them when I replaced the pcm. I also checked the plugs.

The ground wires going to the drivers side fender on the inside have been know to have corrosion with many wires wrapped together and you can't see it happening. You might want to check it again.
Reply With Quote
  #5 (permalink)  
Old 17 Sep 2014, 07:20 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,344
Default Re: P0601 code again!!

Quote:
Originally Posted by ptcruisersteve View Post
The ground wires going to the drivers side fender on the inside have been know to have corrosion with many wires wrapped together and you can't see it happening. You might want to check it again.
My grounds "LOOKED GOOD_TIGHT" but redoing them and soldering them together and to the eyelet fixed my P0032

If the sensor in question has a ground you need to check the wires for continuity.
NitroPT likes this.
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #6 (permalink)  
Old 17 Sep 2014, 08:20 pm
Young Cruiser
 
Join Date: Aug 2012
Location: Camp Hill, PA
Posts: 52
Default Re: P0601 code again!!

The grounds come out to two main positions on the driver's side correct? There is a cluster attached to a large bolt and another attached to a screw going into the sheet metal. I removed these when i replaced the pcm, brushed them (even though there was no crud on them), and tightened them all back into place.

The inside of the pcm plugs was clean and the posts were all straight and shiny.

I can always take the grounds back off and add some solder to them.

Now that the 0601 code is on, is there any way to get it off again? The reason I ask is that when i tried to clear the code (on my old pcm) with my scan tool, it wouldn't erase.

Or, is it more likely could it be that the replacement pcm is defective and pooped out on me. From what I have seen in the forums and elsewhere, the main culprit seams to be the pcm and not electrical issues.

Sorry for the rambling...I am sick, very low on sleep, and this stress isn't helping.

Thanks everyone!
Reply With Quote
  #7 (permalink)  
Old 18 Sep 2014, 11:54 am
Young Cruiser
 
Join Date: Aug 2012
Location: Camp Hill, PA
Posts: 52
Default Re: P0601 code again!!

Weird...I started to the car today (CEL on) and drove 2 minutes to get gas. Started again (CEL on) and began my commute. About 2 minutes in, I see the CEL turn off. I thought that once a 0601 was on it was more or less permanent. We'll see what happens when I start it to drive home.
Reply With Quote
  #8 (permalink)  
Old 18 Sep 2014, 01:26 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,344
Default Re: P0601 code again!!

Quote:
Originally Posted by Jdwags View Post
Weird...I started to the car today (CEL on) and drove 2 minutes to get gas. Started again (CEL on) and began my commute. About 2 minutes in, I see the CEL turn off. I thought that once a 0601 was on it was more or less permanent. We'll see what happens when I start it to drive home.

Like I said, the grounds may look good but its the crimp and oxidation that causes problems. Its not wise to mix 2 dis-simular metals,it promotes oxidation and when i took my grounds apart, I found they coated the copper eyelet with a thin coat of dis-simular metal and the copper grounds were oxidized making a bad ground.

If your code comes back, revisit the ground and redo it for peace of mind at least.
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh

Last edited by JoeX; 18 Sep 2014 at 01:28 pm.
Reply With Quote
  #9 (permalink)  
Old 18 Sep 2014, 04:33 pm
Young Cruiser
 
Join Date: Aug 2012
Location: Camp Hill, PA
Posts: 52
Default Re: P0601 code again!!

Thanks for the info. They are easy to get to so I think I will give them a going over again. It never hurts to double or triple check. Sometimes you find that you missed something that you overlooked the first or even second time. I will check the crimps, brush the contacts, and make sure that they are tightly reconnected to the frame.

Thanks again everyone!
Reply With Quote
  #10 (permalink)  
Old 18 Sep 2014, 08:02 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,344
Default Re: P0601 code again!!

Quote:
Originally Posted by Jdwags View Post
Thanks for the info. They are easy to get to so I think I will give them a going over again. It never hurts to double or triple check. Sometimes you find that you missed something that you overlooked the first or even second time. I will check the crimps, brush the contacts, and make sure that they are tightly reconnected to the frame.

Thanks again everyone!
Not to harp on the grounds but sanding the back of the terminal to clean it is not a bad idea, but you need to clean what you cannot see, under where the wires are crimped to the eyelet, thats where the wires corrode.
I cut mine off the eyelet, stripped the wires back about an inch and twisted them together, used non acid electrical flux and soldered them together.
then I pried the eyelet crimps apart and removed the old wires, cleaned the surface down to the copper, tined the surface with solder, crimped the wires back to the eyelet , then soldered it all together..
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing the PCM (P0601) steveclv Tech & Performance Forum 16 23 Feb 2016 07:34 am
Check Engine Code P0601 PCM internal malfunction lgowen Tech & Performance Forum 1 06 Jun 2012 04:05 pm
Code P0601 Question dougk Tech & Performance Forum 6 02 Aug 2010 03:41 pm
trouble code p0601 bob1 General PT Cruiser Discussions 2 30 Mar 2010 10:02 am
Error Code P0601 - Help SlowwCory Tech & Performance Forum 2 20 Aug 2009 12:35 pm


All times are GMT -5. The time now is 09:44 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors