PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
No right front turn signal or parking light

 
Like Tree2Likes
  • 1 Post By LionPT
  • 1 Post By johnnyzero

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Oct 2014, 06:05 pm
Fresh Cruiser
 
Join Date: Oct 2014
Posts: 4
Default No right front turn signal or parking light

The right front amber bulb on my wife's 2006 PT Cruiser stopped working for both turn signal and parking light.

I replaced the bulb, still no go.

Curiously, when I enable the 4-way flashers (hazard lights), one of the filaments flashes just like it's supposed to.

Before I take a gamble and order a new multi-function switch, I figured I'd post here to see if anyone had any thoughts/advice.

Thanks in advance,
JohnB
Reply With Quote
  #2 (permalink)  
Old 24 Oct 2014, 06:14 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,343
Default Re: No right front turn signal or parking light

Try wiggling or use a test light on the socket wires with the blinker on...sounds like a loose wire. Since you didn't mention the right rear, I assume it's working...you might just need to replace the socket.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #3 (permalink)  
Old 24 Oct 2014, 06:30 pm
Fresh Cruiser
 
Join Date: Oct 2014
Posts: 4
Default Re: No right front turn signal or parking light

Thanks for your reply.

Since the "blinker" filament flashes just fine when the 4-ways are on, wouldn't that rule out a bad socket or loose wire?

The parking lights & turn signals are both controlled by the multi-function switch, whereas the 4-ways are controlled by a separate dash-mounted switch. This is why I suspect the MFS.

btw, the socket is clean as a whistle (no corrosion), and I've already tried lots of jiggling to see if it made any difference.
Reply With Quote
  #4 (permalink)  
Old 24 Oct 2014, 06:41 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,343
Default Re: No right front turn signal or parking light

Quote:
Originally Posted by johnnyzero View Post
The parking lights & turn signals are both controlled by the multi-function switch, whereas the 4-ways are controlled by a separate dash-mounted switch. This is why I suspect the MFS.
If the MFS was bad...shouldn't the whole right side be bad, not just the front..?? If the socket is good, I would remove the steering covers & check the plug that goes into the MFS for a burnt wire.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #5 (permalink)  
Old 24 Oct 2014, 06:57 pm
Fresh Cruiser
 
Join Date: Oct 2014
Posts: 4
Default Re: No right front turn signal or parking light

Quote:
Originally Posted by LionPT View Post
If the MFS was bad...shouldn't the whole right side be bad, not just the front..??
Good point. You're right: it's very unlikely that there are separate contacts/feeds for front and rear.

Quote:
Originally Posted by LionPT View Post
If the socket is good, I would remove the steering covers & check the plug that goes into the MFS for a burnt wire.
I'll try that tomorrow when I've got daylight, and post back here. I'm also gonna break out my voltmeter & do some more checking at the socket.

From what I've read, the '06 had a lot of MFS- and turn signal-related issues. I'm really hoping it's not a problem with the TIPM, which is big $$$'s to replace.
Reply With Quote
  #6 (permalink)  
Old 04 Nov 2014, 04:21 pm
Fresh Cruiser
 
Join Date: Oct 2014
Posts: 4
Default Re: No right front turn signal or parking light

Solved. It turned out to be a bad ground wire to that connector/socket.

I used a self-piercing connector to splice to the existing ground wire at the socket end, and then I snaked my new wire up thru the wheel well and connected it to a grounded bracket bolt in the engine compartment.

Everything works great now.
Reply With Quote
  #7 (permalink)  
Old 04 Nov 2014, 04:44 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,343
Default Re: No right front turn signal or parking light

__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #8 (permalink)  
Old 04 Nov 2014, 05:36 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: No right front turn signal or parking light

Thanks fopr the update
Reply With Quote
  #9 (permalink)  
Old 04 Nov 2014, 05:44 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: No right front turn signal or parking light

Quote:
Originally Posted by johnnyzero View Post
Solved. It turned out to be a bad ground wire to that connector/socket.

I used a self-piercing connector to splice to the existing ground wire at the socket end, and then I snaked my new wire up thru the wheel well and connected it to a grounded bracket bolt in the engine compartment.

Everything works great now.
Good diagnostics and thanks for posting the cure....
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Front Turn Signal Lights Turn On and Off When Applying Brake? Danny7627 Tech & Performance Forum 12 20 Jan 2014 09:42 pm
LED turn signal light bulbs agr1233 Tech & Performance Forum 3 10 Jan 2013 07:06 am
Right front turn signal not working rctjroy Tech & Performance Forum 3 15 Sep 2012 04:26 pm
Turn signal & stop light gonzomania General PT Cruiser Discussions 12 25 Apr 2004 01:18 pm
Help removing front turn signal reflector. GT_Firebreather Exterior Accessories Forum 7 28 Jul 2003 02:14 pm


All times are GMT -5. The time now is 06:23 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors