PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Replaced almost everything. Really need help

 
Like Tree2Likes
  • 2 Post By ptcruisersteve

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Apr 2015, 01:11 pm
Fresh Cruiser
 
Join Date: Apr 2015
Posts: 3
Default Replaced almost everything. Really need help

Fans will not cut on even after car warms up just replaced head and all gaskets and water pump have not replaced freon yet don't know if that will keep fans from cutting on i have tested the fans they run fine and ran fine even when head gasket was blown dont know what else to do hate taking it to a dealer and blowing even more money what else could keep fans from running i only took it for a short test drive after replacing the warped head i have also replaced radiator and cap and thermostat help help help with my 2001 pt cruiser 2.4 has 70,000 miles
Reply With Quote
  #2 (permalink)  
Old 24 Apr 2015, 01:51 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,339
Default Re: Replaced almost everything. Really need help

I would suggest taking the low speed radiator fan relay out and see if the high speed on the radiator fan automatically turns on.
I would suggest you introduce yourself and tell us about your PT Cruiser.
Reply With Quote
  #3 (permalink)  
Old 24 Apr 2015, 02:23 pm
Fanatic Cruiser
 
Join Date: May 2014
Location: Pasadena TX
Posts: 713
Default Re: Replaced almost everything. Really need help

Please say you replaced the timing belt and tensioners when that water pump was changed! The labor charge is little more since everything but the tensioners has to be removed to replace the pump. And you would then have a nice 100k mileage cushion before having to worry about it again.
Reply With Quote
  #4 (permalink)  
Old 24 Apr 2015, 02:40 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: Replaced almost everything. Really need help

with the key on -engine off, you should unhook the coolant temperature sender and stick a paperclip in the connector. this should make the fans come on. if it does not, it should keep things energized so you can try the usual crap like swapping relays from the horn and poking around with a multimeter to see where your electricity stops.

i'd retest the fan before anything else. they are normally the part that fails. maybe you had a brain fart when checking them. it happens to all of us.

Last edited by rob342; 24 Apr 2015 at 02:44 pm.
Reply With Quote
  #5 (permalink)  
Old 24 Apr 2015, 04:34 pm
Fresh Cruiser
 
Join Date: Apr 2015
Posts: 3
Default Re: Replaced almost everything. Really need help

Quote:
Originally Posted by ptcruisersteve View Post
I would suggest taking the low speed radiator fan relay out and see if the high speed on the radiator fan automatically turns on.
I would suggest you introduce yourself and tell us about your PT Cruiser.
Ok guys hopefully every one concerned and trying to help will see this i have replaced the timing belt and tensioner pulley cams valves the entire head and everything in it came across a deal after finding out the head was warped so figured low mileage car why not since it was a deal 250 for all gaskets bolts cams head valves water pump timing belt car ran hot off and on for 10,000 miles never real hot in less the air was wide open or just idling in the end the radiator hose built up enough pressure twice to blow off last time it ran out of coolant and of course the head just got to hot warped it as many do as of now i have replaced everything you can think of car cranks great sounds great runs great or ran great for a short test run but the fans will not cut on and yes I have had many brain farts in life but i tested the fans they run fine low and high have not checked any relays i have heard that the computer will not engage the fans sometimes after you have drained the freon and i have not put any back in it i will be doing that tonight if that doesn't help then im back where I started i am not a every day mechanic im a welder fitter that just happens to know how to turn a wrench follow directions and use a little common since and almost forgot take advice from any of you guys that might know more then me of done the work on this car me and my wife have been bent over from the work done on the Origanal head that is now a boat anchor I've taking two heads off other pt cruisers just to clearly see they were warped and or valves were shot i won't even talk about the wasted money on this car other then to say the great good lord found me the deal i got on gaskets head valves cams water pump belts basically every thing new from the block and pistons up for 250 the car seemed to not run hot while driving guessing i had no air blowing since there's no freon yet and it was kind of a cool night temperture was exactly what it should be by computer but I've got no idea why fans will not cut on at all I've been through the wiring dont know anything about the relays or if I've got to have a dealership flash or reset the computer that would be the very last thing I'd want to do i hope I've giving enough info that maybe someone has had the same problem and could help me i normally Able to figure it out by trial and error but there's just so many people that are going to say i told you so if i don't get it running like a top I've done to good and gotten to far to give up on my own now thanks rob dreamer and Steve for you reply any more help well please bring it on im fixing to get under the hood in the next two hours by the way i love know it alls if there's any out there y'all are sometimes full of great info to so feel free tell me what I don't know or haven't tried

Last edited by Nealpeters; 24 Apr 2015 at 04:38 pm.
Reply With Quote
  #6 (permalink)  
Old 24 Apr 2015, 04:55 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,348
Default Re: Replaced almost everything. Really need help

If there is no freon in the AC system or it is low on freon the AC compressor will not energize because a low pressure switch on the accumulator /dryer tell the computer not to turn the AC compressor on. This switch also controls the high speed cooling that pulls more air through the Condenser and radiator to keep the pressure regulated for the AC. This is only for the AC system.

Low speed on the same fan cycles on and off to regulate engine cooling without the AC on.
Fan motors last about 100,000 miles, wiring connector to the fan are a weak link, the fan cycling on and off could and does cause a spike in amp draw and with a loose male to female connection in the wiring harness will cause heat and a unreliable cooling fan. If the low speed and high speed are not working a ground (center pin) is a likely culprit. Even if you probe the three cooling fan harness wires the pin may be loose (damaged-burned) and not passing the voltage or ground to the fan side of the motor harness.
I had mine out three time and wired directly checking to make sure the motor worked, then found the pin on the voltage feed side (ground in my case) to be bad.
I jumped around it with a ground directly to the battery---no more problems.
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh

Last edited by JoeX; 24 Apr 2015 at 05:11 pm.
Reply With Quote
  #7 (permalink)  
Old 24 Apr 2015, 05:55 pm
Fresh Cruiser
 
Join Date: Apr 2015
Posts: 3
Default Re: Replaced almost everything. Really need help

Will post who's idea was correct will be putting in freon checking all connections to fans ect wish me luck will find out shortly
Reply With Quote
  #8 (permalink)  
Old 24 Apr 2015, 06:42 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,339
Default Re: Replaced almost everything. Really need help

Quote:
Originally Posted by ptcruisersteve View Post
I would suggest taking the low speed radiator fan relay out and see if the high speed on the radiator fan automatically turns on.
I would suggest you introduce yourself and tell us about your PT Cruiser.
If you pull out the low speed fan relay, start the engine and then see if the high speed fan automatically starts. If it does then the cooling fan circuit is working good from the fan relay to the radiator fan itself. Its a simple step and might save you some time figuring out what is wrong.
JoeX and Nealpeters like this.
Reply With Quote
  #9 (permalink)  
Old 24 Apr 2015, 07:34 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,895
Default Re: Replaced almost everything. Really need help

What does the heat gage read? Is it normal?
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does this mean my transmission needs to be replaced? redheadlady Tech & Performance Forum 12 17 Nov 2013 01:06 pm
03 PT GT needs A/C line replaced, which one is it? Clay General Turbo Discussions 6 28 Jul 2011 08:34 am
Just replaced the battery War_Eagle Tech & Performance Forum 0 24 Jul 2010 11:43 am
Almost all of the front end needs to be replaced??!! Triplecat2002 Turbo Wheels/Suspension/Handling 5 17 Jun 2010 07:59 pm
When should shocks be replaced? slkanger Wheels, Tires, Suspension 4 15 Apr 2008 07:24 pm


All times are GMT -5. The time now is 03:02 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors