PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Weird overheating problem

 
Like Tree1Likes
  • 1 Post By NitroPT

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 May 2015, 03:21 pm
Young Cruiser
 
Join Date: Oct 2012
Posts: 98
Default Weird overheating problem

2006 touring

After driving for a mile or so, it starts to overheat, I stop the car, check the fan and radiator, the fan is fine.
The weird thing is the radiator hose. The upper radiator hose has pressure built in it, but it is cold. I thought the coolant in the engine was not circulated into the radiator upper hose yet. But how could this happen, if the pressure inside has been built up?

Then I continue to drive it, the gauge drop to normal level, and the upper hose became hot, which make sense.

What confuse me is, if this is a thermostat problem, why there is pressure built up in the upper hose but the coolant there is cold?
Reply With Quote
  #2 (permalink)  
Old 23 May 2015, 04:23 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,066
Default Re: Weird overheating problem

I would suggest you check your thermostat and see if its not opening up.
Take a infrared non-contact temperature gun and see what the temperature difference is between the upper and lower radiator hose.

Last edited by ptcruisersteve; 24 May 2015 at 12:51 am.
Reply With Quote
  #3 (permalink)  
Old 25 May 2015, 06:18 pm
Young Cruiser
 
Join Date: Oct 2012
Posts: 98
Default Re: Weird overheating problem

Thanks

I think it is the thermostat.

The temp gauge passed the mid-level a little, then returned to normal level.

I guess the thermostat open a little later than designed.

I did replace the original one with a stant superstat because the original one was leaking.

Should I replace the thermostat again? which brand is better?

Thanks
Reply With Quote
  #4 (permalink)  
Old 25 May 2015, 06:34 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,066
Default Re: Weird overheating problem

What temperature stant superstat did you put in it?
How long ago was this thermostat replaced?
Reply With Quote
  #5 (permalink)  
Old 25 May 2015, 06:39 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,221
Default Re: Weird overheating problem

Quote:
Originally Posted by postbeauty View Post
Thanks

I think it is the thermostat.

The temp gauge passed the mid-level a little, then returned to normal level.

I guess the thermostat open a little later than designed.

I did replace the original one with a stant superstat because the original one was leaking.

Should I replace the thermostat again? which brand is better?

Thanks

This is also the spot when the fan will kick in.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #6 (permalink)  
Old 25 May 2015, 06:54 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,066
Default Re: Weird overheating problem

Quote:
Originally Posted by postbeauty View Post
2006 touring

After driving for a mile or so, it starts to overheat, I stop the car, check the fan and radiator, the fan is fine.
The weird thing is the radiator hose. The upper radiator hose has pressure built in it, but it is cold. I thought the coolant in the engine was not circulated into the radiator upper hose yet. But how could this happen, if the pressure inside has been built up?

Then I continue to drive it, the gauge drop to normal level, and the upper hose became hot, which make sense.

What confuse me is, if this is a thermostat problem, why there is pressure built up in the upper hose but the coolant there is cold?
When you say it starts to overheat how far did it go up to on the temperature gauge?
Reply With Quote
  #7 (permalink)  
Old 26 May 2015, 10:59 pm
Young Cruiser
 
Join Date: Oct 2012
Posts: 98
Default Re: Weird overheating problem

Quote:
Originally Posted by ptcruisersteve View Post
What temperature stant superstat did you put in it?
How long ago was this thermostat replaced?
I used the superstat 45209, it is 195F.

I replaced it in the winter.
Reply With Quote
  #8 (permalink)  
Old 26 May 2015, 11:00 pm
Young Cruiser
 
Join Date: Oct 2012
Posts: 98
Default Re: Weird overheating problem

Quote:
Originally Posted by LionPT View Post
This is also the spot when the fan will kick in.
Yes, the fan starts to work.

But the issue is the hot coolant is not circulated into the radiator, so the fan can do nothing.
Reply With Quote
  #9 (permalink)  
Old 26 May 2015, 11:02 pm
Young Cruiser
 
Join Date: Oct 2012
Posts: 98
Default Re: Weird overheating problem

Quote:
Originally Posted by ptcruisersteve View Post
When you say it starts to overheat how far did it go up to on the temperature gauge?
If the mid-level is normal level, and it is 50% of the range,

Sometimes it can go to 75% of the range, then drop to the 50% level.
Before that , the upper hose is cool.

Does this hurt the engine?

I really do not want to replace the thermostat again.

Thanks
Reply With Quote
  #10 (permalink)  
Old 26 May 2015, 11:48 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,016
Default Re: Weird overheating problem

The STANT Super stant is one of the best thermostat you can get. It work beeter than the OE dinasure type thermostat and better then most all aftermarket replacements. Your discription sounds like it is working properly.

It you go to STANT and resd how they work you will understand better.

You may want to consider what Steve is suggestion as far as tempreture varification is concerned. After all the gauge is controled by the senor and it value may be incorrect which would need you to replace the sensor.


Your last response is more inline with air flow which means fan related or radiator.
__________________

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP ASAP! weird Overheating problem 2001 PT ptptptpt Tech & Performance Forum 20 20 Dec 2015 10:14 pm
Grrrr!!! Weird overheating. GrapeApe Tech & Performance Forum 6 03 Feb 2015 03:07 pm
overheating weird problem... nor11384 Tech & Performance Forum 37 02 May 2013 07:35 pm
02 PT Cruiser Overheating (Very Weird issue) HDuece2 General PT Cruiser Discussions 19 12 Feb 2011 10:22 pm
Weird Problem JoeyC33 General PT Cruiser Discussions 5 06 Aug 2008 05:21 pm


All times are GMT -5. The time now is 04:21 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors