PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Fan/blower not blowing

 
Like Tree2Likes
  • 2 Post By j0e

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 31 May 2015, 12:21 pm
j0e j0e is offline
Cool Cruiser
 
Join Date: Aug 2012
Posts: 299
Default Fan/blower not blowing

So, with the warm weather really getting going the a/c has been struggling.
I think the hi/low on the fan isn't working properly.
But... today the vent blower just stopped.
Nothing is forced from the vents, but when a/c is on I can still feel coolness, just no blowing.
I tried every setting on the dial and nothing!
I'm probably gonna need to bring to mechanic, but any advice for DIY is appreciated.
Reply With Quote
  #2 (permalink)  
Old 31 May 2015, 12:38 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,309
Default Re: Fan/blower not blowing

You need to give us more information about your PT Cruiser.
What year?
How many miles?
Is the engine overheating?
Have you tried starting it up when its cold, turn on the A/C and see if the radiator fan automatically starts working?
Reply With Quote
  #3 (permalink)  
Old 31 May 2015, 01:06 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,344
Default Re: Fan/blower not blowing

Quote:
Originally Posted by j0e View Post
So, with the warm weather really getting going the a/c has been struggling.
I think the hi/low on the fan isn't working properly.
But... today the vent blower just stopped.
Nothing is forced from the vents, but when a/c is on I can still feel coolness, just no blowing.
I tried every setting on the dial and nothing!
I'm probably gonna need to bring to mechanic, but any advice for DIY is appreciated.
Quote:
Originally Posted by ptcruisersteve View Post
You need to give us more information about your PT Cruiser.
What year?
How many miles?
Is the engine overheating?
Have you tried starting it up when its cold, turn on the A/C and see if the radiator fan automatically starts working?
Even if the fan is working, no point in running A/C till blower is fixed.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #4 (permalink)  
Old 31 May 2015, 01:16 pm
j0e j0e is offline
Cool Cruiser
 
Join Date: Aug 2012
Posts: 299
Default Re: Fan/blower not blowing

Pt is an '05 with 95,000 miles.
The main fan issue that I think I have has been there for a bit but didn't matter with the cool weather.
It seems to only matter when a/c is running.

The blower issue is new.
Could it be a fuse or a relay?
Reply With Quote
  #5 (permalink)  
Old 31 May 2015, 01:35 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,344
Default Re: Fan/blower not blowing

Test your fan
New here....and a question
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #6 (permalink)  
Old 31 May 2015, 03:42 pm
j0e j0e is offline
Cool Cruiser
 
Join Date: Aug 2012
Posts: 299
Default Re: Fan/blower not blowing

^
Thanks for the link.
I remember reading that thread before. I'm going to try testing the fan.
I wish the blower was something easy.
Reply With Quote
  #7 (permalink)  
Old 31 May 2015, 04:09 pm
sanatanadharma's Avatar
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,070
Default Re: Fan/blower not blowing

Because Trump
__________________
Please refer to the forum guidelines for posting content

Last edited by sanatanadharma; 10 Nov 2016 at 06:11 pm.
Reply With Quote
  #8 (permalink)  
Old 31 May 2015, 05:49 pm
j0e j0e is offline
Cool Cruiser
 
Join Date: Aug 2012
Posts: 299
Default Re: Fan/blower not blowing

^
Ha! Right on, brother!
#7 is shot. En route for a new one.
Thanks!
Reply With Quote
  #9 (permalink)  
Old 31 May 2015, 06:55 pm
j0e j0e is offline
Cool Cruiser
 
Join Date: Aug 2012
Posts: 299
Default Re: Fan/blower not blowing

Well, new fuse popped, too!
Something's up with the blower.
I'm gonna check that resistor now if I can.
I think it's gotta go to a pro.
Any other ideas on it before I drop it off?
Reply With Quote
  #10 (permalink)  
Old 10 Jun 2015, 08:54 pm
j0e j0e is offline
Cool Cruiser
 
Join Date: Aug 2012
Posts: 299
Default Re: Fan/blower not blowing

Blower motor seized.
Put a new one in and I'm back in business.

I do want my a/c colder tho, so that's next.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C Blower Flow Noisy! rcalzadilla General PT Cruiser Discussions 12 26 Jun 2014 12:03 pm
a/c blower fan issue dadjmon General PT Cruiser Discussions 10 16 Sep 2012 02:45 am
Fake blower motor? GuruCruiser Exterior Accessories Forum 3 27 Apr 2012 07:20 am
Blower motor journalist1947 General PT Cruiser Discussions 6 21 Sep 2009 10:35 pm
Need help with my civics blower motor 85_305 Tech & Performance Forum 12 25 Aug 2009 07:14 pm


All times are GMT -5. The time now is 11:54 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors